Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: SF bei CPU verschwindet nicht mehr

  1. #1
    Registriert seit
    23.11.2012
    Ort
    Österreich
    Beiträge
    147
    Danke
    48
    Erhielt 19 Danke für 19 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Jungs,

    habe ein sehr kurioses Problem bei einer S7 317F-2 DP. Die LED für einen SF verschwindet nicht mehr.

    kurz zur Geschichte,

    Habe im Juli einen DB erstellt und ein paar Bit's, Wörter und DWörter definiert. Das Bit 0.0 und das Wort 2 wurden verwendet, habe
    aber vorher vergessen den DB rein zu spielen. Es wurde dann der OB121 aufgerufen und die SF-LED leuchtete auf.
    Ich spielte dann DB sofort in die CPU und dachte mir, dass es damit getan sei. Leider leuchtete die SF-LED immer noch.
    Ich habe dann den DB und seine Zuweisung gelöscht, also auf den letzten Stand gebracht bevor der Fehler auftrat, hat leider
    auch nicht geholfen.

    Mittlerweile habe ich meine Programmierung wieder reingespielt. Läuft super und der OB121 wird auch nicht aufgerufen, habe aber
    immer noch den SF-Fehler.
    Im Diagnosepuffer steht allerdings, dass dieser DB nicht geladen ist und das ich einen Bereichslängenfehler beim schreiben habe (mit dem Datum vom Juli). OB100 ist vorhanden.


    Vielleicht kann mir einer sagen wie ich die LED aus kriege, ohne die CPU auszuschalten.

    gruss
    Kapo
    Zitieren Zitieren SF bei CPU verschwindet nicht mehr  

  2. #2
    Registriert seit
    12.09.2013
    Beiträge
    24
    Danke
    8
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Neustarten der SPS also einmal von RUN auf STOP und wieder zurück.

  3. #3
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.622
    Danke
    377
    Erhielt 799 Danke für 642 Beiträge

    Standard

    Kannst du den Diagnose Puffer hier posten ?
    Jesper M. Pedersen

  4. #4
    Registriert seit
    25.11.2008
    Ort
    Westpfalz
    Beiträge
    1.550
    Danke
    187
    Erhielt 212 Danke für 186 Beiträge

    Standard

    Zitat Zitat von kapo666 Beitrag anzeigen
    Ich spielte dann DB sofort in die CPU und dachte mir, dass es damit getan sei. Leider leuchtete die SF-LED immer noch.
    Ich habe dann den DB und seine Zuweisung gelöscht, also auf den letzten Stand gebracht bevor der Fehler auftrat, hat leider
    auch nicht geholfen.

    Mittlerweile habe ich meine Programmierung wieder reingespielt. Läuft super und der OB121 wird auch nicht aufgerufen, habe aber
    immer noch den SF-Fehler.
    Im Diagnosepuffer steht allerdings, dass dieser DB nicht geladen ist und das ich einen Bereichslängenfehler beim schreiben habe (mit dem Datum vom Juli). OB100 ist vorhanden.
    Vielleicht braucht es hier ein "Gehen Ereignis", dazu müsstest du den DB wenn er drin ist nochmal aufrufen.
    Oder eben die CPU neu starten.
    and we all support the team (S.King - Die Arena)

  5. #5
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.166
    Danke
    921
    Erhielt 3.286 Danke für 2.655 Beiträge

    Standard

    Daß die SF-LED nach Programmierfehlern aktiv bleibt und erst beim nächsten Stop/Run ausgeht kenne ich auch von anderen S7-300-CPU. Ich würde dieses Verhalten als normal bezeichnen.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  6. Folgende 2 Benutzer sagen Danke zu PN/DP für den nützlichen Beitrag:

    ducati (17.09.2013),kapo666 (18.09.2013)

  7. #6
    kapo666 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    23.11.2012
    Ort
    Österreich
    Beiträge
    147
    Danke
    48
    Erhielt 19 Danke für 19 Beiträge

    Standard

    Der DB ist geladen und wird in einem Baustein aufgerufen (Bit 0.0), es kommt aber kein gehen Ereigniss.

    Die Anlage fährt 24h/7T durch, dadurch gestaltet sich das Stop/Start schalten etwas schwierig. Ich dachte mir, dass es vielleicht einen
    Trick gibt wie ich die LED weg bekomme.

    Habe hier einen Auszug aus dem Puffer und danke für eure Hilfe.

    Code:
    Diagnosepuffer der Baugruppe CPU 317F-2 DP
    
    Bestell-Nr./ Bezeichn.        	Komponente                    	Ausgabestand                  
    6ES7 317-6FF03-0AB0           	Hardware                      	2                             
    - - -                         	Firmware                      	V 2.6.5                       
    Boot Loader                   	Firmware-Erweiterung          	A 10.13.9                     
    
    Baugruppenträger:             	0
    Steckplatz:                   	2
    
    
    Ereignis 1 von 10:  Ereignis-ID 16# 2523
    Bereichslängenfehler beim Schreiben 
    Global -DB ,Bitzugriff, Zugriffsadresse:      0
    Angeforderter OB: Programmierfehler-OB (OB 121)
    Prioritätsklasse:  1
    interner Fehler, kommendes Ereignis
    09:16:28.628  02.07.2013
    (Kodierung: 16# 2523  0179  0004  0000  0000  0000)
    
    
    Ereignis 2 von 10:  Ereignis-ID 16# 253A
    DB nicht geladen 
    DB-Nummer:    522
    Angeforderter OB: Programmierfehler-OB (OB 121)
    Prioritätsklasse:  1
    interner Fehler, kommendes Ereignis
    09:16:28.628  02.07.2013
    (Kodierung: 16# 253A  0179  007A  020A  0000  0000)
    
    
    Ereignis 3 von 10:  Ereignis-ID 16# 2523
    Bereichslängenfehler beim Schreiben 
    Global -DB , Wortzugriff, Zugriffsadresse:      2
    Angeforderter OB: Programmierfehler-OB (OB 121)
    Prioritätsklasse:  1
    interner Fehler, kommendes Ereignis
    09:16:28.628  02.07.2013
    (Kodierung: 16# 2523  0179  0024  0002  0000  0000)
    
    
    Ereignis 4 von 10:  Ereignis-ID 16# 253A
    DB nicht geladen 
    DB-Nummer:    522
    Angeforderter OB: Programmierfehler-OB (OB 121)
    Prioritätsklasse:  1
    interner Fehler, kommendes Ereignis
    09:16:28.628  02.07.2013
    (Kodierung: 16# 253A  0179  007A  020A  0000  0000)
    
    
    Ereignis 5 von 10:  Ereignis-ID 16# 2523
    Bereichslängenfehler beim Schreiben 
    Global -DB ,Bitzugriff, Zugriffsadresse:      0
    Angeforderter OB: Programmierfehler-OB (OB 121)
    Prioritätsklasse:  1
    interner Fehler, kommendes Ereignis
    09:16:28.614  02.07.2013
    (Kodierung: 16# 2523  0179  0004  0000  0000  0000)
    
    
    Ereignis 6 von 10:  Ereignis-ID 16# 253A
    DB nicht geladen 
    DB-Nummer:    522
    Angeforderter OB: Programmierfehler-OB (OB 121)
    Prioritätsklasse:  1
    interner Fehler, kommendes Ereignis
    09:16:28.613  02.07.2013
    (Kodierung: 16# 253A  0179  007A  020A  0000  0000)
    
    
    Ereignis 7 von 10:  Ereignis-ID 16# 2523
    Bereichslängenfehler beim Schreiben 
    Global -DB , Wortzugriff, Zugriffsadresse:      2
    Angeforderter OB: Programmierfehler-OB (OB 121)
    Prioritätsklasse:  1
    interner Fehler, kommendes Ereignis
    09:16:28.613  02.07.2013
    (Kodierung: 16# 2523  0179  0024  0002  0000  0000)
    
    
    Ereignis 8 von 10:  Ereignis-ID 16# 253A
    DB nicht geladen 
    DB-Nummer:    522
    Angeforderter OB: Programmierfehler-OB (OB 121)
    Prioritätsklasse:  1
    interner Fehler, kommendes Ereignis
    09:16:28.613  02.07.2013
    (Kodierung: 16# 253A  0179  007A  020A  0000  0000)
    
    
    Ereignis 9 von 10:  Ereignis-ID 16# 2523
    Bereichslängenfehler beim Schreiben 
    Global -DB ,Bitzugriff, Zugriffsadresse:      0
    Angeforderter OB: Programmierfehler-OB (OB 121)
    Prioritätsklasse:  1
    interner Fehler, kommendes Ereignis
    09:16:28.606  02.07.2013
    (Kodierung: 16# 2523  0179  0004  0000  0000  0000)
    
    
    Ereignis 10 von 10:  Ereignis-ID 16# 253A
    DB nicht geladen 
    DB-Nummer:    522
    Angeforderter OB: Programmierfehler-OB (OB 121)
    Prioritätsklasse:  1
    interner Fehler, kommendes Ereignis
    09:16:28.606  02.07.2013

  8. #7
    Registriert seit
    25.11.2008
    Ort
    Westpfalz
    Beiträge
    1.550
    Danke
    187
    Erhielt 212 Danke für 186 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von PN/DP Beitrag anzeigen
    Daß die SF-LED nach Programmierfehlern aktiv bleibt und erst beim nächsten Stop/Run ausgeht kenne ich auch von anderen S7-300-CPU. Ich würde dieses Verhalten als normal bezeichnen.

    Harald
    Bevor hier weiter Glückwünsche verteilt werden muss ich dem etwas wiedersprechen.
    Mag sein dass es nicht für alle CPUs gilt, aber ein identischer Test mit einer 315F-2DP hat ergeben,
    dass die SF-LED sehr wohl beim Einspielen des DB als auch beim Löschen des fehlerhaften Aufrufs aus geht.
    Ein gehend Ereignis wird im Diagnosepuffer dabei nicht angezeigt.


    Diagnosepuffer der Baugruppe CPU 315F-2 DP

    Bestell-Nr./ Bezeichn. Komponente Ausgabestand
    6ES7 315-6FF01-0AB0 Hardware 6
    - - - Firmware V 2.0.12

    Baugruppenträger: 0
    Steckplatz: 2


    Ereignis 1 von 10: Ereignis-ID 16# 2523
    Bereichslängenfehler beim Schreiben
    Global -DB ,Bitzugriff, Zugriffsadresse: 0
    Angeforderter OB: Programmierfehler-OB (OB 121)
    Prioritätsklasse: 1
    interner Fehler, kommendes Ereignis
    00:47:56.256 22.08.1998
    (Kodierung: 16# 2523 0179 0004 0000 0000 0000)


    Ereignis 2 von 10: Ereignis-ID 16# 253A
    DB nicht geladen
    DB-Nummer: 10
    Angeforderter OB: Programmierfehler-OB (OB 121)
    Prioritätsklasse: 1
    interner Fehler, kommendes Ereignis
    00:47:56.255 22.08.1998
    (Kodierung: 16# 253A 0179 007A 000A 0000 0000)

    Gab ja schon öfter mal bei der 315er mit FW 2.x Probleme, vielleicht eben auch bei der 317er, zumindest ein Update gibt es.

    MfG Mäuseklavier
    and we all support the team (S.King - Die Arena)

  9. Folgender Benutzer sagt Danke zu Sinix für den nützlichen Beitrag:

    kapo666 (18.09.2013)

Ähnliche Themen

  1. CPU 315-2PN/DP reagiert nicht mehr auf PING
    Von rrauch im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 07.12.2010, 10:44
  2. Antworten: 13
    Letzter Beitrag: 22.10.2010, 22:22
  3. S7-400H Reserve-CPU fährt nicht mehr hoch
    Von MandiNice im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 27.03.2009, 21:35
  4. Antworten: 5
    Letzter Beitrag: 17.07.2008, 19:46
  5. Antworten: 3
    Letzter Beitrag: 16.05.2008, 09:12

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •