Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: Problem mit den Ausgängen

  1. #1
    Registriert seit
    29.05.2013
    Beiträge
    353
    Danke
    74
    Erhielt 3 Danke für 3 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich habe jetzt einen FB fertig programmiert. Wenn der Enable-Eingang true ist, fährt der Regelschieber entweder auf oder zu. Bis dahin läuft er korrekt. Wenn ich jetz aber den Enable-Eingang auf false setze, bleibt der alte Ausgang, also der letztmalig true war, aktiv. Das verstehe ich jetzt nicht. Warum macht er das? Warum wird der Ausgang nicht false, sobald der FB auf false ist?

    Gruß
    Zitieren Zitieren Problem mit den Ausgängen  

  2. #2
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.733
    Danke
    317
    Erhielt 1.522 Danke für 1.283 Beiträge

    Standard

    Mit EN = FALSE wird der Bausteinaufruf übersprungen, und somit angehängte Variablen nicht mehr beschrieben,
    folglich bleiben diese, da das PAW auch "nur" ein Speicher ist, so wie sie eben zuletzt beschrieben wurden,
    selbiges gilt auch für die Inhalte des IDB.

    Ergo: Mit Enable ist dein gewünschtes Verhalten ganz und gar unmöglich, und auch nicht wirklich glücklich, bezogen auf die Gesamtfunktionalität.

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  3. Folgender Benutzer sagt Danke zu MSB für den nützlichen Beitrag:

    kuti (29.09.2013)

  4. #3
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.717
    Danke
    443
    Erhielt 919 Danke für 740 Beiträge

    Standard

    Weil der FB nicht bearbeitet und damit am Ausgang nichts verändert wird.

    Wenn Du den Fernseher an machst und dann aus dem Zimmer gehst, bleibt er doch auch an, auch wenn Du nicht mehr hinsiehst.

  5. Folgender Benutzer sagt Danke zu hucki für den nützlichen Beitrag:

    kuti (29.09.2013)

  6. #4
    kuti ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    29.05.2013
    Beiträge
    353
    Danke
    74
    Erhielt 3 Danke für 3 Beiträge

    Standard

    Habe ich mir fast gedacht. Tja, dann muss ich mir irgendwie anders helfen.

  7. #5
    Registriert seit
    13.09.2010
    Beiträge
    2.292
    Danke
    178
    Erhielt 375 Danke für 355 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    .
    Du solltest die Stop-Bedingung für den Regelschieber
    im FB programmieren und diesen auch dauernd aufrufen.
    Oder ihn an anderer Stelle rüchsetzen (aber unschön).
    Mit "Enable" frierst du nur den letzten Zustand ein.
    kind regards
    SoftMachine

Ähnliche Themen

  1. Antworten: 13
    Letzter Beitrag: 04.03.2013, 08:34
  2. Antworten: 8
    Letzter Beitrag: 30.11.2009, 15:28
  3. Problem mit den eingebenen Zeitwert
    Von rasima im Forum Simatic
    Antworten: 14
    Letzter Beitrag: 22.09.2008, 18:37
  4. S7 - 300 Problem mit Ausgängen
    Von spower im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 11.06.2008, 18:40
  5. Eine Frage zu den digitalen Ausgängen
    Von pinolino im Forum Simatic
    Antworten: 17
    Letzter Beitrag: 02.12.2007, 11:32

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •