Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 22

Thema: IP Adresse ändern

  1. #11
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.192
    Danke
    925
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Router neu gestartet? Computer neu gestartet?

    - versuchsweise mal die 1212C an einen anderen LAN-Port am Router stecken
    - Welcher Bereich ist im Router für DHCP eingestellt? Den Bereich so einschränken, daß die 1.199 außerhalb liegt, z.B. 192.168.1.20 bis .99
    - Desktop-Firewall im Computer ausschalten
    - Geht Ping auf die neue oder alte IP-Adresse der 1212C? Wenn nein: Sieht man den Ping an der Netzwerk-LED der 1212C oder am LAN-Port des Routers?
    - Kommst Du auf den Webserver der 1212C drauf (unter neuer oder alter Adresse)? dort kannst Du die CPU in Run schalten

    Wie/Womit hast Du die IP-Adresse geändert? Geht das vielleicht nochmal bzw. findet das Tool die SPS wieder?

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  2. #12
    kiar ist gerade online Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.12.2011
    Ort
    Tor zum Harz
    Beiträge
    189
    Danke
    31
    Erhielt 28 Danke für 27 Beiträge

    Standard

    Zitat Zitat von PN/DP Beitrag anzeigen
    Router neu gestartet? Computer neu gestartet?


    Harald
    Hallo Harald,
    habe ich so gemacht.

    Werde jetzt mal die anderen Möglichkeiten probieren, welche Du mir aufgezeigt hast.

    melde mich danach wieder.

    Danke Raik

    PS wohl schlechtes Wetter auf Rügen
    nochmals Danke

  3. #13
    kiar ist gerade online Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.12.2011
    Ort
    Tor zum Harz
    Beiträge
    189
    Danke
    31
    Erhielt 28 Danke für 27 Beiträge

    Standard

    Hallo,

    habe es jetzt so gemacht, auf meinem zweitem Laptop das Programm von JooB installiert und dann hatte ich Zugriff auf die CPU. Die hatte gar keine IP Adresse
    Na alle Einstellung gemacht und schon konnte ich darauf zugreifen. Leider lässt Sie sich noch nicht in den RUN schicken, aber das ist erstmal ein anderes Problem.


    Dank an Euch beiden

    Raik

  4. #14
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.192
    Danke
    925
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Vermutlich werden zukünftig weitere Anfänger diesen Thread lesen auf der Suche, wie man denn die IP einer S7-1200 ändert. Einige werden sich dann vielleicht erinnern, daß mit "das Programm von JooB" das Primary Setup Tool (PST) gemeint ist.
    Nur schade, daß kiar nicht schreibt, was er gemacht hat wodurch die IP-Adresse in der CPU gelöscht wurde ... dadurch wissen die Suchenden leider nicht, was man auf jeden Fall vermeiden sollte. Diese Gefahr schwebt also noch ...

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  5. #15
    kiar ist gerade online Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.12.2011
    Ort
    Tor zum Harz
    Beiträge
    189
    Danke
    31
    Erhielt 28 Danke für 27 Beiträge

    Standard

    Manöverkritik

    Ich kann Dir ehrlich nicht sagen, wie es passieren konnte. Ich kann es mir nur so erklären, das ich beim rücksetzen auf Werkseinstellung die IP 0.0.0.0 stehen hatte.
    Aber Du hast sicherlich Verständnis, das ich es nicht versuche dies zu reproduzieren.

    raik

  6. #16
    Registriert seit
    29.04.2012
    Beiträge
    195
    Danke
    13
    Erhielt 42 Danke für 37 Beiträge

    Standard

    Ich denke du hast eine Mischung aus zwei Themen.
    Fassen wir mal zusammen:

    1. "Erreichbare Teilnehmer" ist ein Layer 2 Ethernet Multicast. Das geht per Definition niemals über einen Router hinweg.
    > Routet dein Netgear wirklich zwischen WLAN und LAN?
    >> Dann müssen die Subnetze WLAN-LAN unterschiedlich sein?

    >> Wenn nicht, ist die nächste Frage, ob dein Router Layer 2 Multicasts auf dem WLAN auch ins LAN verschickt. Nicht alle WLAN-LAN Bridges tun das.

    2. Falls wirklich (und richtig) geroutet wird, dann braucht dein PC kein zusätzliche IP. Es darf sogar keine vergeben werden - damit entsteht sofort ein Problem.
    Knackpunkt ist, ob du im TIA Portal "Subnetz X" oder "Direkt an Port XY" wählst. Hat die CPU in ein anderes Subnetz als die Netzwerkkarte und ist "Direkt an Port XY" ausgewählt, so wird eine zusätzlich IP angelegt.

    Negativbeispiel:
    Router: 192.168.1.1. und 192.168.2.1.
    PC: 192.168.1.2. Router 192.168.1.1.
    CPU: 192.168.2.2. Router 192.168.2.1.

    Die CPU wäre erreichbar. Wird aber "Direkt an Port XY" ausgewählt, setzt TIA ein zusätzlich IP aus 192.168.2.x.
    > Für den PC ist das Subnetz 192.168.2.x damit lokal und es wird nicht mehr über den (funktionierenden) Router 192.168.1.1. angesprochen. Es geht nichts, bis die zusätzlich IP gelöscht wurde.

    BTW: Klassik beherrscht das auch mit der "TCP/IP Auto" Funktion.

    Für mich persönlich ist etwas faul, sobald Step7 eine zusätzlich IP vegeben möchte. Anderenfalls muss man sich über die Konsequenzen im Klaren sein.

  7. Folgender Benutzer sagt Danke zu Pipboy für den nützlichen Beitrag:

    PN/DP (06.10.2013)

  8. #17
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.192
    Danke
    925
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Sein Home-Router (Netgear) behandelt das WLAN und die LAN-Ports als das selbe Subnetz - "routen" zwischen den Teilnehmern ist nicht nötig.
    Anscheinend bildet er adhoc weitere lokale Netze, wenn er am WLAN und an den LAN-Ports Teilnehmer mit zueinander "passenden" IP findet und stellt ihre Telegramme gegenseitig direkt zu. Anders kann ich mir nicht erklären, wieso die Kommunikation zur CPU funktionierte, als diese noch die 192.168.0.1 hatte.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  9. #18
    kiar ist gerade online Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.12.2011
    Ort
    Tor zum Harz
    Beiträge
    189
    Danke
    31
    Erhielt 28 Danke für 27 Beiträge

    Standard

    Moin,

    so wie Pipboy oben als Negativbeispiel beschrieben hat, ist meine Situation.

    PC hat 192.168.1.2
    Router 192.168.1.1
    CPU hat 192.168.0.1

    als ich jetzt versucht habe auf die CPU zu kommen wurde von Tia eine weitere IP vergeben, die war dann 192.168.0.254. Es wurde auch nachgefragt, dann wurde ein Programm von Siemens gestartet. Leider habe ich einfach auf weiter gedrückt ohne zu schauen was es für ein Programm ist und was es macht. Jedenfalls hatte ich dann Zugriff auf die CPU.

    Dann wollte ich ich der CPU eine IP mit 192.168.1.xxx geben und muss dann, aus Unwissenheit, die Anlage zurückgesetzt haben, mit der IP 0.0.0.0.
    Vielleicht ist es noch interessant zu erwähnen, das ich TIA in Win 8 laufen lasse. Ich habe aber bisher keine Probleme oder Abstürze, sicherlich auch deshalb, weil ich bloß einfache Sachen gemacht habe

    Raik

  10. #19
    Registriert seit
    06.12.2006
    Beiträge
    52
    Danke
    7
    Erhielt 5 Danke für 5 Beiträge

    Standard

    Ich habe ein ähnliches Phänomen.
    CPU,Basic-Panel und ein Feldbusgateway hängen an einem Siemens Switch. Alle im gleichen IP-Adressraum. Ich kann auf die CPU und auf das Terminal pingen. Ich kann auch das Projekt auf CPU 1200 und auf das Panel übertragen. Beobachten auf der CPU funktioniert auch. Nur zum Panel kann ich mich nicht online Verbinden. Wlan ist nicht im Spiel. Erreichbare Teilnehmer ist auch fehlanzeige. Es funktionierte aber im Projekt schonmal. Ich bin ratlos.

  11. #20
    Registriert seit
    24.10.2007
    Ort
    Niederlande
    Beiträge
    673
    Danke
    22
    Erhielt 143 Danke für 135 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Habe Sie in das Basic Panel auch das IP Adresse eingegeben? Sie musse das adresse in WinCC eingeben und auch in dass Panel . Nach starten panel control panel drucken, Profinet, IP adresse eingeben, unter Device eventuel ein Name eingeben , bei TIA konte Sie auch ein Time server eingeben ( auf ein neu gerad geht dass auch ,aber wenn Sie ein WinCC flex in dass Panel load ist Dass tabblad mit die Time server weg.

    Joop

Ähnliche Themen

  1. TIA S7-3xxC PN IP-Adresse ändern
    Von superkato im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 01.06.2013, 19:03
  2. IP - Adresse ändern
    Von Knister im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 26.11.2012, 20:20
  3. IP-Adresse ändern
    Von ka1978 im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 07.10.2012, 13:33
  4. BC9000 IP-Adresse ändern
    Von cas im Forum CODESYS und IEC61131
    Antworten: 8
    Letzter Beitrag: 25.02.2010, 07:13
  5. S5 Profibus Adresse ändern
    Von ditschio im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 18.04.2009, 19:18

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •