Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 14

Thema: Korrekturwert für Temperatur erstellen

  1. #1
    Registriert seit
    25.11.2012
    Beiträge
    9
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo habe ein Problem.
    habe bei meiner Steuerung S7 315 die Temperaturen soweit visualisiert bekommen, aber die Anzeige auf meinem TP177B zeigt ca 2 Grad zuviel an.
    Wie bekomme ich einen Korrekturwert von - 2 Grad hin.
    Vielen Dank im vorraus.
    Zitieren Zitieren Korrekturwert für Temperatur erstellen  

  2. #2
    Registriert seit
    09.08.2006
    Beiträge
    3.627
    Danke
    912
    Erhielt 656 Danke für 542 Beiträge

    Standard

    naja, es ist jetzt schwierig, zu verstehen, was Du gemacht hast und warum die Abweichung auftritt... Tritt die Abweichung auch in der SPS auf oder hast Du ne Abweichung zwischen Wert in der SPS und de Anzeige auf dem Panel?

    Wenn die Abweichung auch in der SPS auftitt, dann würde ich auch dort den Wert korrigieren bzw. schauen, ob ich bei der Scalierung keinen Fehler gemacht habe.
    Wenn Die Abweichung zwischen SPS und Panel auftritt, hast Du dort einen Fehler gemacht.

    Gruß.

  3. #3
    Kralle2006 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    25.11.2012
    Beiträge
    9
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Der Wert in der Variablentabelle beträgt 228 Dezimal , auf dem Panel 22,8 Grad.
    Die Umrechnug scheint richtig zu sein.

    Grüße

  4. #4
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.181
    Danke
    923
    Erhielt 3.289 Danke für 2.658 Beiträge

    Standard

    Woher kommen die Temperaturen? PT100 mit langen Anschlußleitungen womöglich nur in 2-Draht angeschlossen?
    Dann sollte man direkt am Fühler die Temperaturanzeige mit einem (geeichten) Thermometer vergleichen und bei/nach dem Einlesen und ggf. Skalierung einen entsprechenden Korrekturwert verrechnen.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  5. #5
    Kralle2006 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    25.11.2012
    Beiträge
    9
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Das will ich ja auch machen, nur ich bin Neuling.
    Der Temperaturwert vom geeichtem Thermometer liegt ziemlich genau 2 Grad unter der Temperatur der SPS.
    Ja ich verwende PT 100 mit 2-Draht aber mit Brücken im 4-Draht angeschlossen.

    Habe es bisher so gemacht.

    Beispiel:

    L PEW256
    DTR
    T DB15.DBD6

    Ralf
    Geändert von Kralle2006 (08.10.2013 um 12:14 Uhr)

  6. #6
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.850
    Danke
    78
    Erhielt 800 Danke für 543 Beiträge

    Standard

    L pew256
    dtr
    l 2.0
    -r
    t db15.dbd6
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  7. Folgender Benutzer sagt Danke zu volker für den nützlichen Beitrag:

    Kralle2006 (08.10.2013)

  8. #7
    Registriert seit
    03.12.2009
    Beiträge
    64
    Danke
    1
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Hallo,

    PT100 ist eine Widerstandsmessung. Je nach Länge der Leitung ergibt sich ein Fehler, da die Leitung selbst ja schon einen Widerstand hat. Du hast nur 2 Adern angeschlossen, also wirst Du einen falschen Wert messen. Der zusätzliche Widerstand wird von der SPS als höhere Temperatur erkannt, deshalb hast Du 2 Grad mehr in der Anzeige. Das Gute ist, der Widerstand der Leitung ist konstant, der Strom ist sowieso konstant, also ist auch Dein Fehler konstant, ziehe also die 2 Grad ab und Du bist fertig.

    Gruss

    Oliver

  9. Folgender Benutzer sagt Danke zu extruder_luder für den nützlichen Beitrag:

    Kralle2006 (08.10.2013)

  10. #8
    Registriert seit
    15.04.2009
    Ort
    Nordsachsen
    Beiträge
    252
    Danke
    171
    Erhielt 105 Danke für 97 Beiträge

    Standard

    Zitat Zitat von volker Beitrag anzeigen
    L pew256
    dtr
    l 2.0
    -r
    t db15.dbd6
    Da der eingelesene Wert scheinbar erst im Panel normiert wird, sollte 20.0 (2.0 * 10) abgezogen werden.

    Ralph

  11. Folgender Benutzer sagt Danke zu RGerlach für den nützlichen Beitrag:

    Kralle2006 (08.10.2013)

  12. #9
    Registriert seit
    09.08.2006
    Beiträge
    3.627
    Danke
    912
    Erhielt 656 Danke für 542 Beiträge

    Standard

    Zitat Zitat von Kralle2006 Beitrag anzeigen
    Ja ich verwende PT 100 mit 2-Draht aber mit Brücken im 4-Draht angeschlossen.
    Wo Sind denn die Brücken? Am Sensor oder erst an der AI-Karte?

    -> 4 Adern bis zum Sensor ziehen und dort jeweils 2 Adern auf eine Sensorklemme!

    Evtl. hättest Du dann auch schon weniger Abweichungen. Auf jeden Fall würdest Du es dann richtig machen. Zur Korrektur, siehe die Aussagen der Kollegen.

    Gruß.

  13. Folgender Benutzer sagt Danke zu ducati für den nützlichen Beitrag:

    Kralle2006 (08.10.2013)

  14. #10
    Kralle2006 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    25.11.2012
    Beiträge
    9
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Vielen Dank für eure Hilfe, hat super geklappt.
    Messwerte sind jetzt syncron, habe es noch etwas erweitert.
    Habe DB's angelegt wo ich jetzt Korrekturwerte mittels Panel verändern kann.

    Ralf

Ähnliche Themen

  1. Temperatur, Feuchte Sensor für Home Bereich
    Von babylon05 im Forum Elektronik
    Antworten: 4
    Letzter Beitrag: 27.04.2011, 09:36
  2. Antworten: 35
    Letzter Beitrag: 19.07.2008, 14:16
  3. Rollenhebelendschalter für hohe Temperatur
    Von Lipperlandstern im Forum Schaltschrankbau
    Antworten: 4
    Letzter Beitrag: 05.06.2008, 11:35
  4. String für Meldungen erstellen
    Von Bööscher im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 17.11.2007, 17:58
  5. Temperatur Differenz steurung für Siemens logo
    Von Anonymous im Forum Sonstige Steuerungen
    Antworten: 1
    Letzter Beitrag: 20.01.2005, 14:50

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •