Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 16

Thema: OS in KoKo laden

  1. #1
    Registriert seit
    20.04.2010
    Beiträge
    65
    Danke
    17
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo liebe Forenmitglieder,
    oft schon konntet ihr mir helfen so hoffentlich auch bei diesem Problem.
    Ich habe auf einer virtuellen Maschine Windows 2008 R2 Server sowie Step7 5.5, WinCC 7.2 und Simatic.Net 8.2 installiert.
    Nun habe ich in einem Projekt eine Steuerung sowie eine PC-Station, da am Ende beides über ein herkömmliches Ethernet mit einander kommunizieren soll.
    Dazu habe ich mir in der PC-Station auf Position 1 eine IE-Allgemein (mit entsprechneder IP) und auf Position 2 eine WinCC Appl konfiguriert. Das ganze wollte ich dann übersetzen, sodass es in den KoKo eingetragen wird (Stationsnamen sind bei Step7 sowie dem KoKo identisch und PG/PC Schnittstelle ist auf "internal" gesetzt).
    Alles startet ohne Probleme bis die WinCC Appl übertragen werden soll, da sagt er mir dann, dass er keine Verbindung herstellen konnte. Das Ergebnis ist somit, dass lediglich der IE Adapter sowie der Stationsmanager eingetragen ist.
    Eine weiter mir unverständliche Angelegenheit ist, dass ich auch manuell im KoKo nichts "Hinzufügen" kann, da diese Postion ausgegraut ist (der KoKo ist online). Auch das Importieren über die XDB Dateien führt zu einem Fehler, der mir dann sagt, dass diese Komponente nicht installiert ist.

    Hat da irgend jemand einen Hinweis und kann mir helfen?
    Vielen Dank für eure Hilfe!
    Zitieren Zitieren OS in KoKo laden  

  2. #2
    Registriert seit
    09.08.2006
    Beiträge
    3.627
    Danke
    912
    Erhielt 656 Danke für 542 Beiträge

    Standard

    Ist das ne Testumgebung oder soll später alles in der Anlage unter der VM funktionieren.

    der KOKO macht oft Probleme. Wenn Du ihn nicht unbedingt benötigst, lass ihn weg!

    Also IP Adresse unter Windows vergeben, PG/PC Schnittstelle auf S7ONLINE, SimaticNet PC konfigurieren alles auf PG-Betrieb und beim Zugangspunkt S7Online die richtige virtuelle Netzwerkkarte auswählen. Die andere virt. Netzwerkkarte (Du brauchst mind. 2) in der Simatic Shell als Terminalbus einstellen. in WinCC im Variablenhaushalt S7Online auswählen.

    den KOKO kannst Du frei lassen, bzw. sogar aus dem Autostart entfernen.

    fertig

  3. Folgender Benutzer sagt Danke zu ducati für den nützlichen Beitrag:

    motamas (16.10.2013)

  4. #3
    Registriert seit
    13.07.2011
    Ort
    nähe Köln
    Beiträge
    173
    Danke
    25
    Erhielt 38 Danke für 25 Beiträge

    Standard

    Du solltest prüfen ob beim OS übersetzen deines Projektes die richtige Verbindug ausgewählt wurde.
    Und du solltest im Win CC Projekt die Systemparameter deines Variablenhaushalts mal überprüfen (in deinem Fall TCP IP)

  5. #4
    Registriert seit
    09.08.2006
    Beiträge
    3.627
    Danke
    912
    Erhielt 656 Danke für 542 Beiträge

    Standard

    Zitat Zitat von Larzerus Beitrag anzeigen
    Du solltest prüfen ob beim OS übersetzen deines Projektes die richtige Verbindug ausgewählt wurde.
    Und du solltest im Win CC Projekt die Systemparameter deines Variablenhaushalts mal überprüfen (in deinem Fall TCP IP)
    Was hat das damit zu tun, dass er den Koko nicht laden kann?

  6. #5
    Registriert seit
    25.03.2012
    Beiträge
    314
    Danke
    60
    Erhielt 9 Danke für 8 Beiträge

    Standard

    Zitat Zitat von ducati Beitrag anzeigen
    den KOKO kannst Du frei lassen, bzw. sogar aus dem Autostart entfernen.
    Heisst das, man kann PCS7 ohne Koko zum laufen kriegen ?
    We must all suffer from one of two pains: the pain of discipline or the pain of regret. The difference is discipline weighs ounces while regret weighs tons.

  7. #6
    Registriert seit
    09.08.2006
    Beiträge
    3.627
    Danke
    912
    Erhielt 656 Danke für 542 Beiträge

    Standard

    Zitat Zitat von Flux Beitrag anzeigen
    Heisst das, man kann PCS7 ohne Koko zum laufen kriegen ?
    In dem Thread hier geht's ja nicht um PCS7. Sondern so wie ich es verstanden habe, um eine Testumgebung in einer VM mit Step7 und WinCC! Auf dieser Annahme beruht die Empfehlung.

    Ob es Sinn macht, PCS7 ohne Koko zu betreiben, muss man im Einzelfall entscheiden.

    Die Frage stellt sich immer wieder, wofür ist der Koko zwingend notwendig... Ich vermute, wenn Du "Named Connections" zwischen SPS und Visu-Server verwenden willst/musst brauchst Du den Koko, zumindest auf dem Server. Für reine TCPIP oder ISO Verbindung brauchst Du ihn eigentlich nicht, dann musst Du aber die ganzen Zugangspunkte auf den verschiedenen PCs händisch am jeweiligen PC konfigurieren. Der Vorteil am Koko ist ja, dass Du ihn von der ES auf alle anderen Rechner laden kannst, also theoretisch musst Du bei Änderungen nicht zu jedem Rechner laufen...

    naja, Koko ist nen leidiges Thema.

    Ansonsten gibt's halt noch H-CPUs, IE-CPs im Rechner, redundante Server, redundanter Anlagenbus, OPC-Server, Soft-SPS usw. welche dieser Dinge zwingend den Koko voraussetzt, weiss vermutlich niemand so genau...

    soviel Dazu, aber eigentlich alles OT.

    Gruß.
    Geändert von ducati (15.10.2013 um 09:24 Uhr)

  8. #7
    Registriert seit
    13.07.2011
    Ort
    nähe Köln
    Beiträge
    173
    Danke
    25
    Erhielt 38 Danke für 25 Beiträge

    Standard

    Zitat Zitat von ducati Beitrag anzeigen
    Was hat das damit zu tun, dass er den Koko nicht laden kann?
    Ich hatte die Fragestellung falsch verstanden.

  9. #8
    Registriert seit
    20.04.2010
    Beiträge
    65
    Danke
    17
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Erst einmal vielen dank für die schnellen antworten.

    Es sieht so aus, dass das WinCC in der VMware laufen soll und mit einer SPS über Ethernet kommunizieren soll. Dabei sollen named connections verwendet werden und somit sollte der KoKo leider benötigt werden.
    Das Thema mit der zweiten Netzwerkkarte hattest du als Alternative zum KoKo gesehen oder brauche ich generell zwei Schnittstellen?

    Danke für weitere Hilfe.

  10. #9
    Registriert seit
    09.08.2006
    Beiträge
    3.627
    Danke
    912
    Erhielt 656 Danke für 542 Beiträge

    Standard

    Zitat Zitat von motamas Beitrag anzeigen
    Es sieht so aus, dass das WinCC in der VMware laufen soll und mit einer SPS über Ethernet kommunizieren soll. Dabei sollen named connections verwendet werden und somit sollte der KoKo leider benötigt werden.
    Das Thema mit der zweiten Netzwerkkarte hattest du als Alternative zum KoKo gesehen oder brauche ich generell zwei Schnittstellen?
    Dann musst Du den Koko, zum laufen bringen... Aber das ist schwierig bis unmöglich, aus der Ferne zu erkennen, warum das nicht geht, zumal in einer VM. Ob NamedConnections aus der VM heraus überhaupt funktionieren wäre schonmal die erste Frage...

    Die zweite Netzwerkkarte zur Trennung von Anlagenbus und Terminalbus macht es einfacher, da abundzu irgendwas nicht geht, wenn Du Beides auf der selben Karte hast. Dafür reicht ja eine zweite virtuelle Karte. Beide virtuellen Karten legst Du dann in VM auf die selbe reale Netzwerkkarte, das ist dann egal. Nur WinCC mag es manchmal nicht, wenn es nur eine Karte hat.

    Gruß.
    Geändert von ducati (15.10.2013 um 10:00 Uhr)

  11. #10
    Registriert seit
    20.04.2010
    Beiträge
    65
    Danke
    17
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Doppelpost sry, kann gelöscht werden!
    Geändert von motamas (16.10.2013 um 10:59 Uhr)

Ähnliche Themen

  1. Programm laden
    Von CJay im Forum HMI
    Antworten: 7
    Letzter Beitrag: 06.05.2013, 07:47
  2. HW-Konfig - Laden in PG
    Von Onkel Dagobert im Forum Feldbusse
    Antworten: 6
    Letzter Beitrag: 13.09.2012, 23:15
  3. wert in DB laden
    Von gabbo im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 21.04.2011, 08:47
  4. String in DB laden
    Von Pinmaster im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 12.09.2008, 12:57
  5. Laden in PG Problem
    Von martin3885 im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 03.08.2006, 22:32

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •