Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 11

Thema: PN Kommunikation mit DPRD-DAT

  1. #1
    Registriert seit
    29.11.2012
    Beiträge
    57
    Danke
    8
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Leute

    ich kann die Daten meines Profinet-Teilnehmers via DPRD_DAT baustein nicht lesen. Der Fehler 8090 wird angezeigt.

    Fehler 8090:
    • Für die angegebene HW-Kennung haben sie keine Baugruppe projektiert, oder
    • Sie haben die Einschränkung über die Länge der konsistenten Daten nicht beachtet, oder
    • Sie haben als Adresse am Parameter LADDR keine HW-Kennung angegeben.


      Ich benutze das Siemens Telegramm 110 PZD12/7 zur Positionierung mit den Eingangsbereich 349...362 und Ausgangsbereich 349...372.


      Ich hab mal einfach das Bild mit beigefügt um das besser zu veranschaulichen.(im moment lädt der das nicht hoch, werde es später nochmal probieren.)

      LADDR scheint zu stimmen, denn wenn ich andere Zahlen eingebe ändert sich der Fehlerwert in 9093:

      Für die unter LADDR angegebene HW-Kennung existiert keine DP-Baugruppe / kein PROFINET IO-Device, von der/dem Sie konsistente Daten lesen können. Dieser Fehlercode tritt auch auf, wenn die über LADDR adressierte Baugruppe nicht über Eingänge verfügt.

      Ich befürchte, dass die Länge der Daten nicht stimmt. Aber ich weiß nicht was ich da sonst schreiben soll. 7 wörter die von meinem Teilnehmer kommen -> das heißt also 14 Bytes.

      Vielleicht könnt ihr mir dabei helfen.

      Vielen Dank schon mal für euer Interesse und eure Hilfe.
    Zitieren Zitieren PN Kommunikation mit DPRD-DAT  

  2. #2
    Registriert seit
    05.04.2012
    Beiträge
    949
    Danke
    94
    Erhielt 216 Danke für 191 Beiträge

    Standard

    Hallo Boegge,

    falls Du mit einer S7-1x00 arbeitest dann folgende Hinweise:
    1.) Zunächsteinmal musst Du die HardwareID angeben - zu finden, wenn Du in der GSD- Datei das Telegramm reingezogen hast, bzw. unter PLC- Variablen (rechte Lasche).
    2.) Anstatt DPRD_DAT / DPWR_DAT würde ich für eine S7-1x00 gleich den FB284 verwenden - das ist ein komplette Ansteuerbaustein für den Einfachpositionierer, also macht nicht nur die Kommunikation, sondern
    Du kannst gleich eine Betreibsart vorgeben, Achse einschalten und z.B. absolut / relativ über vorgebbare Dynamikwerte positionieren. Anstatt Telegramm 110 dann aber Telegramm 111 verwenden.
    3.) Hinweis: Mit TIA V12 SP1 kannst Du für DPRD_DAT/DPWR_DAT auch mit optimierten Datenbausteinen arbeiten.
    4.) Mit einer S7-1500 könntest Du auch mittels einem Technologieobjekt in der S7-1500 positionieren (falls Du z.B. kein Fahren auf Festanschlag, Verfahrsätze, oder keine optimalen Verfahrprofile zur Vibrationsunterdrückung brauchst). Dann kannst Du auch schön mit PLC Open Bausteinen programmieren (mir persönlich gefällt der FB284 mit EPos im Antrieb besser).
    5.) In den Bibliotheken der S7-1x00 würdest Du auch noch die sog. Drive ES Simatic Bausteine finden, die mit dem TIA Portal kostenfrei zur Verfügung gestellt werden. Aber wenn Du die nicht kennst, würde ich die auch nicht nehmen - haben zwar einige nette Features, aber wenn man es zum ersten mal macht, ...

    Grüße
    Zako

  3. #3
    Boegge ist offline Benutzer
    Themenstarter
    Registriert seit
    29.11.2012
    Beiträge
    57
    Danke
    8
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Zako

    Ja ich arbeite mit der 1200er. Leider kann ich den FB284 nicht finden. Ich habe in der Bibliothek nur der Reiter DriveLib_S71200_V12 und dort ist der FB284 nicht zu finden.

  4. #4
    Registriert seit
    05.04.2012
    Beiträge
    949
    Danke
    94
    Erhielt 216 Danke für 191 Beiträge

    Standard

    Die Bibliotheken musst Du noch einbinden, siehe SINAMICS_Bausteine_TIA_PORTAL_V12_SP1.pdf

    http://support.automation.siemens.co...ew/de/68034568

    Schön ist, dass z.b. dass da auch Timingdiagramme dabei sind.

  5. #5
    Registriert seit
    11.03.2011
    Beiträge
    384
    Danke
    32
    Erhielt 80 Danke für 69 Beiträge

    Standard

    Zitat Zitat von Boegge Beitrag anzeigen
    Ja ich arbeite mit der 1200er. Leider kann ich den FB284 nicht finden. Ich habe in der Bibliothek nur der Reiter DriveLib_S71200_V12 und dort ist der FB284 nicht zu finden.
    Lade die Bib nochmal runter:
    http://support.automation.siemens.co...ew/de/68034568
    Die dritte Zeile (Nach Optionspaket und Standalone)

  6. #6
    Registriert seit
    03.07.2006
    Beiträge
    1.725
    Danke
    515
    Erhielt 303 Danke für 223 Beiträge

    Standard

    Jungs dumme Frage...... war unter dem Link nicht auch die DriveLib für S7-300/400 zu finden ???

  7. #7
    Registriert seit
    11.03.2011
    Beiträge
    384
    Danke
    32
    Erhielt 80 Danke für 69 Beiträge

    Standard

    Ich meine, die wird schon bei der Installation des Startdrive installiert.

  8. #8
    Registriert seit
    05.04.2012
    Beiträge
    949
    Danke
    94
    Erhielt 216 Danke für 191 Beiträge

    Standard

    ... da bekommst Du unter anderen den SINA_FB "FB283".
    Also einen reinen Kommunikationsbaustein für zykl. und azkl. Kommunikation.
    Der SINA_POS "FB284" geht hier einen Schritt weiter.

  9. #9
    Registriert seit
    11.03.2011
    Beiträge
    384
    Danke
    32
    Erhielt 80 Danke für 69 Beiträge

    Standard

    Für die S7-300/400 gibt's auch nur den FB283, für die S7-1200/1500 nur die FBs 284, 285 und 286.
    Die Funktionen sollten weitestgehend identisch sein, nur dass der FB283 für die S7-1200/1500 in drei Teile zerlegt wurde.

  10. #10
    Registriert seit
    03.07.2006
    Beiträge
    1.725
    Danke
    515
    Erhielt 303 Danke für 223 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ja das ist alles klar.... Nur bei einer Neuinstallation ist mir aufgefallen das der Ordner DriveLib_S7300-S7400_V12_SP1 unter Siemens\Automation\Portal V12\lib\Sys fehlt........ Und deshalb war mir so als wenn
    man die Lib. auch separat installieren muß.
    Daher die Frage " Frage...... war unter dem Link nicht auch die DriveLib für S7-300/400 zu finden ???"

Ähnliche Themen

  1. Problem mit Wago bzw Codesys / Source.dat will nicht
    Von kintaro im Forum CODESYS und IEC61131
    Antworten: 11
    Letzter Beitrag: 27.10.2011, 17:38
  2. Retain persistent Variablen in persist.dat ?
    Von dietere im Forum Sonstige Steuerungen
    Antworten: 0
    Letzter Beitrag: 17.01.2008, 13:30
  3. Wat Dat?!
    Von Teletubbi-Admin im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 26.04.2006, 01:00
  4. Datei PTREG.DAT ???
    Von Ralle im Forum PC- und Netzwerktechnik
    Antworten: 2
    Letzter Beitrag: 11.08.2004, 11:57

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •