Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: OPC Variablen lassen sich am TP1200 nicht steuern

  1. #1
    Registriert seit
    14.08.2012
    Beiträge
    55
    Danke
    28
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    habe folgendes Problem. Ich möchte Variablen über eine OPC UA Verbindung steuern (z.B Tipp Betrieb). Dies funktioniert auch, auf dem PC in der runtime. Aber wenn ich die HMI aufs TP1200 lade funktioniert es nicht mehr. Was könnte das Problem sein? Die HMI Verbindungen funktionieren aufen TP1200

    Tia Portal V11 SP2
    WinCC Professional V11 SPS2

    Danke
    Zitieren Zitieren OPC Variablen lassen sich am TP1200 nicht steuern  

  2. #2
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.333
    Danke
    932
    Erhielt 3.333 Danke für 2.691 Beiträge

    Standard

    Was meinst Du mit "funktioniert es nicht mehr"? Bekommst Du irgendwelche Fehlermeldungen?

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  3. #3
    Registriert seit
    25.02.2013
    Beiträge
    8
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo flashgorny,

    Ich stehe vor dem gleichen Problem. Ich habe ein Siemens TP1200 und möchte auf Variablen in der Beckhoff CX1010 zugreifen über OPC UA.
    In der Runtime kann ich die Variablen anzeigen und beschreiben. Auf dem Panel werden nur "####" angezeigt.
    Hast Du eine Lösung gefunden ?

    Danke und Gruss
    adco

  4. #4
    Registriert seit
    25.02.2013
    Beiträge
    8
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich habe nun eine Lösung gefunden für das Anzeige-Problem am Siemens TP1200 über OPC-UA :

    Im LMHosts File muss das Panel mit Name und IP Adresse eingetragen werden (weil kein DNS Server vorhanden ist).
    Da auf CE kein LMHosts File existiert, muss Name und Adresse (in Hex) direkt in die Registry eintragen werden.

    HKEY_LOCAL_MACHINE\Comm\Tcpip\Hosts\<PanelName>
    Werte:
    ipaddr C0 A8 00 01
    ExpireTime 99 99 99 99 99 99 99

    Bei der Panel-Projektierung in TIA (Geräte-Konfiguration\Profinet Schnittstelle X1\IP-Protokoll) Hacken setzen bei "Router verwenden".
    Als Router-Adresse die IP Adresse der Beckhoff-Steuerung mit dem OPC-UA Server eintragen.

    So funktioniert es !

    Gruss
    adco

Ähnliche Themen

  1. Antworten: 2
    Letzter Beitrag: 16.05.2012, 20:46
  2. Antworten: 20
    Letzter Beitrag: 22.01.2011, 00:13
  3. Antworten: 6
    Letzter Beitrag: 20.01.2011, 10:45
  4. Antworten: 2
    Letzter Beitrag: 25.07.2010, 18:15
  5. Antworten: 2
    Letzter Beitrag: 21.01.2009, 09:56

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •