Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 4 von 5 ErsteErste ... 2345 LetzteLetzte
Ergebnis 31 bis 40 von 46

Thema: S7-317-2DP Firmwareuprgrade / Kundenprogrammmigration von STEP7 zu TIA

  1. #31
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.725
    Danke
    314
    Erhielt 1.519 Danke für 1.282 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Draco Malfoy Beitrag anzeigen
    P.S: mit "Compilieren" ist die Ausdrucksweise wie sie von den Hochsprachen kommt, gemeint. Heißt, geschriebenen Code in den Maschinencode übersetzen.
    P.S. Was "Compilieren ist weiß ich selber auch, ich weiß aber auch, das es diesen Begriff bei Siemens nicht ausdrücklich gibt, noch ist oder war mir klar wo du kompilierst (Step7 oder TIA).
    P.P.S. TIA spuckt beim Migrieren mit Sicherheit seitenweise Fehlermeldungen aus ... musst du halt step by step abarbeiten, bei DBs ist der Datentyp ja fix, bei den Merker und EA Bereichen musst du die Symbolik halt entsprechend aufbauen (mit den korrekten Datentypen).
    P.P.P.S. In deinem Projekt hast du noch nicht mal die richtige Version der GSD-Datei installiert, was der Kenner daran erkennt, das die Module immer noch mit einem Fragezeichen versehen sind.
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  2. #32
    Avatar von Draco Malfoy
    Draco Malfoy ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    16.10.2012
    Beiträge
    737
    Danke
    51
    Erhielt 34 Danke für 28 Beiträge

    Standard

    Zitat Zitat von bike Beitrag anzeigen
    Im Gegensatz zu dir kann ich ein Projekt von Step7 Version nach TIA mitnehmen.
    Wieso könntest Du dann nicht einfach meine Frage nach den auftauchenden Fehlern beantworten, ohne persönlich und angreifend zu werden ?
    doch es ist doch hirnrissig wenn man so ein Projekt angeht und es nicht kann
    Meinst Du nicht daß man bei der Betrachtung des Problems zwischen geschäftlichen Überlegungen und persönlichem Wissensstand etwas trennen sollte ?
    Wenn ich irgendwo partout nicht weiter kommen sollte, dann werden halt andere Kollegen für € hinzugezogen.
    Und ich bedaure den Kunden jetzt schon aus ganzem Herzen.
    bike, Ich denke, es ich besser wenn wir an dieser Stelle mit unserer Unterhaltung einen Cut machen.

    @MSB: Verstehe. Naja gut, denn werden wir des so angehen. Ich habe gehofft, daß es noch eine schnellere Variante ohne Fußarbeit gibt.
    P.P.P.S. In deinem Projekt hast du noch nicht mal die richtige Version der GSD-Datei installiert, was der Kenner daran erkennt, das die Module immer noch mit einem Fragezeichen versehen sind.
    Ich habe da noch gar nichts installiert, das sind die Rohdaten. Im STEP7 ins PG geladen und ohne Veränderungen gezippt und hier ausgestellt. In der Wirklichkeit wurden da wohl GSD-Dateien für FGP2 installiert, die waren wohl noch etwas unbehobelt und zeigen Fragezeichen und Leerzeichen in der Ansicht. Mittlerweile gibt es FGP3 mit entsprechenden GSDs, dort sieht man auch daß es ich um einen ECORDRIVE/DURODRIVE handelt und die Fragezeichen sind weg.

  3. #33
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.218
    Danke
    533
    Erhielt 2.696 Danke für 1.948 Beiträge

    Standard

    Ich glaube, du mußt zuerst alle GSD-Dateien per Hand in TIA installieren. Bei einer Migration ist TIA so doof, das es nicht mal aus einem Projekt mit kompletten Daten (GSD und Symbolik etc.) die GSD mitnimmt (das ist jedenfalls mein letzter Versuchsstand).
    An deiner Stelle würde ich mal bei Step7 bleiben und nicht zu TIA wechseln. Oder du schreibst den Code gleich neu, kannst ja vom vorhanden Projekt abschreiben, zumindest das was gut und auch zu verstehen ist.

    Auf jeden Fall sehr mutig von dir, aber TIA-Nutzer müssen ja eh einen gewissen Mut beweisen …. , m.E. setzt du dich da freiwillig auf einen Vulkan, der jederzeit hochgehen kann.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  4. Folgender Benutzer sagt Danke zu Ralle für den nützlichen Beitrag:

    ducati (14.11.2013)

  5. #34
    Avatar von Draco Malfoy
    Draco Malfoy ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    16.10.2012
    Beiträge
    737
    Danke
    51
    Erhielt 34 Danke für 28 Beiträge

    Standard

    Zitat Zitat von Ralle Beitrag anzeigen
    Ich glaube, du mußt zuerst alle GSD-Dateien per Hand in TIA installieren. Bei einer Migration ist TIA so doof, das es nicht mal aus einem Projekt mit kompletten Daten (GSD und Symbolik etc.) die GSD mitnimmt (das ist jedenfalls mein letzter Versuchsstand)
    Jo. Denke, die HW-Config kann ich gleich komplett von Hand neu schreiben.
    Oder du schreibst den Code gleich neu, kannst ja vom vorhanden Projekt abschreiben, zumindest das was gut und auch zu verstehen ist.
    Sieht ganz danach aus daß ich das so machen müsste
    Auf jeden Fall sehr mutig von dir, aber TIA-Nutzer müssen ja eh einen gewissen Mut beweisen …. , m.E. setzt du dich da freiwillig auf einen Vulkan, der jederzeit hochgehen kann.
    Wie mein niederländischer Kollege so schön sagt.... "Bei Risiken und Nebenwirkungen - Pech gehabt, oder bleib gleich zu Hause" Ich habe mir halt zum Ziel gesetzt, diese Software zu beherrschen, daher muss es sein. Denke, daß in 3-4 Jahren so ziemlich alles auf TIA Portal läuft. Wobei ich mittlerweile davon ausgehe, daß es auch in der v12 schon einiges besser geworden ist seit der v11 oder ?
    ... Was mir übrigens bei der 12er Version aufgefallen ist daß es wieder BLKMOV gibt, anstatt von MOVE_BLK, und auch die Any-Zeiger sind wieder da, aber mit P#Q.... bzw. P#I.... anstatt von P#E und P#A.
    Geändert von Draco Malfoy (13.11.2013 um 20:00 Uhr)

  6. #35
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.163
    Danke
    921
    Erhielt 3.286 Danke für 2.655 Beiträge

    Standard

    Zitat Zitat von Draco Malfoy Beitrag anzeigen
    Derzeit kotzt er hauptsächlich, weil WORD /= INT Zugriff erfolgt oder entsprechend INT /= WORD.
    Sind die beteiligten Operanden Merker-Words MW...?

    Weil Du nur einen AG-Abzug hast, hast Du natürlich keine Symboltabelle. In Step7 classic wirkt sich das so aus:
    MW.. ohne Symbol werden als WORD interpretiert. Wenn sie als INT interpretiert werden sollen, dann müssen sie zwingend als Symbol angelegt sein. Step7 classic hat allerdings in Operationen, welche eigentlich INT verlangen, auch nicht als Symbol deklarierte MW.. ohne Fehlermeldung toleriert (unabhängig davon, ob die Typprüfung aktiviert ist oder nicht).

    TIA toleriert das offensichtlich nicht mehr. Als was für ein Datentyp werden MW.. ohne Symbol in TIA interpretiert?

    [Nachtrag]
    Step7 classic toleriert auch WORD aus DB wenn eigentlich INT verlangt wird, solange die Adresse rein absolut angegeben ist z.B. DB10.DBW12.
    Sobald der DB einen symbolischen Namen hat wird ein als WORD deklariertes DBW.. als fehlerhaft abgewiesen.

    Harald
    Geändert von PN/DP (13.11.2013 um 22:15 Uhr) Grund: Nachtrag DBW
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  7. #36
    Avatar von Draco Malfoy
    Draco Malfoy ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    16.10.2012
    Beiträge
    737
    Danke
    51
    Erhielt 34 Danke für 28 Beiträge

    Standard

    Also ich habe jetzt den TIA-Portal komplett außen vor gelassen, und erst mal folgendes gemacht:
    Neues Projekt in STEP7 öffnen -> AGs rüberkopieren -> Bausteinkonsistenzprüfung durchführen.
    Ergebnis: es kommen dieselben Fehlermeldungen wie im TIA.

    Wenn jemand nachgucken möchte so ist es Baustein FC32 in dem Abzug, und Netzwerk ebenfalls 32.
    DB10.STAT198 Aktualdatentyp WORD passt nicht zum Formaldatentyp INT des Aktualparameters.

  8. #37
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.163
    Danke
    921
    Erhielt 3.286 Danke für 2.655 Beiträge

    Standard

    Zitat Zitat von Draco Malfoy Beitrag anzeigen
    und auch die Any-Zeiger sind wieder da, aber mit P#Q.... bzw. P#I.... anstatt von P#E und P#A.
    Kann man im TIA irgendwo die Sprache der Mnemonik auf Deutsch einstellen?
    Oder ist die bereits auf Deutsch (hast Du SPB, U ..) und nur bei der ANY-Mnemonik wurde geschlampt?

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  9. #38
    Avatar von Draco Malfoy
    Draco Malfoy ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    16.10.2012
    Beiträge
    737
    Danke
    51
    Erhielt 34 Danke für 28 Beiträge

    Standard

    Gute Frage, weiß ich nicht ob man die umstellen kann
    Die Bedienoberfläche ist auf jeden Fall deutsch, aber auch alle anderen Anweisungen wie UN und U sind britanisiert worden und lauten jetzt entsprechend AN und A.

  10. #39
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.725
    Danke
    314
    Erhielt 1.519 Danke für 1.282 Beiträge

    Standard

    Ich kann dazu jetzt nur sagen, das ich dein Problem weder nachvollziehen noch reproduzieren kann.
    Ich kann das Projekt übersetzten wie ich will und erhalte dabei aber keine Fehlermeldung(en) ... zumindestens wenn die von dir im Beitrag 11 angehängte "RDK.zip" dieselbe Ausgangsbasis darstellt.
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  11. #40
    Avatar von Draco Malfoy
    Draco Malfoy ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    16.10.2012
    Beiträge
    737
    Danke
    51
    Erhielt 34 Danke für 28 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von MSB Beitrag anzeigen
    Ich kann dazu jetzt nur sagen, das ich dein Problem weder nachvollziehen noch reproduzieren kann.
    Ich kann das Projekt übersetzten wie ich will und erhalte dabei aber keine Fehlermeldung(en) ... zumindestens wenn die von dir im Beitrag 11 angehängte "RDK.zip" dieselbe Ausgangsbasis darstellt.
    Mach ein neues Projekt auf, importiere die HW Config und kopiere die Bausteine dahin. Bei mir kommt dann sofort diese Fehlermeldung.
    Oder versuch das Projekt in TIA zu importieren, dann kommt auch dieselbe.
    Geändert von Draco Malfoy (13.11.2013 um 21:30 Uhr)

Ähnliche Themen

  1. CPU 317-2DP löschen
    Von lololo im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 08.10.2011, 14:25
  2. ea Bereich sz 317 2dp
    Von Bensen83 im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 27.07.2011, 10:32
  3. Antworten: 7
    Letzter Beitrag: 06.10.2009, 14:11
  4. cpu 317-2DP
    Von hobel im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 31.08.2006, 10:46
  5. Wechsel der CPU, z.B. von 315-2DP auf 317-2DP
    Von plc_tippser im Forum FAQ
    Antworten: 0
    Letzter Beitrag: 12.07.2006, 09:18

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •