Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: Verbindung S7 mit Ethernet

  1. #1
    Registriert seit
    13.01.2011
    Ort
    Bremen
    Beiträge
    128
    Danke
    15
    Erhielt 7 Danke für 5 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich würde gerne etwas mit den Ethernet TCP "Spielen"

    Vorhaben: S7-300, CP343

    Programm auf dem PG: Hercules zum senden und empfangen

    nun würde ich gerne mit FC5 und FC6 Arbeiten

    bin mir aber unsicher, wann ich "Aktiver Verbindungsaufbau" wählen muss

    Später soll ein Arduino mit ethernetshield mit der SPS reden der Arduino wird als client arbeiten, also müsste doch Aktiver Verbindungsaufbau abgeschaltet sein oder`?
    Zitieren Zitieren Verbindung S7 mit Ethernet  

  2. #2
    Registriert seit
    13.09.2010
    Beiträge
    2.292
    Danke
    178
    Erhielt 375 Danke für 355 Beiträge

    Standard

    .
    Den Verbindungsaufbau übernimmt immer nur einer der beiden
    Teilnehmer, beim anderen ist dieser dann deaktiviert.
    Dieser Teilnehmer muss allerdings auch den aktiven Aufbau (die
    Initialisierung) durchführen können.
    Am besten, du lässt den aktiven Aufbau bei der S7, dann wird sie auf der
    anderen Seite automatisch abgestellt.
    Dann sollte es auch mit dem Hercules klappen.

    Für den FC5/FC6 findest du HIER ein Beispiel.
    kind regards
    SoftMachine

  3. #3
    Benni89 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    13.01.2011
    Ort
    Bremen
    Beiträge
    128
    Danke
    15
    Erhielt 7 Danke für 5 Beiträge

    Standard

    ok danke, werde es mal probieren

  4. #4
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.316
    Danke
    932
    Erhielt 3.331 Danke für 2.689 Beiträge

    Standard

    Zitat Zitat von Benni89 Beitrag anzeigen
    Später soll ein Arduino mit ethernetshield mit der SPS reden der Arduino wird als client arbeiten, also müsste doch Aktiver Verbindungsaufbau abgeschaltet sein oder`?
    Ja.
    KEIN Aktiver Verbindungsaufbau.

    Üblicherweise baut der Client die Verbindung auf (und ggf. wieder ab). Der Server wartet passiv auf Client-Anfragen. Dadurch können sich verschiedene Clients mit verschiedenen IP-Adressen mit dem Server verbinden (wenn gewünscht).
    Bei Aktivem Verbindungsaufbau des Servers müßte der die IP-Adresse des Clients wissen (bzw. die Adressen aller Clients).

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  5. #5
    Benni89 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    13.01.2011
    Ort
    Bremen
    Beiträge
    128
    Danke
    15
    Erhielt 7 Danke für 5 Beiträge

    Standard

    ok PN/DP

    eine sache noch ich lasse also im Netpro dann die IP bei dem Partner leer, sowie den Port richtig?

    Angenommen ich will später 2 Arduinos mit der SPS reden lassen:

    Arduino 1: eingänge
    Arduino 2: ausgänge

    woher weiß die sps dann, wenn sie keine IP hat, das Arduino 1 Verbindung 1 (eingänge ist) und Arduino 2 der mit den ausgängen ist?

    löst man das über die ports einfach oder gebe ich dann ip adressen einfach ein? Bei dem Siemens Leitfaden stand das die IP Felder leer bleiben

  6. #6
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.316
    Danke
    932
    Erhielt 3.331 Danke für 2.689 Beiträge

    Standard

    Entweder für jedes "Protokoll" einen anderen Server-Port nutzen oder das Telegramm so aufbauen, daß die SPS denn Sinn aus dem Inhalt entnehmen kann (z.B. einen zusätzlichen Header mit einer Typ-Codierung: "E:xxxxxx", "A:xxxxxx").

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  7. #7
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.316
    Danke
    932
    Erhielt 3.331 Danke für 2.689 Beiträge

    Standard

    Ich würde in NetPro 2 Verbindungen anlegen, die dann 2 verschiedene Ports haben müssen.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  8. #8
    Benni89 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    13.01.2011
    Ort
    Bremen
    Beiträge
    128
    Danke
    15
    Erhielt 7 Danke für 5 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    ok, dann werde ich mal etwas rumprobiereb

Ähnliche Themen

  1. Antworten: 2
    Letzter Beitrag: 21.04.2013, 15:45
  2. BC 9100 Verbindung über Ethernet mit Twincat
    Von Otto im Forum CODESYS und IEC61131
    Antworten: 2
    Letzter Beitrag: 11.07.2012, 06:55
  3. Mit VMware keine Ethernet Verbindung
    Von ChristianP im Forum Simatic
    Antworten: 15
    Letzter Beitrag: 10.10.2011, 08:24
  4. Ethernet verbindung mit CP-343-1 Lean
    Von focus81 im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 28.01.2010, 12:52
  5. Ethernet Verbindung PC - S7 mit CP
    Von sali im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 31.08.2005, 02:12

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •