Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: Kuka KRC4 an eine 317TF-2DP über CP

  1. #1
    Registriert seit
    05.11.2004
    Ort
    Schweiz
    Beiträge
    1.135
    Danke
    224
    Erhielt 127 Danke für 85 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo.

    Hab einen Kuka Roboter KR5 an einer KRC4 über Profinet an eine Siemens S7-317TF-2DP über einen CP343-1 Advance angeschlossen.
    Roboter konnte ich über Step7 in "Erreichbare Teilnehmer" finden und mit dem Profinet-Namen taufen.
    Der Name wird auch im Kuka korrekt angezeigt.

    Leider erkennt die CPU den Roboter aber nicht und im Roboter kommt die Meldung das die Kommunikation zur SPS nicht hergestellt werden kann in einem Zeitraum von 20000ms.

    Leider braucht ein T-CPU bis zu 5mins bis sie hochgefahren ist.

    Jetzt weiß ich nicht, woran das liegen könnte, das der Roboter nicht von der SPS gefunden wird.
    Liegt das an dem T-CPU, an der CP oder hat noch wer ne Idee?

    Danke!
    Kommt Zeit.... Kommt Rat.... In der Tat.
    Gartenlampe mit Windenergie anstelle von Solar? Bei Interesse -> PN
    Zitieren Zitieren Kuka KRC4 an eine 317TF-2DP über CP  

  2. #2
    Registriert seit
    11.12.2009
    Beiträge
    2.115
    Danke
    388
    Erhielt 390 Danke für 271 Beiträge

    Standard

    Du kannst den Kuka nicht über Erreichbare Teilnehmer taufen, sondern musst dies über die Einstellungen des Roboters tun
    (Wende dich dafür an deinen Roboterprogrammierer deines geringsten Misstrauens!)

    Der Roboter muss auch entsprechend konfiguriert sein (Anzahl der E/As müssen am Roboter und der SPS übereinstimmen etc).

    Wenn du noch Safety machst kannst du dich melden! Dann gebe ich dir weitere Infos.

    Grüße

    Marcel

  3. #3
    Krumnix ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.11.2004
    Ort
    Schweiz
    Beiträge
    1.135
    Danke
    224
    Erhielt 127 Danke für 85 Beiträge

    Standard

    Hmm, das Taufen hat aber funktioniert. Sprich, der Name wir im Kuka so angezeigt, und wenn ich diesen über erreichbare Teilnehmer anzeigen lasse, stimmt dieser auch.
    Selbst beim Zugriff mit WorkVisual steht der Name drin
    Daher ging ich davon aus, das es damit funktioniern müsste.

    Safety haben wir auch drin. Das läuft natürlich auch nicht, wenn der Roboter am Bus nicht erkannt wird!
    Kommt Zeit.... Kommt Rat.... In der Tat.
    Gartenlampe mit Windenergie anstelle von Solar? Bei Interesse -> PN

  4. #4
    Registriert seit
    11.03.2011
    Beiträge
    384
    Danke
    32
    Erhielt 80 Danke für 69 Beiträge

    Standard

    Üblicherweise musst Du in Step 7 den Roboter (wie jeden anderen standardmäßig nicht im HW-Katalog vorhandenen PN-Teilnehmer) per GSDML-Datei importieren und in die Netzkonfiguration einbauen.
    Dadurch werden dem Roboter (wie jeden anderen PN-Teilnehmer) I/O-Adressen zugewiesen, über die Du mit ihm die Daten austauschst.

    Dir ist aber auch klar, dass Du die Technologiefunktionen der TF-CPU nur am DP-Drive nutzen kannst? Der PN-Anschluß kann nur vom Steuerungsteil der TF-CPU angesprochen werden.
    Geändert von miami (21.11.2013 um 17:47 Uhr)

  5. #5
    Registriert seit
    11.12.2009
    Beiträge
    2.115
    Danke
    388
    Erhielt 390 Danke für 271 Beiträge

    Standard

    Info zur GSDML:

    Aufbau:

    Sichere E/A (je 64)
    dann EINE Zeile mit Nutzdaten (1byte IO, 2 Byte IO, … 64byte IO)
    Hier keine zwei Zeilen anlegen… das gibt Gemecker!

    Solange der Safetykram am Roboter nicht aktiviert wurde stört er auch nicht und bringt keine Fehler.

    Warum die CPU den Roboter nicht findet kann folgende Gründe haben:

    Name des Roboters verkehrt (Das hast du ja mehrmals erwähnt das der stimmt)
    IP-Adresse für PN ist am Roboter falsch eingestellt (Der bezieht sie NICHT vom Master sondern muss sie am KCP einstellen!)
    PN ist gar nicht aktiviert aufm Robi und ihr habt die Schnittstelle auch nicht in der Liste
    es sind keine E/A Konfiguriert am Kuka… wobei das nicht umbedingt sein muss (aber sicherheitshalber mal machen)

    Grüße

    Marcel

  6. #6
    Registriert seit
    15.03.2011
    Ort
    Illingen
    Beiträge
    14
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo

    wenn in der KRC4 die Netzkonfiguration und die IP Adresse richtig eingestellt sind sollte es eigentlich funktionieren.
    Sollte im WV-Projekt so aussehen.
    kukapn1.jpg

    Gruss

    Andy

Ähnliche Themen

  1. Kuka KR3 über DeviceNet Beckoff EL6752 0010 verbinden
    Von hille im Forum CODESYS und IEC61131
    Antworten: 1
    Letzter Beitrag: 06.10.2013, 13:17
  2. Step 7 317TF-2DP Safety über ProfiNet
    Von Krumnix im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 24.06.2013, 08:13
  3. Antworten: 12
    Letzter Beitrag: 04.05.2010, 08:45
  4. Kommunikation VIPA -> KUKA über 1 Byte
    Von olitheis im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 18.10.2008, 15:04
  5. Antworten: 9
    Letzter Beitrag: 27.07.2007, 14:09

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •