Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 4 ErsteErste 1234 LetzteLetzte
Ergebnis 11 bis 20 von 32

Thema: Eingänge einer ET200 pro flackern (NCU(317-2-DP))

  1. #11
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.218
    Danke
    533
    Erhielt 2.696 Danke für 1.948 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich würde mal Teile des Codes rausnehmen, also im OB1 nach und nach immer mehr Bausteinaufrufe ausklammern.
    Zuerst den zu beobachtenden Eingang im OB1 eintragen und dort beobachten.

    Wie hoch ist den die Zykluszeit im Moment?
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  2. #12
    Registriert seit
    06.10.2003
    Beiträge
    3.406
    Danke
    448
    Erhielt 502 Danke für 406 Beiträge

    Standard

    Ich würde zuerst einmal die Fehler-OBs herausnehmen. Die sind doch bestimmt vorhanden, oder?

    Gruß, Onkel
    Es gibt viel mehr Leute, die freiwillig aufgeben, als solche, die echt scheitern.
    Henry Ford

  3. #13
    slot23 ist offline Benutzer
    Themenstarter
    Registriert seit
    06.04.2011
    Beiträge
    86
    Danke
    16
    Erhielt 2 Danke für 1 Beitrag

    Standard

    @PN/DP, PC1246: vielen Dank für eure Idee mit dem Zähler. Das werde ich am Montag gleich mal ausprobieren.

    @Ralle: ich habe die Eingänge schon mal in den OB1 geschrieben. Auch hier ist dieses flackern vorhanden. Die Zykluszeit ist glaub ich 12ms, muss ich aber am Montag nochmal kucken.

    @Onkel Dagobert: Die Fehler OBs sind vorhanden. OB 121 Prog_Err und OB 122 Mod_Err. Mit herausnehmen, meinst du löschen oder?

    Gruß

    Slot23

  4. #14
    Registriert seit
    06.10.2003
    Beiträge
    3.406
    Danke
    448
    Erhielt 502 Danke für 406 Beiträge

    Standard

    Zitat Zitat von slot23 Beitrag anzeigen
    .. Mit herausnehmen, meinst du löschen oder? ..
    Genau. Erst einmal gucken, ob im OB122 etwas programmiert ist, wahrscheinlich ist er leer. Dann den OB122 online (also in der CPU) löschen. Wenn ich mit meinem Verdacht richtig liege, wird die CPU auf Stopp gehen. Im Diagnosepuffer muss dann Stopp-Ursache zu sehen sein.

    Gruß, Onkel
    Es gibt viel mehr Leute, die freiwillig aufgeben, als solche, die echt scheitern.
    Henry Ford

  5. #15
    slot23 ist offline Benutzer
    Themenstarter
    Registriert seit
    06.04.2011
    Beiträge
    86
    Danke
    16
    Erhielt 2 Danke für 1 Beitrag

    Standard

    @Onkel Dagobert: also das löschen vom OB 122, bewirkt überhaupt nicht. Die Steuerung geht deshalb auch nicht in den Stopbetrieb. Es steht auch nix drin in der Fehlerdiagnose.


    Ich habe den Zähler jetzt einmal mit ins Programm in den OB 1 geschrieben. Man sieht jetzt ganz deutlich, das der Zähler mit jedem flackern hochzählt.
    Die Zykluszeiten sind folgende: kürzeste 2 ms aktuelle: 17ms längste: 26ms.

    Werde jetzt dann alle Busteilnehmer rausnehmen und nur mal die beiden ET200pros mit dem Bus anfahren. Mal sehen wie das ganze dann aussieht.
    Wenn euch noch etwas einfällt, wäre ich über jeden Tipp dankbar.

    Gruß

    Slot23

  6. #16
    Registriert seit
    26.06.2013
    Ort
    Wendeburg
    Beiträge
    26
    Danke
    3
    Erhielt 4 Danke für 4 Beiträge

    Standard

    Hallo Slot

    Wie ist es denn wenn Du den Eingang an der ET brueckst, flackert er dann auch?

    Gruss
    Christoph
    Abraham sprach zu Bebraham, kann ich mal Dein Cebraham? Heinz Erhardt

  7. #17
    slot23 ist offline Benutzer
    Themenstarter
    Registriert seit
    06.04.2011
    Beiträge
    86
    Danke
    16
    Erhielt 2 Danke für 1 Beitrag

    Standard

    Komischerweise habe ich jetzt festgestellt, das wenn ich im Programm vor die Eingänge das Eingangswort nochmals zuweise, das flackern weggeht.
    L PEW 12
    T EW 12
    Mein Eingang ist hier zum Beispiel E12.1

    Hat hierfür jemand eine Erklärung?

    Gruß

    Slot23

  8. #18
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Zitat Zitat von slot23 Beitrag anzeigen
    Komischerweise habe ich jetzt festgestellt, das wenn ich im Programm vor die Eingänge das Eingangswort nochmals zuweise, das flackern weggeht.
    L PEW 12
    T EW 12
    Mein Eingang ist hier zum Beispiel E12.1

    Hat hierfür jemand eine Erklärung?

    Gruß

    Slot23
    Kann es sein, dass du irgendwo das Ew beschreibst?
    Entweder direkt oder indirekt?
    Dann du solch ein Verhalten.


    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  9. #19
    Registriert seit
    26.06.2013
    Ort
    Wendeburg
    Beiträge
    26
    Danke
    3
    Erhielt 4 Danke für 4 Beiträge

    Standard

    Wie bike schon geantwortet hat, kann es sein, dass Du die Eingaenge beschreibst! Deswegen solltest Du ja auch das Programm in OB1 abklemmen und dort nur mal den Eingang betrachten!
    Wenn Du das PEW12 einliest, dann ist das der topaktuelle Momentanwert ,den Du dann wieder auf das EW12 schreibst! Wo machst Du das denn, direkt vor der Abfrage des E12.1?
    Gruss
    Christoph
    Abraham sprach zu Bebraham, kann ich mal Dein Cebraham? Heinz Erhardt

  10. #20
    Registriert seit
    07.04.2011
    Beiträge
    65
    Danke
    7
    Erhielt 11 Danke für 9 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Wo ist denn Maschinen Steuettafel hin gepointert? Steht im OB 100. IdR fängt die Hardware ab AB/EB32 an. vorher ist NC Bereich. Verschieb mal die Adressen vom Et200 aus den Bereich.

    Gesendet von meinem GT-N7100 mit Tapatalk

Ähnliche Themen

  1. CF Karte einer NCU sichern
    Von slot23 im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 16.02.2013, 07:10
  2. Tausch einer NCU von Version F auf K
    Von S7newbie im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 18.10.2012, 16:01
  3. S7-200 ASi Bus Eingänge flackern
    Von Daimonion im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 14.08.2008, 18:43
  4. S5 ET200(U?) an S7 317 Profibus DP
    Von wincc im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 08.07.2008, 18:13
  5. Antworten: 7
    Letzter Beitrag: 19.03.2008, 21:11

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •