Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 4 ErsteErste 1234 LetzteLetzte
Ergebnis 21 bis 30 von 32

Thema: Eingänge einer ET200 pro flackern (NCU(317-2-DP))

  1. #21
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von DauYing Beitrag anzeigen
    Wo ist denn Maschinen Steuettafel hin gepointert? Steht im OB 100. IdR fängt die Hardware ab AB/EB32 an. vorher ist NC Bereich. Verschieb mal die Adressen vom Et200 aus den Bereich.

    Gesendet von meinem GT-N7100 mit Tapatalk
    Also unser Steuertafeln sind oberhalb Adresse 256.
    Es kommt darauf an wie der FB1 Parametriert ist.
    Und einen NC-Bereich kenne ich leider nicht. Kannst du mir das bitte erklären?


    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  2. #22
    slot23 ist offline Benutzer
    Themenstarter
    Registriert seit
    06.04.2011
    Beiträge
    86
    Danke
    16
    Erhielt 2 Danke für 1 Beitrag

    Standard

    @PC1246: also ich kann über die Referenzdaten kein PEW bzw. EW finden, welches ich beschrieben hab. Die Funktionen L PEW 12, T EW 12 schreibe ich schon in den OB1.
    @Dau Ying: Die Maschinensteuertafel fahre ich über Ethernet an. Die Pointer sind P#E0.0 MCPIN P#A0.0 MCPOUT.

    Gruß

    Slot23

  3. #23
    Registriert seit
    03.07.2006
    Beiträge
    1.725
    Danke
    515
    Erhielt 303 Danke für 223 Beiträge

    Standard

    Nur als Gedankenanstoß ....... hatte das früher öfters das Problem

    Wenn Deine Eingänge wirklich flackern (Hardware) was man mit dem Auge nicht sehen kann ---- > Dann kann es sein das Du Probleme mit der 24VDC Versorgung hast sprich die Restwelligkeit ist zu hoch.
    Wenn zB. jemand einen Trafo 24V AC und nur einen einfachen Brückengleichrichter zum erzeugen der Steuerspannung genommen hat.... dann flackern Deine Eingänge was mit dem Auge kaum sichtbar ist.

  4. #24
    slot23 ist offline Benutzer
    Themenstarter
    Registriert seit
    06.04.2011
    Beiträge
    86
    Danke
    16
    Erhielt 2 Danke für 1 Beitrag

    Standard

    Hallo UniMog!
    Habe ich letzte Woche schon gemacht. Hab die 24V Versorgung mit einem Oszilloskop auf Oberwelligkeit gemessen, aber das ist alles in Ordnung.

  5. #25
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Zitat Zitat von slot23 Beitrag anzeigen
    @Dau Ying: Die Maschinensteuertafel fahre ich über Ethernet an. Die Pointer sind P#E0.0 MCPIN P#A0.0 MCPOUT.

    Gruß

    Slot23
    Es ist unerheblich wie die MSST angeschlossen ist.
    Wenn du aus dem GP den OB100 übernommen hast, dann ist MCP2StatRec auf Adresse P#A12.0 belegt.

    Ist vielleicht eine 2. MSST im OB 100 am Hochlauf FB oder ein BHG?


    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  6. #26
    Registriert seit
    07.04.2011
    Beiträge
    65
    Danke
    7
    Erhielt 11 Danke für 9 Beiträge

    Standard

    Wie Bike schon schreibt bist du im Bereich der NC-Maschinensteuertafeln. Lege einfach deine Profibus Adressen ab ~AB/EB 32. Oder schiebe die Maschinensteuertafeln aus dem Bereich.
    ZB: P#E256.0 und P#A256.0. Man kann auch die MSST-Nahtstelle in einen Datenbaustein "Pointern".
    Hast du die DocOnCD oder nutzt du die DocOnWeb?
    Siehe dazu die Listenhandbücher. Hier der Link zum DocOnWeb: https://www.automation.siemens.com/d...ltType=content

  7. #27
    slot23 ist offline Benutzer
    Themenstarter
    Registriert seit
    06.04.2011
    Beiträge
    86
    Danke
    16
    Erhielt 2 Danke für 1 Beitrag

    Standard

    Vielen Dank für eure Hilfe, nach der Änderung der Profibus Adressen, funktioniert jetzt alles, ohne flackern.

    Gruß

    Slo23

  8. #28
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.166
    Danke
    921
    Erhielt 3.286 Danke für 2.655 Beiträge

    Standard

    Zitat Zitat von slot23 Beitrag anzeigen
    Vielen Dank für eure Hilfe, nach der Änderung der Profibus Adressen, funktioniert jetzt alles, ohne flackern.
    Die beiden Smileys am Ende sollen uns nun sagen, daß Deine Aussage ein Scherz bzw. eine Verarsche ist?

    Kannst Du vielleicht mehr schreiben, wie Du das Problem beseitigt hast - vielleicht wird Deine Aussage dann glaubwürdiger ...

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  9. Folgender Benutzer sagt Danke zu PN/DP für den nützlichen Beitrag:

    UniMog (27.11.2013)

  10. #29
    Registriert seit
    30.08.2010
    Ort
    Östereich
    Beiträge
    1.458
    Danke
    503
    Erhielt 217 Danke für 192 Beiträge

    Standard

    Hat er doch geschrieben: nach dem Ändern der PB Adressen, . . .
    Elektrotechnik und Elektronik funktioniert mit Rauch (Beweis: Tritt Rauch aus, funktioniert auch das Bauteil nicht mehr)

  11. #30
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von winnman Beitrag anzeigen
    Hat er doch geschrieben: nach dem Ändern der PB Adressen, . . .
    Die Lösung ist nicht die PB Adresse gewesen, sondern ziemlich sicher die Adressen der Ein- Ausgänge der Profibusbusteilnehmer.
    War vermutlich ein Kommunikations- oder Ausdruckfehler


    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  12. Folgender Benutzer sagt Danke zu bike für den nützlichen Beitrag:

    PN/DP (27.11.2013)

Ähnliche Themen

  1. CF Karte einer NCU sichern
    Von slot23 im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 16.02.2013, 07:10
  2. Tausch einer NCU von Version F auf K
    Von S7newbie im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 18.10.2012, 16:01
  3. S7-200 ASi Bus Eingänge flackern
    Von Daimonion im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 14.08.2008, 18:43
  4. S5 ET200(U?) an S7 317 Profibus DP
    Von wincc im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 08.07.2008, 18:13
  5. Antworten: 7
    Letzter Beitrag: 19.03.2008, 21:11

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •