Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: Rückmeldung eines Analogen Ausgangs auf das Panel

  1. #1
    Registriert seit
    24.08.2013
    Ort
    Mittelhessen
    Beiträge
    35
    Danke
    5
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    habe folgendes Problem.

    Ich habe eine Handschaltung für einen Analogen Ausgang programmiert.
    Das hat auch soweit geklappt. Über das Panel kann ich jetzt den Analogen Ausgang setzen
    und diesem einen Wert zuweisen [Real-Wert].

    Die Rückmeldung wieder auf das Panel wird aber als INT-Zahl dargestellt.

    L #Out_Ventil U #Alarm_Wasser
    SPB Wass

    U #DB_Kuehlen_Ausgang.Hand_Ein // Handschaltung "Ein"
    SPBN Aus
    SPB Han

    Wass: L 0

    Aus: U #Alarm_Frostschutz
    UN #Alarm_Wasser
    SPBN Fro
    L 27648

    Han: L #DB_Kuehlen_Ausgang.Ausgang_Hand // Vorgabe der "Handschaltung" "Real-Wert"
    TRUNC
    T #Out_zwischen
    ITD
    DTR
    T #Out_zwischen_1

    Fro: T #Out //Ansteuerung des Heizungsventil "INT-Wert"
    DTR
    T #DB_Kuehlen_Ausgang.Anf_Kuehlvent

    Im Endeffekt geht darum wie mache ich aus der INT-Zahl wieder eine Real_Zahl.

    Ist bestimmt kinderleicht, ich komme aber nicht darauf.

    Ich bin noch Anfänger!!

    Gruß
    Ertrinkender
    Zitieren Zitieren Rückmeldung eines Analogen Ausgangs auf das Panel  

  2. #2
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.717
    Danke
    443
    Erhielt 916 Danke für 740 Beiträge

    Standard

    Zitat Zitat von ertrinkender Beitrag anzeigen
    Im Endeffekt geht darum wie mache ich aus der INT-Zahl wieder eine Real_Zahl.
    Ist bestimmt kinderleicht, ich komme aber nicht darauf.


    Dann weißt Du wohl auch nicht, was Du hier machst:
    Zitat Zitat von ertrinkender Beitrag anzeigen
    Code:
    Han: L #DB_Kuehlen_Ausgang.Ausgang_Hand // Vorgabe der "Handschaltung" "Real-Wert"
    TRUNC 
    T #Out_zwischen 
    ITD 
    DTR 
    T #Out_zwischen_1

  3. #3
    Registriert seit
    13.09.2010
    Beiträge
    2.292
    Danke
    178
    Erhielt 375 Danke für 355 Beiträge

    Standard

    .
    Hi hucki,

    naja, einen kleinen Hinweis oder
    einen hilfreichen Link hättest du
    schon mal geben können !

    Gruss nach D.
    kind regards
    SoftMachine

  4. #4
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.717
    Danke
    443
    Erhielt 916 Danke für 740 Beiträge

    Standard

    Hab' ich doch.


    Hast Du etwa noch einen monochromen Monitor, dass Du die rote Markierung nicht sehen kannst?








    Aber mal im Ernst, ertrinkender hat ja schon vermutet, dass er den Wald vor lauter Bäumen nicht sieht.
    Da hat dieser dezente Hinweis anscheinend auch ausgereicht. Sonst hätte er bestimmt noch mal nach gefragt, oder?


    Grüße nach G.

  5. #5
    Registriert seit
    13.09.2010
    Beiträge
    2.292
    Danke
    178
    Erhielt 375 Danke für 355 Beiträge

    Standard

    .
    Na, da muss ich mal meine Monitor-Farbeinstellungen prüfen !

    Hauptsache, der TE kommt jetzt mit den Hinweisen weiter !

    Gruss
    kind regards
    SoftMachine

  6. #6
    Registriert seit
    24.08.2013
    Ort
    Mittelhessen
    Beiträge
    35
    Danke
    5
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Hucki,
    Hallo SoftMachine,

    ihr habt sofort mein "hohes Wissen" erkannt!!
    Danke für eure Hilfe, jetzt sehe ich klar.


    Habe aber schon wieder ein Problem.

    Ich habe einen Störmeldeblock entwickelt, der nachdem er quittiert wurde wieder die gleiche Störung generiert nach Ablauf der eingestellten Zeit.
    Diese Funktion funktioniert auch.

    Ich habe jetzt für mehre Störungen [Ventilator, Wasserwarnung usw.] die gleiche Funktion verwendet und diese in eine andere Funktion
    verschachtelt [FC80].

    Wenn ich jetzt den FC80 im OB1 aufrufe und Testen will funktioniert das ganze nicht. Es sieht so aus, als ob immer etwas überschrieben wird obwohl ich verschiedene Timer und Merker verwendet habe.

    Was beachte ich nicht? Man kann doch Funktionen sooft aufrufen wie man will!?!

    Gruß
    Ertrinkender

  7. #7
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.717
    Danke
    443
    Erhielt 916 Danke für 740 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Da Du ja noch einen separaten Thread dafür aufgemacht hast, sollten wir auch dort antworten und dieses Thema hier vorerst als erledigt betrachten.

Ähnliche Themen

  1. Antworten: 0
    Letzter Beitrag: 08.12.2010, 13:49
  2. Beschaltung eines analogen Spannungseingangs
    Von steven im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 18.10.2008, 13:36
  3. Auswertung eines analogen Signals
    Von Rübezahl im Forum Simatic
    Antworten: 14
    Letzter Beitrag: 26.09.2008, 22:46
  4. Antworten: 10
    Letzter Beitrag: 02.06.2008, 08:38
  5. Antworten: 0
    Letzter Beitrag: 06.03.2008, 23:02

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •