Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: S5 Bausteinübertragung

  1. #1
    Registriert seit
    11.06.2010
    Beiträge
    35
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    nachdem bei einem Kunden das Netzteil einer S5 115 U abgeraucht ist, hat man mich gebeten, nach
    Einbau eines neuen Netzteils, das Programm neu auf die CPU zu übertragen (PG 740).
    Das Übertragen der Bausteine wird aber mit der Meldung " DMA-Schnittstelle unklar" abgebrochen.
    Bis jetzt ist mir diese Fehlermeldung noch nicht untergekommen.
    Mein Verdacht ist jetzt, daß der Speicher der CPU defekt ist und das Übertragen daher nicht funktioniert.
    Liege ich mit meinem Verdacht richtig, oder gibt es noch eine andere Möglichkeit und wie ist das Problem
    dann zu lösen?

    Gruß

    Ralle
    Zitieren Zitieren S5 Bausteinübertragung  

  2. #2
    Registriert seit
    30.08.2003
    Beiträge
    2.196
    Danke
    30
    Erhielt 258 Danke für 229 Beiträge

    Standard

    Hallo,

    haste keine andere S5 um zu probieren ob mit dem PG alles ok ist? Woher kommste denn? Evtl ist ja jemand in der Nähe.

    André
    www.raeppel.de
    mit innovativen SPS-Tools schneller ans Ziel ....

  3. #3
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Hast du urgelöscht?
    Ist ein externer Speicher RAM/EPROM gesteckt?
    Wenn die CPU in Stop ist, schon einmal in USTACK geschaut?


    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  4. #4
    Registriert seit
    19.06.2003
    Beiträge
    2.200
    Danke
    85
    Erhielt 259 Danke für 175 Beiträge

    Standard

    Die Meldung "DMA-Schnittstelle unklar" ist mir noch nie untergekommen. Ich habe aber auch immer mit PCs, nie mit original Siemens-PGs gearbeitet. Könnte sie sich nicht auf ein Problem mit der S5 sondern auf eines mit dem PG beziehen?

    Ein paar Schritte bis zum Einspielen des Programms:
    - Wenn du in den Voreinstellungen "Betriebsart online" wählst, wird die Schnittstelle getestet. Ist das Resultat ok?
    - Kannst du jetzt Urlöschen? "Bausteine"/"Löschen"/"Ag" und dann alle oder "B" eingeben. Bei unklarer Vorgeschichte der S5 mache ich das gerne zweimal nacheinander.
    - Läuft die Übertragung der Bausteine an?
    - Wenn ja, bricht es immer bei demselben Baustein ab?
    - Manche S5 haben zwei serielle Schnittstellen. Verwende die erste, die erste kann nämlich mehr. Die erste ist die in der Vertiefung.

  5. #5
    Registriert seit
    19.06.2003
    Beiträge
    2.200
    Danke
    85
    Erhielt 259 Danke für 175 Beiträge

    Standard

    Unter
    http://cache.automation.siemens.com/...4SR11band2.pdf
    habe ich ein Handbuch zur S5-155 gefunden. Hier ein Auszug:
    ...
    Einschränkungen beim
    Übertragen von FD
    Wenn Sie Bausteine von FD zum AG übertragen möchten, müssen Sie
    folgende Einschränkungen beachten:
    1: "UEBERTR QUELLE : FD BAUST [DX1] NACH ZIEL: AG"
    Diese Funktion ist im RUN nicht zulässig. Bei Nichtbeachtung
    erscheint am PG die Systemmeldung "Unzul. Bausteintyp/-nummer".
    2. "UEBERTR QUELLE: FD BAUST [RAM-DB] NACH ZIEL: AG"
    Der RAM-DB darf im RUN nicht übertragen werden! Bei
    Nichtbeachtung erscheint am PG die Systemmeldung
    "DMA-Schnittstelle unklar" bzw. "Zeitüberlauf".
    Soll heißen bevor du den DB1 oder die DBs überträgst, solltest du den Schalter RUN/STOP auf Stop stellen.
    DB1 konfiguriert verschiedene Systemfunktionen. Ansonsten nachlesen, was "RAM-DB" meint.
    Geändert von Zottel (26.11.2013 um 21:18 Uhr)

  6. #6
    RalleM ist offline Benutzer
    Themenstarter
    Registriert seit
    11.06.2010
    Beiträge
    35
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    So, mal eben zur Info.
    Man hat gestern Abend noch eine Ersatz CPU aufgetrieben und eingebaut. Damit hat die Programmübertragung dann geklappt. Also scheint mit der alten wirklich etwas nicht zu stimmen. Ich hatte jedenfalls Zugriff auf die alte CPU. Das Programm gab beim Verbinden die Meldung aus, daß die AG-Schnittstelle geprüft und o.k. ist.

    Vielen Dank für Eure Hilfe.

    Gruß Ralle

  7. #7
    Registriert seit
    25.05.2009
    Ort
    Raum Zürich CH
    Beiträge
    85
    Danke
    15
    Erhielt 15 Danke für 15 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Die Meldung "DMA-Schnittstelle unklar" habe ich auch noch nicht gesehen. Allerdings habe ich für die S5 immer mit "S5 für Windows" gearbeitet (IBH-Softec).

    Ich hatte aber mal den Fall, wo ich auch nicht Online kam. Die Ursache war, dass die CPU (relativ alt) noch eine PASSIVE PG-Schnittstelle hatte.
    Es musste dann einen Einspeisungsadapter mit Netzteil dazwischengeschaltet werden, dann gings.

    Möglicherweise war die orginale CPU in deinem Fall auch eine ältere.

    Gruss SW-Mech

Ähnliche Themen

  1. Antworten: 12
    Letzter Beitrag: 05.12.2011, 10:33

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •