Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 13

Thema: S5 115 U CPU 941b mit Ram

  1. #1
    Registriert seit
    20.12.2003
    Ort
    Obrigheim
    Beiträge
    420
    Danke
    31
    Erhielt 31 Danke für 27 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich möchte an einer Anlage eine Programmänderung machen. Da in der CPU ein EPROM drin ist möchte ich dieses gegen einen RAM austauschen.
    Wenn ich nun das Projekt übertrage geht mir die CPU sofort in STOP.
    Hab dasselbe Programm auch auf andere Baureihen übertragen, ohne Erfolg.

    Im U-Stack sind folgende Infos mit einem x gekennzeichnet.

    REMAN, STOZUS , STOANZ , BETPUF, ASPNRA, ERAB , VKE.

    So wie ich die Sache sehe liegt es aber am Programm.
    Erst wenn ich einen Programmierten OB 13 übertrage geht mir die Kiste auf Stop.

    Darin steht:

    L PY 6
    T EB 6

    in einem Weiteren Baustein steht Ähnliches geschrieben. Lasse ich diese Bausteine weg, bleibt das AG auf RUN.
    Kann es sein das irgendwelche Infos auf dem Eprom drauf sind die ich im AG brauche. Kann es mir eigentlich nicht vorstellen. Es ist eigentlich nicht das erste RAM das ich gegen eine EPROM austausche.

    Ich hoffe ihr habt n paar Tipps


    Danke

    Robert
    Stress hat nur der Leistungsschwache
    Zitieren Zitieren S5 115 U CPU 941b mit Ram  

  2. #2
    Registriert seit
    23.11.2004
    Beiträge
    347
    Danke
    2
    Erhielt 28 Danke für 28 Beiträge

    Standard

    Leuchtet an der CPU die Lampe ADF bzw QVZ?
    Geh doch im U-Stack mal auf WEITER.
    Gibt es eine Eingangsbaugruppe mit der Adresse 6?

    Gruß
    raika

  3. #3
    Registriert seit
    20.12.2003
    Ort
    Obrigheim
    Beiträge
    420
    Danke
    31
    Erhielt 31 Danke für 27 Beiträge

    Standard

    Hallo,

    ich habe das Programm jetzt in eine 945 übertragen. Da leuchtet jetzt QVZ und BASP und das AG ist auf Stop.

    Im U-Stack habe ich nichts gefunden, was auf eine Adresse 6 hindeutet.


    Gruß

    Robert
    Stress hat nur der Leistungsschwache

  4. #4
    Registriert seit
    23.11.2004
    Beiträge
    347
    Danke
    2
    Erhielt 28 Danke für 28 Beiträge

    Standard

    So wie ich die Sache sehe liegt es aber am Programm.
    Erst wenn ich einen Programmierten OB 13 übertrage geht mir die Kiste auf Stop.

    Darin steht:

    L PY 6
    T EB 6
    Gibt es denn eine Eingabebaugruppe mit der Adresse 6?
    Der QVZ (Quittungsverzug) bezieht sich ofensichtlich auf die Anweisung "L PY 6", also ein direkter Zugriff auf die Peripherie mit der Byte-Adresse 6.

    Gruß
    raika

  5. #5
    Registriert seit
    06.10.2003
    Beiträge
    3.445
    Danke
    453
    Erhielt 509 Danke für 411 Beiträge

    Standard

    Mahlzeit Robert,

    ersetze mal PY durch PB. PY wurde bei alten PG's verwendet. Eigene Erfahrung habe ich damit nicht, habe es nur mal irgendwo gelesen.
    Bei der 945 ist einiges anders, also nicht wundern wenn die 945 auf Stop geht.

    Gruß, Onkel
    Geändert von Onkel Dagobert (16.02.2006 um 12:28 Uhr)
    Es gibt viel mehr Leute, die freiwillig aufgeben, als solche, die echt scheitern.
    Henry Ford

  6. #6
    Registriert seit
    20.12.2003
    Ort
    Obrigheim
    Beiträge
    420
    Danke
    31
    Erhielt 31 Danke für 27 Beiträge

    Standard

    Hallo,

    PY kann ich nicht in PB ändern. Bekomme dann eine Fehlermeldung.

    Gruß

    Robert
    Stress hat nur der Leistungsschwache

  7. #7
    Registriert seit
    23.11.2004
    Beiträge
    347
    Danke
    2
    Erhielt 28 Danke für 28 Beiträge

    Standard

    Hallo Robert!

    Ich wiederhole die Frage: Gibt es denn eine Eingabebaugruppe mit der Adresse 6???

    Den Begriff PB gibt es bei der S5 nur im Zusdammenhang mit Programmbausteinen. Um Verwechslungen zu vermeiden nennt man den Zugriff auf die Peripherie für Byte PY.

    Gruß
    raika

  8. #8
    Registriert seit
    20.12.2003
    Ort
    Obrigheim
    Beiträge
    420
    Danke
    31
    Erhielt 31 Danke für 27 Beiträge

    Standard

    Hallo Raika,

    Sorry, laut Programm gibt es das EB 6.


    Ich habe mit einem von Siemens gesprochen und der meinte ich solle nicht mit dem AG-Abzug arbeiten, sondern mir die Daten aus dem EPROM holen. Naja, die Hoffnung stirbt zuletzt.

    Gruß

    Robert
    Stress hat nur der Leistungsschwache

  9. #9
    Registriert seit
    06.10.2003
    Beiträge
    3.445
    Danke
    453
    Erhielt 509 Danke für 411 Beiträge

    Standard

    Hallo Kolbendosierer,

    das ist schon sehr eigenartig, vielleicht hilft der folgende link:
    http://support.automation.siemens.co...iew/de/4139194

    Zitat Zitat von Onkel Dagobert
    ..ersetze mal PY durch PB...
    Den Hinweis mit "PB" hatte ich aus der Operationsliste (Tabellenheft). Aber der Fehler scheidet ja aus, wird von Step5 abgefangen und ausserdem hast du einen Programmabzug aus dem AG. Hast du diesen mal mittels PG mit dem Eprom-Inhalt verglichen? Besonders denke ich an den DB1?


    Gruß, Onkel
    Es gibt viel mehr Leute, die freiwillig aufgeben, als solche, die echt scheitern.
    Henry Ford

  10. #10
    Registriert seit
    07.07.2004
    Beiträge
    3.285
    Danke
    38
    Erhielt 584 Danke für 382 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    Zitat Zitat von Kolbendosierer
    Hallo Raika,

    Sorry, laut Programm gibt es das EB 6.
    Mensch Kolbendosierer, Raika wollte wissen, ob eine Baugruppe mit der Adresse 6 physikalisch vorhanden ist und nicht laut Programm.

    Gruß
    Question_mark
    ''Ich habe wirklich keine Vorurteile.
    Meine Meinung ist nur die Summe der Erfahrungen" ... (Question_mark)

Ähnliche Themen

  1. Unterschiede bei S5-CPU941, -941A, -941B?
    Von Jörg_24 im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 06.02.2010, 12:45

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •