Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: Profibusverbindung hängt sich auf

  1. #1
    Registriert seit
    12.12.2004
    Beiträge
    55
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo liebes Forum,
    ich habe eine S7-300 CPU mit Profibus. Am Profibus hängen zwei Teilnehmer (Probenehmer von Endress und Hauser) mit den Adressen 2 und 3. Die Kommunikation erfolgt azyklisch über SFB 52 und SFB 53.
    Die Bausteine werden per Multiinstanz aufgerufen. Bei der Requestabfrage ist ein Blinkmerker mit 1 Sekunde benutzt.
    Die Kommunikation läuft circa 2 Tage durch. Danach zeigen beide Geräte (SPS und Probenehmer) noch eine Kommunikation an. Der Probenehmer reagiert aber nicht mehr.
    Wenn ich SPS und Probenehmer resette, dann läuft wieder alles (2 Tage lang).
    Hat jemand vielleicht eine Idee was das sein kann ?

    Vielen Dank

    Gruß Steffen
    Zitieren Zitieren Profibusverbindung hängt sich auf  

  2. #2
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.622
    Danke
    377
    Erhielt 799 Danke für 642 Beiträge

    Standard

    Diagnosepuffer exportieren und hier anhängen.

    Und, wenn das Problem besteht, dann die STATUS Werte von beide Bausteine notieren und hier melden.
    Geändert von JesperMP (08.12.2013 um 11:29 Uhr)
    Jesper M. Pedersen

  3. #3
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.181
    Danke
    923
    Erhielt 3.289 Danke für 2.658 Beiträge

    Standard

    Zitat Zitat von steffen21m Beitrag anzeigen
    Danach zeigen beide Geräte (SPS und Probenehmer) noch eine Kommunikation an.
    WIE zeigen die Geräte "noch eine Kommunikation" an bzw. was meinst Du damit?

    Wie sieht denn Dein Programm rund um die Bausteinaufrufe aus?

    Ist es bei den Probenehmern nicht möglich, die Dich interessierenden Daten in der zyklischen E/A-Kommunikation zu übertragen?

    Harald

    PS: zur allgemeinen Info: SFB52 ist RDREC / SFB53 ist WRREC
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  4. #4
    Registriert seit
    12.12.2004
    Beiträge
    55
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke für die schnellen Antworten.
    Die Diagnoseliste ist leer. Die Teilnehmer sind alle erreichbar. Wenn die CPU der SPS neu gestartet wird, (Warmstart) dann läuft alles wieder.
    Die Kommunikation muss über RDREC und WRREC erfolgen, weil die Ansteuerung diverser Parameter als Sonderlösung der Firma angeboten wurde. Ansonsten müsste das GSD File angepasst werden, was zur Inkompatibilität mit vorhandenen Systemen führen würde.
    Ich halte euch auf dem Laufenden ..... Momentan läuft wieder alles

  5. #5
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.622
    Danke
    377
    Erhielt 799 Danke für 642 Beiträge

    Standard

    Zitat Zitat von JesperMP Beitrag anzeigen
    Und, wenn das Problem besteht, dann die STATUS Werte von beide Bausteine notieren und hier melden.
    Nächste mal, bitte die STATUS Werte checken.
    Jesper M. Pedersen

  6. #6
    Registriert seit
    12.12.2004
    Beiträge
    55
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo liebes Forum,
    danke für die zahlreichen Antworten. Gestern hat sich das Problem gelöst. Es lag ein dem Schirm des Profibuskabels, der an einer Stelle nicht richtig geerdet wurde. Deswegen trat komischerweise immer zur gleichen Zeit der ein Fehler auf.

    Ich habe noch eine Frage:
    Wie kann ich im TIA Portal eine Meldung (in einer Variable) erzeugen, wenn ein Profibusteilnehmer nicht mehr online (erreichbar) ist ? Welchen Baustein kann ich verwenden ?
    Vielen Dank

    Gruß Steffen

Ähnliche Themen

  1. CPX hängt sich auf
    Von Aventinus im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 13.12.2011, 15:30
  2. Step 7 V5.5 hängt sich auf
    Von Boris im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 26.01.2011, 21:40
  3. OP 73 hängt sich auf
    Von Paule im Forum HMI
    Antworten: 6
    Letzter Beitrag: 26.05.2009, 15:42
  4. CP 443-1 IT hängt sich auf ?
    Von MW im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 20.05.2009, 21:01
  5. Netlink hängt sich auf
    Von afk im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 20.02.2006, 10:29

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •