Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: Web für S7-1200

  1. #1
    Registriert seit
    10.11.2013
    Ort
    Essen
    Beiträge
    119
    Danke
    39
    Erhielt 17 Danke für 14 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Jungs

    da ich von HTML keine Ahnung (0-Ahnung) habe könnte mir mal einer verraten warum das nicht funktioniert ???

    Mein HTML erstellt mit Expression Web 4

    <!-- AWP_In_Variable Name='"Start"' -->
    <!-- AWP_In_Variable Name='"Stop"' -->

    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
    <html>
    <head>
    <meta content="de" http-equiv="Content-Language" >
    <meta content="text/html; charset=utf-8" http-equiv="Content-Type" >
    </head>
    <body>
    <p>Welcome to my Homepage</p>
    <form method="post" action="" style="width: 381px">
    <input style="width: 170px" type="submit" value="Start" >
    <input type="hidden" name="Start" value="1" >
    <input type="hidden" name="Stop" value="0" >

    <input style="width: 170px" type="button" value="Stop" >
    <input type="hidden" name="Stop" value="1" >
    <input type="hidden" name="Start" value="0" >
    </form>
    </body>

    Sind einfach nur zwei Schaltflächen zum Ein und Ausschalten siehe Bild dazu

    PIC_1.png

    Web Server ist eingeschaltet und auch Bausteine übersetzt aber leider geht das nicht....
    Danke für jeden Tipp

    Gruss
    Zitieren Zitieren Web für S7-1200  

  2. #2
    Registriert seit
    29.03.2004
    Beiträge
    5.739
    Danke
    143
    Erhielt 1.686 Danke für 1.225 Beiträge

    Standard

    Um Daten schreiben zu können, musst du dich vorher auf der Startseite anmelden.

  3. #3
    Registriert seit
    10.11.2013
    Ort
    Essen
    Beiträge
    119
    Danke
    39
    Erhielt 17 Danke für 14 Beiträge

    Standard

    Hi

    das habe ich gemacht.... Admin und Passwort.

    Ist der HTML Code denn OK ???? oder ist das noch etwas falsch ???

  4. #4
    Registriert seit
    29.03.2004
    Beiträge
    5.739
    Danke
    143
    Erhielt 1.686 Danke für 1.225 Beiträge

    Standard

    Hm, ich meine der Variablenname darf nur in einfache Anführungszeichen gesetzt werden.
    Also so für die Variable Start/Stop:

    Code:
    <!-- AWP_In_Variable Name='Start' -->
    <!-- AWP_In_Variable Name='Stop' -->
    Und als Buttons für Ein/Aus
    Code:
    <form method="post">
    <input type="submit" value='Einschalten'>
    <input type="hidden" name='Start' value="1">
    </form>
    
    <form method="post">
    <input type="submit" value='Ausschalten'>
    <input type="hidden" name='Stop' value="1">
    </form>
    In dem Fall bleibt bei Stop das Bit für Start auf 1, aber kannst ja mal testen obs prinzipiell so funktioniert.

  5. #5
    Registriert seit
    10.11.2013
    Ort
    Essen
    Beiträge
    119
    Danke
    39
    Erhielt 17 Danke für 14 Beiträge

    Standard

    Jo danke stimmt mit den "einfache Anführungszeichen" klappt es.
    Man da hätte ich noch lange gesucht nochmal Danke.

    Aber mal ehrlich bei "Totally Integrated Automation Portal" gehört eigentlich ein einfacher WYSIWYG- Editor ( What You See Is What You Get)
    mit zur Grundausstattung.

    Gruss

  6. #6
    Registriert seit
    03.07.2006
    Beiträge
    1.725
    Danke
    515
    Erhielt 303 Danke für 223 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Auf die Nummer bin ich auch schon reingefallen mit den " " Zeichen
    klappt aber nur mit ' ' <!-- AWP_In_Variable Name='Start' --> nur leider ist das in jedem Beispiel und Handbuch mit " " dargestellt......

    Aber das Beste kommt noch zB. keine automatische Aktualisierung der Webseiten also immer F5 drücken oder noch etwas mit js üben.
    Dieser Web Kram steckt noch sehr in den Kinderschuhen und ist von dem was man zB. mit einem TP oder einer Visu macht so weit weg das mir die Worte fehlen.

    Gruß
    Geändert von UniMog (22.12.2013 um 21:08 Uhr)

Ähnliche Themen

  1. S7-1200 Web Visualisierung
    Von rwinnen im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 16.04.2013, 14:39
  2. Tips für stabilere Web Visualisierung
    Von carki im Forum CODESYS und IEC61131
    Antworten: 3
    Letzter Beitrag: 10.06.2012, 00:11
  3. Welches Web-panel für Wandeinbau?
    Von berc im Forum HMI
    Antworten: 3
    Letzter Beitrag: 21.06.2011, 02:13
  4. Web Visu für Simatic
    Von babylon05 im Forum HMI
    Antworten: 6
    Letzter Beitrag: 01.02.2011, 20:29
  5. WEB Visualisierung S7 1200
    Von ziede im Forum HMI
    Antworten: 0
    Letzter Beitrag: 09.07.2010, 18:57

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •