Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: Merker ist im FC1 True und gibt in einem anderen/mehreren FC kein Signal mehr

  1. #1
    Registriert seit
    06.09.2013
    Beiträge
    9
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich setze einen Merker mit einem Knebelschalter. Wenn dieser ungleich 1 ist, wird der Merker zurückgesetzt. Dies funktioniert auch.
    Sobald ich jedoch einen bestimmten Taster drücke, fällt das Signal des Merkers in meinem FC4 und FC6 ab.-was durch mein programm eigentlich nicht sein kann.
    Im FC1, wo der Merker ist, bleibt er grün-true.
    Beim Beobachten der Variablen fällt der Merker auch ab.
    Finde nichts im Forum. Hat jemand Lösungsvorschläge?
    Vielen Dank!!
    Zitieren Zitieren Merker ist im FC1 True und gibt in einem anderen/mehreren FC kein Signal mehr  

  2. #2
    Registriert seit
    22.11.2006
    Ort
    CH
    Beiträge
    3.621
    Danke
    778
    Erhielt 649 Danke für 494 Beiträge

    Standard

    überlappender Speicherbereich?

    Rechtsklick auf merker in FC1 Verwendungsstelle anzeigen, übergreifende Speicherbereiche anhaken.

    mfG René

  3. #3
    Immer Besser ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    06.09.2013
    Beiträge
    9
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Speicherbereich.jpg
    Hat es damit zu tun??

  4. #4
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Ja, wenn du deine Merker überschreibst, was dann?


    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  5. #5
    Registriert seit
    22.11.2006
    Ort
    CH
    Beiträge
    3.621
    Danke
    778
    Erhielt 649 Danke für 494 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    genau das hat es.

    m10.3 m10.2 ist Teil von MD 8

    mfG René

Ähnliche Themen

  1. Antworten: 0
    Letzter Beitrag: 26.07.2013, 08:27
  2. Am Ausgang kein Signal
    Von Fidibus im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 25.08.2011, 10:19
  3. timer gibt kein signal weiter
    Von MarcusS81 im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 01.09.2008, 12:38
  4. Antworten: 12
    Letzter Beitrag: 31.07.2006, 16:39
  5. Profibus und Oszi...was ist das für ein Signal?
    Von BlauBaer im Forum Feldbusse
    Antworten: 3
    Letzter Beitrag: 22.08.2005, 11:26

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •