Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 10 von 10

Thema: Ausschaltverzögerung Step 7 MicroWin

  1. #1
    Registriert seit
    09.01.2014
    Beiträge
    9
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo
    Ich bin Neu hier und fange auch gearde erst mit S7 Programmierung an, meine Frage ist: wie bekomme ich eine Ausschaltverzögerung hin
    die ich zurücksetzen kann?
    Bei der Logo heist das Komfortschalter.

    Meine CPU ist eine S7-200 222

    Ich bedanke mich schon einmal und hoffe mit solchen einfachen Fragen nicht zu nerven.

    Danke
    Zitieren Zitieren Ausschaltverzögerung Step 7 MicroWin  

  2. #2
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.738
    Danke
    444
    Erhielt 924 Danke für 744 Beiträge

    Standard

    Das ist eine Ausschaltverzögerung TOF (Netzwerk 2).
    Die Komfortfunktion ist von Haus aus nicht in der S7-200 vorhanden. Das muss man sich selbst programmieren, indem man den Zeitwert auf die Ausschaltzeit PT bzw. etwas größer setzt (Netzwerk 1):
    Code:
    Network 1
    LD     E0.0
    U      T37
    MOVW   10, T37
    
    Network 2
    LD     E0.0
    UN     T37
    TOF    T37, 10
    
    Network 3
    LD     T37
    =      A0.0
    Die Ansicht in MicroWin auf AWL umschalten, Code in die Netzwerke kopieren und wieder in gewünschte Ansicht zurückschalten.
    Den TOF anwählen und F1 drücken, dann gibt's auch dazu weitere Hilfe.



    PS: bei den größeren bzw. neueren CPUen gibt es eine separate Rücksetzfunktion für die Timer.
    Geändert von hucki (10.01.2014 um 20:04 Uhr)

  3. #3
    vaglupo ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    09.01.2014
    Beiträge
    9
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Danke erstmal für das annehmen meines Problems.
    ich glaube das ist nicht genau das was ich suche ich beschreibe mal das etwas Besser.
    wen E0.0 aus geht soll 10s A0.0 noch aktiv sein aber man soll über E0.1 das abbrechen können auch wen die zeit noch nicht abgelaufen ist.
    Ich hoffe das ist Verständlich?

    Snap1.jpg


    Danke

  4. #4
    vaglupo ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    09.01.2014
    Beiträge
    9
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Danke erstmal für das annehmen meines Problems.
    ich glaube das ist nicht genau das was ich suche ich beschreibe mal das etwas Besser.
    wen E0.0 aus geht soll 10s A0.0 noch aktiv sein aber man soll über E0.1 das abbrechen können auch wen die zeit noch nicht abgelaufen ist.
    Ich hoffe das ist Verständlich?

  5. #5
    vaglupo ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    09.01.2014
    Beiträge
    9
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Danke erstmal für das annehmen meines Problems.
    ich glaube das ist nicht genau das was ich suche ich beschreibe mal das etwas Besser.
    wen E0.0 aus geht soll 10s A0.0 noch aktiv sein aber man soll über E0.1 das abbrechen können auch wen die zeit noch nicht abgelaufen ist.
    Ich hoffe das ist Verständlich?

  6. #6
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.738
    Danke
    444
    Erhielt 924 Danke für 744 Beiträge

    Standard

    Dann versuch doch mal, Netzwerk 1 und 2 entsprechend umzubauen. Kannst auch Screenshots posten.


    PS: Hab' Deinen obigen Screenshot glatt übersehen. (Hab' die erste Deiner 3 Antworten nicht mitbekommen )
    Mein Netzwerk 1 ist das vorzeitige Rücksetzen des Timers über die Veränderung des Zeitwerts. Nur die Bedingung für den MOV_W muss dann angepasst werden.
    Geändert von hucki (10.01.2014 um 22:06 Uhr)

  7. #7
    vaglupo ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    09.01.2014
    Beiträge
    9
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Ja irgendwie konnte ich keine Antwort schreiben und auf einmal waren es Drei.
    OK
    Teste Morgen weiter.

    Danke

  8. #8
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.738
    Danke
    444
    Erhielt 924 Danke für 744 Beiträge

    Standard

    Zitat Zitat von vaglupo Beitrag anzeigen
    Ja irgendwie konnte ich keine Antwort schreiben
    Spamschutz bei neuen Usern.



    Zitat Zitat von vaglupo Beitrag anzeigen
    OK
    Teste Morgen weiter.
    Bin gespannt auf das Ergebnis.

  9. Folgender Benutzer sagt Danke zu hucki für den nützlichen Beitrag:

    vaglupo (11.01.2014)

  10. #9
    vaglupo ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    09.01.2014
    Beiträge
    9
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Ich habs geschaft .
    hier mein Programm
    Ausschaltverzögerung rücksetzen AWL.jpgAusschaltverzögerung rücksetzen Kop.jpg

    Trotzdem Danke

  11. Folgender Benutzer sagt Danke zu vaglupo für den nützlichen Beitrag:

    hucki (11.01.2014)

  12. #10
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.738
    Danke
    444
    Erhielt 924 Danke für 744 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Sorry, war mir gar nicht mehr bewußt, das es mit Bit-Rücksetzen auch geht.

Ähnliche Themen

  1. Step 7 MicroWin auf Win 7
    Von Franzjosef im Forum PC- und Netzwerktechnik
    Antworten: 1
    Letzter Beitrag: 11.03.2011, 12:26
  2. Step 7 Microwin - TD200 Assistent
    Von ToBo im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 28.01.2010, 10:50
  3. Antworten: 7
    Letzter Beitrag: 23.07.2009, 19:37
  4. Antworten: 7
    Letzter Beitrag: 14.02.2008, 11:37
  5. Antworten: 6
    Letzter Beitrag: 06.07.2005, 18:36

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •