Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: Timer Problem

  1. #1
    Registriert seit
    24.01.2014
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    ich habe folgendes Problem. In der nachfolgend gezeigten Schaltung möchte ich realisieren, dass ein Messwert, der über einen bestimmten Zeitraum (T388 ) ansteht, als Fehler gemeldet wird (M399.5). In diesem Beispiel liegt zur Testzwecke der Messwert dauerhaft an (M0.1).

    Bisher hat diese Schaltung tadellos funktioniert, der Timer als Einschaltverzögerung zählte die im parametrisierte Zeit herunter und unterbrach sich selbst. Nun jedoch funktioniert dies nicht mehr. Sobald die Zeit abgelaufen ist, startet Ssie von neuen und der nachfolgende Merker wird nie gesetzt.
    Hat jemand dafür eine Erklärung ?


    Timer.JPG
    Geändert von olafhahn (24.01.2014 um 12:03 Uhr)
    Zitieren Zitieren Timer Problem  

  2. #2
    Registriert seit
    22.11.2006
    Ort
    CH
    Beiträge
    3.620
    Danke
    777
    Erhielt 647 Danke für 493 Beiträge

    Standard

    Dass der Timer jedesmal automatisch neu startet ist klar. Oder?

    aber der Merker der muss gesetzt werden, es seidenn du überschreibst den Merker irgendwo, was bestimmt der Fall ist.

    Lass dir mal die Belegung mit Überschneidungen anzeigen.

  3. #3
    olafhahn ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    24.01.2014
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Vollmi,

    Das der Timer neustartet ist logisch, aber das das Signal nicht zum Flip Flop durschschaltet ist mit schleirhaft.
    nein der Merker wird nicht mehrfach verwendet oder überschrieben, daran hatte ich auch schon gedacht...

  4. #4
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.726
    Danke
    398
    Erhielt 2.401 Danke für 2.001 Beiträge

    Standard

    ... dann solltest du vielleicht den Merker deines Flip-Flop dazu hernehmen um den Timer neu zu starten - ich denke, dann wird es funktionieren ...

    Gruß
    Larry

  5. #5
    olafhahn ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    24.01.2014
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke Larry,
    deine Lösung funktioniert!
    Komisch ist, das wir die Original- Verschaltung seid Jahren einsetzen, und bisher tadellos funktioniert hat. Kann es sein, das unter verschiedener Harware, die Timer anders reagieren.
    Getestet habe ich die Schaltung auf einer 840D SL 720.3 PN. Aber wir Nutzen eigentlich die Ganze Bandbreite der 840D SL.
    Hat da jemand ähnliche Erfahrungen ?
    Definitiv ist das Fakt, das die Schaltung in der Vergangenheit funktionierte.

  6. #6
    Registriert seit
    22.11.2006
    Ort
    CH
    Beiträge
    3.620
    Danke
    777
    Erhielt 647 Danke für 493 Beiträge

    Standard

    der AWL code der aus deiner konstruktion generiert wird ist auch etwas komisch.

    Es ist halt jetzt so, wenn der Timer true ist dann wird er selbst wieder zurückgesetzt, die zeitspanne zwischen dieser abfrage und der Abfrage zum Setzen des Merkers ist so kurz dass es zufall wäre wenn der timer genau dann true ist und die Zeile zuvor noch nicht.

    mfG René

  7. #7
    olafhahn ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    24.01.2014
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    wir das SPS Programm nich Zyklisch, also Zeilenweise, abgearbeitet

    folgender AWL Code bekomme ich wenn ich von KOP auf AWL umschalte:

    U(
    U "m_true"
    UN T 388
    L #Zeit_ind2
    SE T 388
    NOP 0
    NOP 0
    NOP 0
    U T 388
    )
    S M 399.5
    NOP 0
    NOP 0


    Gehen wir von folgender Situation aus, das die Zeit abgelaufen ist, und der Timer true ist. Dann muss doch bevor er wieder zurückgesetzt wird ersteinmal im gleichen Zyklus 5 Zeilen weiter den Merker setzen. Und erst im nächsten Zyklus den Timer wegen UN T388 wieder zurücksetzen. Oder habe ich da jetzt nen Denkfehler ?

  8. #8
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.191
    Danke
    923
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Zitat Zitat von vollmi Beitrag anzeigen
    die zeitspanne zwischen dieser abfrage und der Abfrage zum Setzen des Merkers ist so kurz dass es zufall wäre wenn der timer genau dann true ist und die Zeile zuvor noch nicht.
    Du weißt aber schon, daß SPS in unheimlich kurzer Zeit jeden denkbaren Zufall generieren?

    Im übrigen ist es "schon immer" so, daß man freilaufende selbst-resettende S5Timer nur zuverlässig auswerten kann, wenn man den Timer.Q auf einen Merker legt und diesen Merker negiert auf den Timer-Eingang zurückführt (also niemals den Timer.Q direkt auf den eigenen Timer-Eingang). Nur dann ist garantiert, daß das Timer-abgelaufen-Signal 1 Zyklus lang aktiv ist.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  9. #9
    Registriert seit
    22.11.2006
    Ort
    CH
    Beiträge
    3.620
    Danke
    777
    Erhielt 647 Danke für 493 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von olafhahn Beitrag anzeigen
    Gehen wir von folgender Situation aus, das die Zeit abgelaufen ist, und der Timer true ist. Dann muss doch bevor er wieder zurückgesetzt wird ersteinmal im gleichen Zyklus 5 Zeilen weiter den Merker setzen.
    Nö, wieso auch? Der Timer ist true, du fragst in mit UN ab und setzt ihn damit zurück, jetzt ist er nicht mehr true und kann den Merker also nicht setzen, die Chance dass er in dieser nächsten Zeile aber gerade true wird ist ja verschwindend klein (und wird kleiner je grösser das Programm und je langsamer der Prozessor wird).

    würdest du den Timer vor dem Reset abfragen wäre die Chance grösser dass das Merkersetzen funktioniert. Aber der Gang über den Merker "is the way to go"

    Und erst im nächsten Zyklus den Timer wegen UN T388 wieder zurücksetzen. Oder habe ich da jetzt nen Denkfehler ?
    Im gegensatz zu IEC Timer können S5 Timer jederzeit abgefragt werden. Ein IEC Timer wird aber erst nach dem Call upgedatet (aber auch da gibt es Probleme wenn man die Instanz direkt als reset nutzt)

    mfG René

Ähnliche Themen

  1. Mitsubishi: Timer-Problem
    Von franzz im Forum Sonstige Steuerungen
    Antworten: 3
    Letzter Beitrag: 15.12.2007, 18:32
  2. problem mit timer
    Von linuxluder im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 06.11.2007, 16:41
  3. Step7 Timer problem
    Von Schlapi im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 28.01.2007, 13:02
  4. Timer Problem !!!
    Von Ma_su im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 04.04.2006, 15:12
  5. Timer problem
    Von spooki01 im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 14.07.2003, 10:49

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •