Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: Bibliothek V12 lässt sich nicht in V12 SP1 einlesen

  1. #1
    Registriert seit
    18.10.2009
    Beiträge
    220
    Danke
    71
    Erhielt 17 Danke für 16 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    habe vor längerer Zeit mit TIA V11 experimentiert und meine alten Step7 V5.5 Bibliotheken über ein migriertes Dummy-Programm nach V11 reingeholt und ordentlich strukturiert in V11 abgelegt. Danach hab ich auf V12 hochgerüstet. Fragt mich bitte nicht mehr wie ich das damals gemacht hab das ich dann einen Satz V12-Bibliotheken hatte. Zu der Zeit konnte ich die Bibliothek noch öffnen und Bausteine bearbeiten. Habe seither aber nichts mehr mit TIA gemacht und auch gibt es den Rechner nicht mehr. Nun soll es für mich losgehen und habe auf einem neuen Rechner TIA V12 SP1 installiert. Es ist die selbe Software und Lizenz, nur eben gleich mit SP1.
    Wenn ich nun versuche die V12 Bibliothek in V12 SP1 zu öffnen kommt ein Störungsfenster mit dem Text: "Bibliothek kann nicht geöffnet werden, da notwendige Produkte fehlen. Um Bibliothek zu öffnen müssen weitere Produkte installiert werden." Das Fenster unterhalb dieses Textes, in welchem die Produkte aufgeführt sein sollten, ist allerdings leer. Und wie gesagt, es ist die das selbe Softwarepaket, vollständig installiert, richtig lizensiert, nur eben als SP1-Version.

    Kann mir jemand sagen wie ich rausbekomme was da fehlt, bzw, wie ich meine V12-Bibliothek in eine V12 SP1 migriere?
    Grüßele vom Bärle
    Zitieren Zitieren Bibliothek V12 lässt sich nicht in V12 SP1 einlesen  

  2. #2
    Bär1971 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    18.10.2009
    Beiträge
    220
    Danke
    71
    Erhielt 17 Danke für 16 Beiträge

    Standard

    Zusätzliche Infos:
    Habe gerade ausprobiert meine V11-Bibliotheken hochzurüsten, TIA stürzt mit unbenanntem Programmfehler ab.
    Habe die Bausteine der V11 Bibliothek nun in ein V11 Projekt kopiert. Beim Versuch das Projekt zu übersetzen oder hochzurüsten erliegt TIA V12 SP1 dem selben Programmfehler. Damals unter V11 ging das mit dem Benutzen und Übersetzen noch einwandfrei.

    Kann ich nun meine ganzen Vorlagen in die Tonne kippen und muss ich bei 0 anfangen? Endlich hab ich meinen Boss davon überzeugen können das TIA was ganz tolles ist und nun das... Meine derzeitigen Empfindungen zu TIA? Gehört in den Müll der Scheiß, und für sowas wollen die auch noch ein Schweinegeld.... Neue Version und nichts funktioniert mehr....
    Grüßele vom Bärle

  3. #3
    Bär1971 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    18.10.2009
    Beiträge
    220
    Danke
    71
    Erhielt 17 Danke für 16 Beiträge

    Standard

    Bin wieder einen Schritt weiter...

    Das Problem beginnt, sobald man einen Datenbaustein öffnen will, in dem Strukturen (Datentypen) verwendet werden, bzw. eine Struktur (PLC-Datentyp) öffnen will. Mit V11 ging das noch einwandfrei. Also vermute ich, das nur die Datentypen dafür verantwortlich sind, das keine Projekte und Bibliotheken übersetzt oder hochgerüstes werden können.

    Wer kann helfen damit ich nicht alles was Datentypen (früher UDT´s) verwendet neu programmieren zu müssen?
    Grüßele vom Bärle

  4. #4
    Bär1971 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    18.10.2009
    Beiträge
    220
    Danke
    71
    Erhielt 17 Danke für 16 Beiträge

    Standard

    Korrigiere...

    ich kann eine V11 Bibliothek öffnen, ein V11 Projekt öffnen, Bausteine aus der Bibliothek in das Projekt kopieren und speichern. Aber nicht übersetzen oder hochrüsten ohne Absturz. Ich kann Bausteine die keine DB´s referenzieren welche Datantypen beinhalten auch einzeln übersetzen. Aber: Ich kann diese Bausteine nicht öffnen ohne Programmabsturz. Also akzeptiert TIA V12 SP1 nichts was aus einer niederen Version kommt (V11 oder V12 ohne SP1).

    Wie gesagt, wer kann mir hier helfen das ich mit TIA anfangen kann zu arbeiten ohne alles neu zu erfinden?
    Grüßele vom Bärle

  5. #5
    Registriert seit
    25.08.2009
    Beiträge
    25
    Danke
    0
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Hi das geht eigendlich ganz easy.
    Deine V11 Bibliothek rufst du rechts unten unter globale Bibliotheken auf und mit Rechtsklick auf deine V11 Version sagst du das du sie hochrüsten möchtest.
    Alle meine V11 Bibliotheken seien es Bilder fürs Display oder FB , FC , OB oder DB da hat Tia V12 noch nie gebockt.

  6. #6
    Bär1971 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    18.10.2009
    Beiträge
    220
    Danke
    71
    Erhielt 17 Danke für 16 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    wie gesagt: Absturz sobald man versucht zu übersetzen oder hochzurüsten
    Grüßele vom Bärle

Ähnliche Themen

  1. TIA TIA V12 SP1 Update 2
    Von The_Hacker im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 02.10.2013, 07:23
  2. Antworten: 19
    Letzter Beitrag: 10.08.2013, 17:02
  3. TIA OSCAT Bibliothek für V12
    Von rogseut im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 28.07.2013, 12:39
  4. TIA Tia V12 Aus - Einlesen
    Von Henschelturm im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 21.06.2013, 20:17
  5. Bibliothek lässt sich nicht öffnen
    Von Anger im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 25.05.2010, 13:02

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •