Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: OB35 wird nicht auf CPU uebertraegt

  1. #1
    Registriert seit
    22.10.2012
    Beiträge
    17
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Beitrag


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Alle zusammen,

    Es handelt sich um einen PID Regler (FB41, Cycle: 30ms), der in einem OB35 integriert wurde. CPU: 314IFM, Analogseingang EW129 und Analogsausgang AW128, FC105,106 wurden benutzt. Nun, als ich das Project auf CPU uebertrage, wurden alle (OB1, FBs, FCs, DBs usw) uebertraegt ausser OB35.
    Woran kann das Problem liegen?
    Danke im voraus

    Gruss
    Gavriil
    Zitieren Zitieren OB35 wird nicht auf CPU uebertraegt  

  2. #2
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.163
    Danke
    921
    Erhielt 3.286 Danke für 2.655 Beiträge

    Standard

    Erstens: Woran hast Du gemerkt, daß der OB35 nicht übertragen wurde?
    Gab es vielleicht eine Fehlermeldung? Wie lautete die?
    Gibt es einen diesbezüglichen Diagnosepuffer-Eintrag?

    Zweitens: überprüfe Deine Angabe "EW129" - die 314IFM hat keinen Analogeingang EW129.
    Meinst Du den zweiten Analogeingang an den Pins 11/12/13? Der heißt PEW130.

    Drittens: der Analogausgang heißt PAW128

    Harald
    Geändert von PN/DP (26.01.2014 um 18:32 Uhr)
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  3. Folgender Benutzer sagt Danke zu PN/DP für den nützlichen Beitrag:

    Rilos (26.01.2014)

  4. #3
    Registriert seit
    30.08.2003
    Beiträge
    2.196
    Danke
    30
    Erhielt 258 Danke für 229 Beiträge

    Standard

    Hallo,

    versuchs mal mit PEW und PAW - das ist sowieso sinniger. Sonst brauchst du das auch nicht im OB35 machen. Da hast du keine aktuellen Werte des EW und das AW geht auch nicht gleich raus.

    Und wie schon erwähnt - EW129 ist komisch.

    André
    www.raeppel.de
    mit innovativen SPS-Tools schneller ans Ziel ....

  5. Folgender Benutzer sagt Danke zu sps-concept für den nützlichen Beitrag:

    Rilos (26.01.2014)

  6. #4
    Rilos ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    22.10.2012
    Beiträge
    17
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich grusse Sie Harald,
    Das Uebertragen wird unterbrochen wenn die Reihe von OB35 ankommt. Wenn ich den Misserfolg von OB35-Uebertragen annehme, wird der Prozess mit den anderen Bausteinen weitergefuert. Die Fehlermeldung lautet: 294:23
    Wie komme ich zu solchen Diagnosepuffer-Eintrag? Habe ich es nicht bemerkt.
    Tatsaechlich, gibt es keinen EW129 auf 314IFM. Ich hab's korrigiert, trotzdem bleibt das Proble.
    Mein Step7 ist auf Englisch. Ich habe den QW128 und IW130 eingetragen. Koennte es ein Problem geben?

  7. #5
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.163
    Danke
    921
    Erhielt 3.286 Danke für 2.655 Beiträge

    Standard

    314IFM Handbücher
    siehe besonders das Anschlussbild der CPU 314 IFM im Handbuch "CPU-Daten" Seite 1-56
    aber natürlich auch die anderen technischen Daten wie "Prozessabbild (nicht einstellbar): 128 Byte / 128 Byte"

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  8. #6
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.163
    Danke
    921
    Erhielt 3.286 Danke für 2.655 Beiträge

    Standard

    Zitat Zitat von Rilos Beitrag anzeigen
    Mein Step7 ist auf Englisch. Ich habe den QW128 und IW130 eingetragen. Koennte es ein Problem geben?
    Die Analogeingänge liegen außerhalb vom Prozessabbild, deshalb ist nur ein Zugriff via Peripherieadresse möglich:
    PEW130 = PIW130
    PAQ128 = PQW128

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  9. #7
    Rilos ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    22.10.2012
    Beiträge
    17
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke André,
    Tatsaechlich, gibt es keinen EW129 auf 314IFM. Ich hab's korrigiert, trotzdem bleibt das Problem.

    Mein Step7 ist auf Englisch. Ich habe den QW128 und IW130 eingetragen. Koennte es ein Problem geben?
    Ich benutze PID Regler (FB41) und deswegen sagt man, ist es sinnvoll statt OB1 das OB35 zu benutzen.

  10. #8
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.163
    Danke
    921
    Erhielt 3.286 Danke für 2.655 Beiträge

    Standard

    Diagnosepuffer der CPU ansehen:
    Rechtsklick auf CPU-Symbol > Zielsystem > Baugruppenzustand (Ctrl+D)
    Rightclick on CPU-symbol > PLC > Module Information (Ctrl+D)

    Die Sprache der Programmoperationen kann man umstellen:
    Extras > Einstellungen > Sprache > Mnemonik (x) Deutsch (oder (x) Englisch)
    Options > Customize > Language > Mnemonics (x) German (or (x) English)

    Zitat Zitat von Rilos Beitrag anzeigen
    Ich benutze PID Regler (FB41) und deswegen sagt man, ist es sinnvoll statt OB1 das OB35 zu benutzen.
    Am FB41 muß man am Eingang CYCLE angeben, in welchem Zeitabstand der FB41 aufgerufen wird - diese Angabe stimmt nur, wenn der FB41 in konstantem Zeitraster aufgerufen wird --> deshalb ist es eine gute und bewährte Idee, den FB41 im OB35 aufrufen.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  11. #9
    Registriert seit
    12.03.2011
    Ort
    Erzgebirge
    Beiträge
    247
    Danke
    77
    Erhielt 29 Danke für 27 Beiträge

    Standard

    Versuche doch mal probeweise, den Programmcode zu verkürzen.
    Die 3xxIFM sind schon etwas älter. Vielleicht ist dein OB35 größer als die erlaubte Bausteingröße.

    Gruß Holger

  12. #10
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.163
    Danke
    921
    Erhielt 3.286 Danke für 2.655 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    314 IFM maximale Bausteingröße OB/FB/FC: 8kB

    Meldung 294:23 Der Baustein AAxx konnte nicht kopiert werden. Soll der Kopiervorgang fortgesetzt werden ?
    Zitat Zitat von Step7 Fehler Meldung 294:23
    Der Baustein AAxx konnte nicht kopiert werden. Soll der Kopiervorgang fortgesetzt werden ?
    ...
    U: Der Baustein verwendet Operanden außerhalb des Bereichs der CPU (z.B. EW128 bei S7-300 CPU).
    A: Überprüfen Sie, den Baustein bezüglich der verwendeten Adressen ob diese nicht den in der Eingesetzten CPU den erlaubten Adressbereich überschreiten.

    U: Der Baustein verwendet Anweisungen, die in der CPU nicht realisiert sind (z.B. ENT bei S7-300 CPU).
    A: Überprüfen Sie den Baustein bezüglich der verwendeten Befehle anhand der Operationsliste für die eingesetzte CPU.
    ...
    Harald
    Angehängte Grafiken Angehängte Grafiken
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

Ähnliche Themen

  1. S7-300 CPU wird nicht gefunden
    Von prime1337 im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 22.02.2013, 11:34
  2. Antworten: 2
    Letzter Beitrag: 29.11.2011, 00:55
  3. CPU wird nicht im S7 Manager angezeigt
    Von Susi im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 09.04.2010, 16:02
  4. CPU wird nicht angezeigt
    Von Erdferkel im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 25.05.2009, 15:27
  5. S7 CPU 317F-2DP wird nicht gefunden
    Von HaeM im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 17.11.2008, 07:33

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •