Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: kein aktiver Partner

  1. #1
    Registriert seit
    10.03.2011
    Beiträge
    17
    Danke
    12
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo liebe SPS-Gmeinde,

    hab mal wieder ein Problem. Wir tauschen gerade unsere alten SPSen (314 c2-DP Version 1.0) gegen neuere Modelle (314 c2-DP/PN Version3.3 aus. Wir nutzen die SPSen auf Boards ausschließlich für Schulungen.

    Seitdem Austausch habe ich immer wieder für mich unlösbare Probleme mit dem Übertragen auf die SPSen. Für mich nicht nachvollziehbar erhalte ich bei SPSen, die am Tag zuvor noch hervorragrend funktioniert haben, auf einmal die folgende Fehlermeldung beim Übertragen (per USB-Adapter Siemens MPI/DP): "Es kann kein aktiver Partner gefunden werden".
    Egal was ich versuche, helfen tut nur eine neue Memorykarte (die gehen mir langsam aus ).
    Ich weiß natürlich nicht, was die Schüler vorher gemacht haben, werde ja im Prinzip gerufen, wenn das Problem auftritt, aber wir hatten das Problem in den vergangenen 10 Jahren mit den alten 314ern nie.
    Ich arbeite mit den Schülern sowohl nicht vernetzt als auch mit der Vernetzung über PROFIBUS DP. Umstellen der Schnittstelle von MPI auf PROFIBUS löst das Problem nicht.

    Was kann eine Fehlerquelle sein und wie rette ich meine Memorycards? Kann beim Zusammenbau irgendwas schiefgelaufen sein?

    Bin für jede Hilfe dankbar,
    Liebe Grüße,
    Neil
    Geändert von NeilYoung (28.01.2014 um 21:02 Uhr)
    Zitieren Zitieren kein aktiver Partner  

  2. #2
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.207
    Danke
    927
    Erhielt 3.293 Danke für 2.662 Beiträge

    Standard

    PG/PC-Schnittstelle einstellen > <dein_Adapter>(MPI) > Eigenschaften > PG/PC ist einziger Master
    hast Du schon versucht?

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  3. Folgender Benutzer sagt Danke zu PN/DP für den nützlichen Beitrag:

    NeilYoung (28.01.2014)

  4. #3
    NeilYoung ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    10.03.2011
    Beiträge
    17
    Danke
    12
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Wow! Das wars tatsächlich danke. Hab´s bei drei SPSen probiert hat überall geklappt.
    Die vierte (315 f DP/PN) meldet "der Bus ist gestört" beim Übertragen. Hast da auch eine Idee?

    Kannst mir in kurzen Sätzen erklären, wieso es mit dem gesetztem Flag funktioniert? Erwartet die SPS bei Flag offen einen anderen Master und gibt mir keine Schreibrechte oder wie?

    Danke aber auf alle Fälle!
    Neil

  5. #4
    Registriert seit
    16.03.2006
    Ort
    Franken
    Beiträge
    3.798
    Danke
    30
    Erhielt 917 Danke für 798 Beiträge

    Standard

    das flag wird verwendet wenn der Partner in dem Betriebsmodus DP-Slave arbeitet, selber also keine Masterfunktionalität (Token etc.) sendet.
    Normalerweise machen das solche Geräte wie Umrichter , Et200 etc. Aber beio der CPU kann man auch einen DP-Slave modus aktivieren über HWConfig und das scheint
    heir passiert zu sein

  6. #5
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.207
    Danke
    927
    Erhielt 3.293 Danke für 2.662 Beiträge

    Standard

    Damit das PG eine eventuell vorhandene Kommunikation auf dem MPI oder Profibus nicht stört, "hört" der Programmieradapter erstmal eine Weile mit auf dem Bus, um die verwendeten Timings und Teilnehmeradressen zu erfahren.
    Wenn gar keine Kommunikation läuft, dann kann der Adapter lange warten... dann sagt man ihm, er ist der einzige Master und er legt gleich los und zwingt dem Bus SEINE Timings auf.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  7. #6
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.207
    Danke
    927
    Erhielt 3.293 Danke für 2.662 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von NeilYoung Beitrag anzeigen
    Die vierte (315 f DP/PN) meldet "der Bus ist gestört" beim Übertragen. Hast da auch eine Idee?
    Diese CPU scheint auf der Schnittstelle zu kommunizieren (oder es zumindest zu versuchen) oder der Programmieradapter benutzt die selbe Busadresse wie die CPU oder eine andere Baudrate. Hier ist es nicht gut, wenn der Programmieradapter auf "Einziger Master" steht. Damit das Mithören/Aufsynchronisieren des Programmieradapters auf den Bus schneller geht, sollte im Projekt des Masters bei den Eigenschaften des PROFIBUS > Netzeinstellungen > Busparameter das "zyklisches Verteilen der Busparameter" eingeschaltet sein.

    Ob auf dem Bus bzw. der MPI/Profibus-Schnittstelle bereits kommuniziert wird kann man so checken:
    PG/PC-Schnittstelle einstellen > bei den Adapter-Eigenschaften das "Einziger Master" ausschalten
    dann unter der Schaltfläche "Eigenschaften" die Schaltfläche "Diagnose" klicken (die gibt es allerdings nicht bei allen Programmieradaptern)
    In der Diagnose dann oben die Schaltfläche "Testen" klicken, dann kommt entweder eine Fehlermeldung:
    Code:
    Fehler 0x031a: Kein aktives PROFIBUS/MPI Netz gefunden. Wenn der CP dieses PC's 
    die einzige aktive Baugruppe sein soll (z.B. reiner DP-Master-Betrieb), muß die 
    Einstellung <PG/PC ist einziger Master am Bus> aktiviert sein.
    oder "O.K." und eine Auflistung der Busparameter:
    Code:
    O.K.
    
    Busparameter:
    Baudrate:                                      187.50 kbit/s
    Höchste Stationsadresse (HSA):                 31
    Min. Protokollbearbeitungszeit (Min Tsdr):     20 tBit
    Max. Protokollbearbeitungszeit(Max Tsdr):      400 tBit
    Auslösezeit (Tset):                            12 tBit
    Modulatorausklingzeit (Tqui):                  0 tBit
    Warte-auf-Empfang-Zeit (tSlot):                415 tBit
    Gap-Aktualisierungsfaktor:                     5
    Anzahl  Aufrufwiederholungen (Retry Limit):    2
    Token-Umlaufzeit Soll (Ttr):                   9984 tBit
    Siemens AG, SOFTNET PB, HW:ASPC2 STEP E2 , SW:V 07.01.01.3577 Feb  3 2009
    Harald
    Angehängte Grafiken Angehängte Grafiken
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

Ähnliche Themen

  1. Antworten: 1
    Letzter Beitrag: 10.07.2013, 18:52
  2. Antworten: 4
    Letzter Beitrag: 12.04.2010, 16:08
  3. Antworten: 0
    Letzter Beitrag: 12.09.2009, 20:06
  4. Anzahl aktiver Meldungen als Ganzzahl
    Von Querdenker im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 06.11.2008, 15:24
  5. Antworten: 1
    Letzter Beitrag: 05.06.2008, 18:57

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •