Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: 315-2DP KTP Panel Problem....4Panel und nur 3 gehn....

  1. #1
    Registriert seit
    21.11.2004
    Beiträge
    154
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    wir haben ein Problem mit den KTP600 und 1000 Touchpanels und zwar:

    haben wir einen 315-2DP als Master DP 1,5MB, MPI 187,5kb.

    3xPanel und einen IM am Profiibus und ein Panel am MPI.

    Alle Panel funktionieren als einzelnes und bis zu 3, das 4te Panel was man dazuschaltet geht nicht Online! Immer das letzte das man einschaltet geht nicht Online!
    Die Panel sind als Slave eingerichtet, alle unterschiedliche Adressen..
    Im der CPU bei Kommunikation sind 12 Verbindungen frei! 3xPanel + 1xPG = 16max..

    Wie kann das kommen? Gibt es einen Trick oder ist das ein BUG?!?!? Wir wissen da nicht mehr weiter

    Hoffe jemand hat einen Tipp.
    Zitieren Zitieren 315-2DP KTP Panel Problem....4Panel und nur 3 gehn....  

  2. #2
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.181
    Danke
    923
    Erhielt 3.289 Danke für 2.658 Beiträge

    Standard

    Deine CPU hat wohl nicht genug freie Kommunikationsressourcen - wahrscheinlich unnötig für S7-Basiskommunikation reserviert?
    Verringere in HW Konfig bei der CPU die Anzahl reservierter Verbindungen für S7-Basiskommunikation. Erhöhe gleichzeitig die Anzahl reservierter OP-Verbindungen auf mindestens 4.
    Wieviele "geplante" Verbindungen braucht Deine CPU?

    PS: Warum sind Deine Panels als DP-Slave in HW Konfig? Brauchst Du die DP-Direkttasten-Funktionalität oder willst Du die Panels überwachen?

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  3. #3
    Registriert seit
    21.11.2004
    Beiträge
    154
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo,

    also wenn ich online reinguckt. Sind 12 frei. Und belegt 3 OP 1 PG.

    Und reserviert sind über all nur 1. Sind ja noch genug frei...Oder ist die Reservierung anders zu sehn?

  4. #4
    Registriert seit
    21.11.2004
    Beiträge
    154
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Die CPU ist ja Master....und ich habe im WinCC den Hacken "Einziger Master am Bus" entfernt...Ist es denn kein Slave?

  5. #5
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.181
    Danke
    923
    Erhielt 3.289 Danke für 2.658 Beiträge

    Standard

    Zitat Zitat von Lars123 Beitrag anzeigen
    also wenn ich online reinguckt. Sind 12 frei. Und belegt 3 OP 1 PG.

    Und reserviert sind über all nur 1.
    Also liegt es nicht an zu wenig freien Kommunikationsressourcen. Trotzdem schadet es nicht, 4 OP-Verbindungen zu reservieren wenn man schon weiß, daß man 4 OP hat.


    Zitat Zitat von Lars123 Beitrag anzeigen
    Die CPU ist ja Master....und ich habe im WinCC den Hacken "Einziger Master am Bus" entfernt...Ist es denn kein Slave?
    Der Haken muß tatsächlich entfernt werden, weil ja noch ein DP-Master vorhanden ist. Das ist soweit korrekt.

    Allerdings sind die Panels keine Slaves, sondern aktive Teilnehmer, welche selbst Kommunikationsaufträge/-anfragen an andere Busteilnehmer auslösen - wenn ihnen noch genug Kommunikationszeit von den anderen aktiven Teilnehmern übrig gelassen wurde. Deshalb ist es wichtig, daß NetPro von der Existenz der 4 Panels weiß um die nötigen Bus-Timings korrekt zu berechnen (insbesondere die Target-Rotation-Time (Ttr)), welche dann von allen aktiven Teilnehmern eingehalten werden müssen. Wenn also in Deinem Projekt in NetPro nicht 3 Panels als aktive Teilnehmer (HMI Station) am Profibus vernetzt zu sehen sind, dann muß dieser Fakt dem NetPro manuell mitgeteilt werden: Eigenschaften des Profibus > Netzeinstellungen > Optionen > Netzteilnehmer > folgende Netzkonfiguration berücksichtigen > Aktive Teilnehmer - hier muß bei Dir eine 3 eingetragen sein oder manuell eingetragen werden. Damit man diesen manuellen Eingriff in die Berechnung der Netztimings machen kann, muß das Profibus-Profil auf Standard, Universell oder Benutzerdefiniert eingestellt sein.

    Besser ist aber, für die nicht in dem Projekt vorhandenen realen Panels Dummy-Panels einzufügen (HMI Station mit leerem Projekt). Damit wird dann als zweiter Effekt auch gleich die Busadresse reserviert.

    Kann es sein, daß Deine 3 Panels nur als 1 Panel im Projekt oder gar in einem externen Projekt projektiert sind und dann einfach nur geklont wurden? Das das NetPro gar nichts von 3 Panels weiß?


    Zitat Zitat von PN/DP Beitrag anzeigen
    PS: Warum sind Deine Panels als DP-Slave in HW Konfig? Brauchst Du die DP-Direkttasten-Funktionalität oder willst Du die Panels überwachen?
    Willst Du die Frage nicht beantworten oder verstehst Du sie nicht?
    Ich vermute einfach mal, daß Du nicht weißt warum ich gefragt habe - weil Du vermutlich gar nicht weißt, warum Deine Panels als DP-Slaves im Projekt sind. Dies wird nämlich aus Unkenntnis oft falsch gemacht. Die Panels werden nur dann als DP-Slaves in HW Konfig projektiert, wenn man die DP-Direkttasten-Funktionalität nutzen will oder wenn man das Vorhandensein des Panels am Profibus so überwachen will, daß Busfehler signalisiert werden soll, wenn das Panel nicht am Bus kommuniziert. Normalerweise braucht man diese Funktionalität aber nicht und die Panels werden nicht als DP-Slave projektiert.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  6. #6
    Registriert seit
    21.11.2004
    Beiträge
    154
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Willst Du die Frage nicht beantworten oder verstehst Du sie nicht?
    Doch aber ich habe es vergessen zu schreiben


    So heute haben wir einfach mal ein paar Verbindungen für die OP reserviert. Und siehe da es geht?!?! Obwohl vorher noch genug frei zur verfügung standen.!


    Aber danke für die Tips

  7. #7
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.181
    Danke
    923
    Erhielt 3.289 Danke für 2.658 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Schön daß es nun funktioniert.
    Danke für die Rückmeldung woran es gelegen hat. Wieder was dazugelernt.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

Ähnliche Themen

  1. Antworten: 40
    Letzter Beitrag: 01.01.2013, 17:06
  2. Baustein übertragen 315-2DP Problem
    Von 1985zottel im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 21.10.2012, 21:25
  3. Antworten: 5
    Letzter Beitrag: 20.04.2010, 21:09
  4. Hardware Problem CPU 315-2DP
    Von mega-mix im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 14.05.2009, 21:49
  5. 4 OP7 an eine S7 315 2DP-!!!problem!!!???
    Von DenEinen im Forum HMI
    Antworten: 5
    Letzter Beitrag: 29.07.2006, 22:34

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •