Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 26

Thema: Verbindung von S7-300 zu Beckhoff-Panel-PC

  1. #11
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.626
    Danke
    377
    Erhielt 801 Danke für 642 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Man braucht nicht zwangsmässig ein PC Station einzurichten (mit oder ohne Simatic Net).

    Das Thema ist hier gut beschrieben:
    PC Station Grundlagen

    Es gibt 3 Varianten:
    1. Ohne Simatic Net, ohne PC Station. Einfach S7ONLINE anpassen in WinCC Flexible Projekt und auf den PC. Nachteile: Kein Routing, keine Symbolische Variabelanbindung.
    2. Als HMI Station (Ohne Simatic Net). Nachteil: MAC Adresse ist fest konfiguriert.
    3. Mit Simatic Net und PC Station. Nachteil: Zusatzsoftware muss gekauft und installiert werden.

    Probier mal mit Nr. 1. Es sollte klappen und ist der einfachste Variante. Einfach S7ONLINE einrichten, .FWX und .PWX übertragen und los gehts.
    In das WinCC Flexible Projekt pas auf das IP, Rack ("0" für S7-300) und Slot ("2" für S7-300) stimmen.
    Jesper M. Pedersen

  2. #12
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.626
    Danke
    377
    Erhielt 801 Danke für 642 Beiträge

    Standard

    @JoopB.

    Es stimmt etwas nicht in deine Screenshots.
    "HMI IE" ist für Siemens Panele gemeint, nicht für ein PC RT. Für ein PC RT muss es ein "IE Algemein"/"IE General" sein.

    Aus den Siemens Anleitung "Wie kann eine Verbindung zwischen WinCC flexible Runtime (PC/Panel) und S7-300/400 über Industrial Ethernet projektiert werden? ":
    Der CP „IE Allgemein“ ist bei allen Verbindungen von PC Runtime zu einer Steuerung zu verwenden, da andere nicht freigegeben sind.
    Der CP „HMI IE“ ist bei allen Verbindungen von Panel zu einer Steuerung zu
    verwenden. Der CP „HMI IE“ ist nur für die Verbindung mit Panels freigegeben.
    Ist das tatsächlich von ein aktuellen Projekt ?
    Jesper M. Pedersen

  3. #13
    Plinsen ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    11.02.2010
    Beiträge
    17
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Tut mir leid, bin heute nicht eher dazu gekommen.
    Habe jetzt versucht, die RT auf dem Projektierungsrechner zum Laufen zu bringen.
    Die Ethernetadressen sind in WinCC (s. WinCC.jpg) und HW-Konfig (IE-Allgemein s. HWK.jpg) aktualisiert: PC 140.80.0.5 / CP 140.80.0.2
    Und wieder tut sich nichts.
    Was mir aufgefallen ist, und da komme ich zum Bild LAN.jpg, wieso habe ich für einen Lan-Adapter zwei IPs
    Ich komme mit dem Projektierungsrechner ungehindert auf die Steuerung.
    Kann ich prüfen, mit welchem Partner (Adresse) der CP 343 momentan kommuniziert?
    Wie Ihr seht, bin ich noch nicht weiter...
    Vielleicht geben ja die JPGs Aufschluss.

    Plinsen

  4. #14
    Plinsen ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    11.02.2010
    Beiträge
    17
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Sorry, die Bilder:

    HWK.JPG
    HWK.JPG
    LAN.JPG
    LAN.JPG
    NETPRO.JPG
    NETPRO.JPG
    WinCC.JPG
    Wincc.JPG

  5. #15
    Registriert seit
    24.10.2007
    Ort
    Niederlande
    Beiträge
    673
    Danke
    22
    Erhielt 143 Danke für 135 Beiträge

    Standard

    Zitat Zitat von JesperMP Beitrag anzeigen
    @JoopB.

    Es stimmt etwas nicht in deine Screenshots.
    "HMI IE" ist für Siemens Panele gemeint, nicht für ein PC RT. Für ein PC RT muss es ein "IE Algemein"/"IE General" sein.

    Aus den Siemens Anleitung "Wie kann eine Verbindung zwischen WinCC flexible Runtime (PC/Panel) und S7-300/400 über Industrial Ethernet projektiert werden? ":

    Ist das tatsächlich von ein aktuellen Projekt ?
    Est ist ein kleines project auf meine laptop mit 2 bilder welche verbindung macht mit der via ein IE CP mit der 315 und via routing mit der 312 (diese ist via mpi mit die 315 verbunden) .
    Ich habe nur die RT gestartet via die stimulator in Winccflex. Ich probiere das morgen in ein VM mit nur RT auf die VM geinstalliert

    Gruss,
    Joop

  6. #16
    Registriert seit
    24.10.2007
    Ort
    Niederlande
    Beiträge
    673
    Danke
    22
    Erhielt 143 Danke für 135 Beiträge

    Standard

    [QUOTE=Plinsen;489070]Sorry, die Bilder:[\QUOTE]
    Welche windows version brauchen Sie?
    Konte Sie die lean cp pingen von der Beckhof PC?
    Ist die PG/PC schnittstelle auf der Beckhof auf tcp/ip eingesteld?

    Gruss,
    Joop
    Geändert von JoopB (15.04.2014 um 23:32 Uhr)

  7. #17
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.192
    Danke
    925
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Zitat Zitat von Plinsen Beitrag anzeigen
    Und wieder tut sich nichts.
    Was soll sich denn tun? Die WinCC-RT kommuniziert nicht mit der SPS?

    wieso habe ich für einen Lan-Adapter zwei IPs
    Das kommt vom TCP/IP(Auto)
    Ändere die PG/PC-Einstellung auf TCP/IP<netzwerkkarte> - auf keinen Fall (Auto)! Auf Deinem PG und auf dem PC! Und starte die Computer danach neu. Und überprüfe, ob der PC tatsächlich die IP 140.80.0.5 hat. Die wird nicht von der WinCC-Projektierung übernommen sondern muß am PC eingestellt werden. Und gib Deinem PG ebenfalls eine IP-Adresse mit 140.80.0.x

    Kann ich prüfen, mit welchem Partner (Adresse) der CP 343 momentan kommuniziert?
    Da siehst Du nur den Status von projektierten Verbindungen, HMI gehören nicht dazu.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  8. #18
    Registriert seit
    24.10.2007
    Ort
    Niederlande
    Beiträge
    673
    Danke
    22
    Erhielt 143 Danke für 135 Beiträge

    Standard

    Zitat Zitat von JesperMP Beitrag anzeigen
    @JoopB.

    Es stimmt etwas nicht in deine Screenshots.
    "HMI IE" ist für Siemens Panele gemeint, nicht für ein PC RT. Für ein PC RT muss es ein "IE Algemein"/"IE General" sein.

    Aus den Siemens Anleitung "Wie kann eine Verbindung zwischen WinCC flexible Runtime (PC/Panel) und S7-300/400 über Industrial Ethernet projektiert werden? ":

    Ist das tatsächlich von ein aktuellen Projekt ?
    Jesper,

    Heute habe ich in einem leeren VM (Windows XP prof) WinCCflex RT installiert.
    Die RT auf ein Netzlaufwerk nach die VM ubertrage.
    PG / PC-Schnittstelle auf TCP / IP und nach den RT gestartet wurde, war es innerhalb 3sec Online auf beiden CPUs. (der 315 direkt via CP341-1 und der 312C via routing nach MPI)

    In Bezug auf die Netzwerkkarte im PC mit HMI IE Algemein Karten, Diese Karte brauchen SIMATIC NET-Software und der HMI IE funktioniert ohne SIMATIC NET software.

    Gruss,

    Joop

  9. #19
    Plinsen ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    11.02.2010
    Beiträge
    17
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    [QUOTE=JoopB;489099]
    Zitat Zitat von Plinsen Beitrag anzeigen
    Sorry, die Bilder:[\QUOTE]
    Welche windows version brauchen Sie?
    Konte Sie die lean cp pingen von der Beckhof PC?
    Ist die PG/PC schnittstelle auf der Beckhof auf tcp/ip eingesteld?

    Gruss,
    Joop
    Hallo JoopB,
    Ich nutze Win XP SP3.
    Ich kann alle drei Geräte untereinander pingen.
    Die PG/PC-Schnittstelle ist auf TCP/IP eingestellt.

    PN/DP
    Den Adapter 'AUTO' habe ich deaktiviert und den -normalen- eingestellt. Danach hatte ich allerdings beim pingen 'Hardwarefehler' vom PC aus. Geht aber wieder.
    Die IP-Adressen liegen alle wieder bei 140.80.0.x

    Und mit 'wieder tut sich nichts' meine ich die Kommunikation von RT zu SPS.
    Netzwerk-LEDs blinken bei RT-PC und CP. Aber in der HW-Konfig sehe ich unter CP-Eigenschaften-Diagnose eine Vielzahl abgelehnter Verbindungsaufbauversuche.

    Plinsen

    PS:
    wieso schmeißt mich das Forum immer wieder raus, bin ständig wieder abgemeldet und kann nicht senden

  10. #20
    Registriert seit
    24.10.2007
    Ort
    Niederlande
    Beiträge
    673
    Danke
    22
    Erhielt 143 Danke für 135 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Plinsen,

    Wechsel die IE-Algemein (dieser karte braucht Simatic Net 2003 Sp1) mit die HMI IE (rot markiert in beilage) und transferier die RT nag die Beckhoff PC und fur 99%sicher komme sie online.

    Gruss,
    Joop.

    RT HMI IE.JPG

Ähnliche Themen

  1. Keine Verbindung von WinCC zu S7-300
    Von CullenTrey im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 10.09.2010, 07:54
  2. Profibus Panel S7-300
    Von mitsch im Forum HMI
    Antworten: 6
    Letzter Beitrag: 09.02.2010, 10:02
  3. Verbindung Touch Panel
    Von ra212 im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 30.11.2009, 14:27
  4. Beckhoff Panel
    Von kuddel7000 im Forum CODESYS und IEC61131
    Antworten: 3
    Letzter Beitrag: 02.02.2009, 19:47
  5. Erfahrungen Panel PC's BECKHOFF
    Von Pro-J im Forum CODESYS und IEC61131
    Antworten: 1
    Letzter Beitrag: 21.12.2007, 11:47

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •