Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: Konsistenzprüfung TIA

  1. #1
    Registriert seit
    25.10.2013
    Ort
    Castrop-Rauxel
    Beiträge
    177
    Danke
    36
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo

    wer kennt sich mit der Software Inkonsistenz aus? Und was sind die Folgen? Sporadisches Abstürzen? Was kann im "worst case" passieren?

    fehler.JPG

    Danke
    Zitieren Zitieren Konsistenzprüfung TIA  

  2. #2
    Registriert seit
    13.09.2010
    Beiträge
    2.292
    Danke
    178
    Erhielt 375 Danke für 355 Beiträge

    Standard

    .
    Die Konsistenz wird nur offline im Projekt
    geprüft und überwacht.
    Fehler können sein:
    - Zeitstempel von Bausteinen
    - Schnittstellenänderungen von Bausteinen
    - geänderte UDT´s
    In der Projektbearbeitung erscheinen dann
    Fehlermeldungen wie "Zeitstempelkonflikt" o.ä.

    Wenn das Projekt schon in der CPU ist und läuft,
    hast du wahrscheinlich "nur" Abweichungen zwischen
    on- und offline.

    Du kannst dein inkonsistentes Projekt durch ein
    neues Übersetzen in einen konsistenten Zu-
    stand bringen und erneut laden.

    --> Die Vorgehensweise ist im HANDBUCH unter
    Bausteinkonsistenz prüfen (in der Abhängigkeits-
    oder in der Aufrufstruktur) beschrieben.
    kind regards
    SoftMachine

  3. #3
    SanjaDO ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    25.10.2013
    Ort
    Castrop-Rauxel
    Beiträge
    177
    Danke
    36
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Das Projekt ist in der CPU und läuft auch, Abweichungen zwische on- und offline gibt es nicht. Habe auch mehrmals übersetzt und geladen und der Fehler ist geblieben. Was tun?

  4. #4
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Möglicherweise hat dein Fehler was mit "optimiertem Bausteinzugriff" zu tun.

    Sind das migrierte Bausteine oder neu erstellte?

    Vorgehensweise
    Um den Bausteinzugriff einzustellen, gehen Sie folgendermaßen vor:

    1. Öffnen Sie in der Projektnavigation den Ordner "Programmbausteine".
    2. Klicken Sie mit der rechten Maustaste auf den Baustein, dessen Bausteinzugriff Sie ändern möchten.
    3. Wählen Sie im Kontextmenü den Befehl "Eigenschaften".
      Der Eigenschaftsdialog des Bausteins wird geöffnet.
    4. Klicken Sie in der Bereichsnavigation auf "Attribute".
    5. Aktivieren oder deaktivieren Sie die Option "Optimierter Bausteinzugriff".
    6. Bestätigen Sie Ihre Eingaben mit "OK".

  5. #5
    SanjaDO ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    25.10.2013
    Ort
    Castrop-Rauxel
    Beiträge
    177
    Danke
    36
    Erhielt 0 Danke für 0 Beiträge

    Standard

    "optimierter Bausteinzugriff" ist nicht angewählt! Das sind in SCL neu erstellte FB's

  6. #6
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Welche Meldung kommt bei der Inkontinenziaprüfung?

    kann in dem Bild Aufrufstruktur nicht viel rauslesen.

  7. #7
    SanjaDO ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    25.10.2013
    Ort
    Castrop-Rauxel
    Beiträge
    177
    Danke
    36
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Es kommt keine Fehlermeldung. Das Programm wird ohne Fehler übersetzt und auf die CPU geladen. Man kann es nur an der roten Farbe am Baustein sehen (siehe Bild).

    fehler.JPG
    Geändert von SanjaDO (12.05.2014 um 17:19 Uhr)

  8. #8
    Registriert seit
    13.09.2010
    Beiträge
    2.292
    Danke
    178
    Erhielt 375 Danke für 355 Beiträge

    Standard

    .
    Meldungen kommen im Inspektorfenster.
    Die Ansicht dafür musst du anwählen.
    kind regards
    SoftMachine

  9. #9
    SanjaDO ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    25.10.2013
    Ort
    Castrop-Rauxel
    Beiträge
    177
    Danke
    36
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Im Inspektorfenster habe ich beim Übersetzen und Laden auf die CPU keine Warnungen oder Fehlermeldungen....

Ähnliche Themen

  1. [TIA-V11] Rechnet TIA falsch bei SCL
    Von BlackLizzard im Forum Simatic
    Antworten: 43
    Letzter Beitrag: 09.02.2016, 02:59
  2. TIA Kompatibilität TIA Professional <--> TIA Basic
    Von TimeOUT im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 21.08.2015, 19:28
  3. TIA Tia
    Von EK1952 im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 24.04.2014, 11:53
  4. Antworten: 0
    Letzter Beitrag: 06.04.2012, 08:37
  5. Antworten: 0
    Letzter Beitrag: 22.01.2012, 18:59

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •