Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: Zei Passive Verbindungen mit FB 65 Aufbauen??

  1. #1
    Registriert seit
    01.02.2008
    Beiträge
    93
    Danke
    9
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Forum

    Wollte mal wissen ob das möglich ist 2 Passive Verbindungen über Netzwerk an eine SPS und zwei Verschiedene
    Rechner einzurichten.
    CPU hat eine Interne Netzwerkschnittstelle und ist von Siemens.
    Da ich das Problem mit mehreren CPU´S habe ist der Typ erst mal nicht so wichtig.
    Wie kann ich bei einer Passiven Verbindung den passenden Rechner zuordnen wenn der dich einfach anmeldet?

    Ich bedanke mich und wünsche noch einen schönen Tag


    Magus111
    ------------------------------------------------------------------------------------
    Ein Danke schadet niemanden spornt aber an


    Wer Rechtschreibfehler findet soll diese behalten....
    Zitieren Zitieren Zei Passive Verbindungen mit FB 65 Aufbauen??  

  2. #2
    Registriert seit
    20.02.2008
    Beiträge
    332
    Danke
    16
    Erhielt 40 Danke für 37 Beiträge

    Standard

    Durch die IP-Adresse?
    Also wenn das die Lösung sein soll ................................................................................ ......... dann hätte ich gerne mein Problem zurück.

  3. #3
    Registriert seit
    01.02.2008
    Beiträge
    93
    Danke
    9
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo

    Das ist ja gerade mein Problem in den Beispiel wird eine Passive Verbindung OHNE IP Verbindung nur mit ID dargestellt.
    Da steht auch drin das man mehrere damit betreiben kann aber nicht wie ich die ID dem "Rechner" beibringe.

    Hm und ich muss wahrscheinlich auch aufpassen das ich den Baustein während er schon in Bearbeitung ist nicht nochmal aufrufe weil das sonst zu Problemen kommst oder ?

    MFG

    magus111

    Nach dem ich nochmal in das Programm reingeschaut hab ist mir aufgefallen das ich eine UDP Verbindung habe und damit kann ich wahrscheinlich nur einen Rechner erreichen. Also muss ich jetzt wahrscheinlich alles auf TCI / IP umstellen und mich mit der IT anlegen . Oder sehe ich das jetzt komplett falsch?
    Geändert von magus111 (19.05.2014 um 15:07 Uhr) Grund: Zusatzinfo
    ------------------------------------------------------------------------------------
    Ein Danke schadet niemanden spornt aber an


    Wer Rechtschreibfehler findet soll diese behalten....

  4. #4
    Registriert seit
    20.02.2008
    Beiträge
    332
    Danke
    16
    Erhielt 40 Danke für 37 Beiträge

    Standard

    Der FB65 dient doch nur dem Verbindungsaufbau. Zum Senden und Empfange werden die FB64 und FB63 verwendet. Wenn ich micht richtig entsinne, steht die Port-Nummer und IP-Adresse als erstes im Empfangsbereich bzw Sendebereich dieser Bausteine.

    Was meinst Du mit Aufrufen? Aufrufen musst Du den schon im Zyklus, sonst geht die Bearbeitung nicht weiter, nur starten sollst Du Ihn nicht erneut, bevor die Verbindung getrennt wurde.
    Ach ja, Du schreibst was von einer passiven Verbindung, der FB65 baut eine Verbindung aktiv auf - was meinst Du mit passiv?
    Geändert von asci25 (19.05.2014 um 15:24 Uhr)
    Also wenn das die Lösung sein soll ................................................................................ ......... dann hätte ich gerne mein Problem zurück.

  5. #5
    Registriert seit
    22.11.2006
    Ort
    CH
    Beiträge
    3.618
    Danke
    775
    Erhielt 646 Danke für 492 Beiträge

    Standard

    Zitat Zitat von asci25 Beitrag anzeigen
    Ach ja, Du schreibst was von einer passiven Verbindung, der FB65 baut eine Verbindung aktiv auf - was meinst Du mit passiv?
    Der TCON muss schon mitkriegen ob er eine passive oder aktive verbindung aufbauen soll.
    Und da du ja zwei TCON aufrufst (für jede Verbindung einen mit Eindeutiger ID und TSAP) dann weisst du ja wann die Verbindung zu welchem Rechner Online ist (dafür ist der Status da).

    mfG René

  6. #6
    Registriert seit
    01.02.2008
    Beiträge
    93
    Danke
    9
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Guten Morgen

    @ vollmi gehe ich dann recht in der Annahme das wenn ich zwei Rechner mit der SPS verbinden möchte es auch mit der ID und TSAP realisieren kann?
    Was ich noch nicht richtig verstehe ist die ID wie soll der Baustein mitbekommen das es der richtige "Partner" ist und nicht der andere Rechner?
    Muss die ID im Programm des Rechners mit übermittelt werden damit das klappt?
    Sonst ist das doch "Glückssache" welcher Rechner sich wie verbindet....

    Danke
    Magus111
    ------------------------------------------------------------------------------------
    Ein Danke schadet niemanden spornt aber an


    Wer Rechtschreibfehler findet soll diese behalten....

  7. #7
    Registriert seit
    22.11.2006
    Ort
    CH
    Beiträge
    3.618
    Danke
    775
    Erhielt 646 Danke für 492 Beiträge

    Standard

    Einerseits muss natürlich die ip mit der in der verbindungskonfiguration angegebenen partner-IP übereinstimmen. Genauso die tsap. Die id des Partners ist unwichtig das ist siemensintern.

    Mit freundlichen Grüßen René


    Sent from my iPad using Tapatalk

  8. #8
    Registriert seit
    19.07.2010
    Beiträge
    1.288
    Danke
    213
    Erhielt 267 Danke für 233 Beiträge

    Standard

    Moment mal,

    welche Verbindung möchtest du denn machen? TCP/IP oder ISO on TCP?

    Bei TCP/IP gibts keinen TSAP, nur IP-Adresse und Portnummer. Und wenn deine Rechner auf die selbe IP-Adresse aber auf unterschiedliche Ports aufbauen und du genau dafür jeweils eine Verbindung eingerichtet hast passt alles.
    Bei ISO on TCP funktionerts etwas anders, da brauchst du den TASP und die IP-Adresse auf der aktiven Seite.
    mfG Aventinus

  9. #9
    Registriert seit
    22.11.2006
    Ort
    CH
    Beiträge
    3.618
    Danke
    775
    Erhielt 646 Danke für 492 Beiträge

    Standard

    Braucht man bei tcp nicht auch die partnerip? Ich war der Meinung der einzige unterschied zu ISO ist da dass man statt tsap den Port in Übereinstimmung bringen muss.


    Sent from my iPad using Tapatalk

  10. #10
    Registriert seit
    19.07.2010
    Beiträge
    1.288
    Danke
    213
    Erhielt 267 Danke für 233 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    imho ist beim Passiven Verbindungsaufbau über ISO on TCP nur der Partner-TSAP relevant.
    mfG Aventinus

Ähnliche Themen

  1. Passive Informationsanzeige
    Von mabruce im Forum CODESYS und IEC61131
    Antworten: 8
    Letzter Beitrag: 24.05.2013, 08:36
  2. Binären Zähler mit Logo aufbauen
    Von illusion2002 im Forum Sonstige Steuerungen
    Antworten: 11
    Letzter Beitrag: 25.02.2013, 21:34
  3. Antworten: 8
    Letzter Beitrag: 16.02.2012, 17:57
  4. mit Operationsverstärker Schmitt-Trigger aufbauen
    Von Claudi689 im Forum Elektronik
    Antworten: 4
    Letzter Beitrag: 07.06.2011, 08:24
  5. Zei Diff über mehrere Tage errechnen
    Von mst im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 12.12.2007, 12:23

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •