Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 3 von 3

Thema: 3 x CPU 315 mit Profinet verbinden / Probleme mit BSEND an CPU 3

  1. #1
    Registriert seit
    21.05.2014
    Beiträge
    1
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    CPU 315-2 PN/DP V2.6 (Bestellnr: 6ES7 315-2EH13-0AB0)
    Step7 V5.4 SP5

    Vorgehen nach Anleitung der TIA Schulungsunterlage PROFINET mit 2x CPU 315F-2PN/DP.


    wir sitzen gerade an unserem Abschlussprojekt: Vernetzung von 3 Steuerungen über einen Switch. Die Anlage ist schon aufgebaut, jetzt haben wir aber noch ein Problem mit dem Datenaustausch untereinander. Dabei müssen jeweils nur 5 Ein/Ausgänge ausgetauscht werden. Eingerichtet ist alles mit Netpro.
    Wir brauchen nur die Kommunikation der jew. Stationen zum Master.

    Profinet.JPG

    Der Datenaustausch über Master zu Station 1 (Pufferstation: LokaleID1 / PartnerID1) funktioniert über BSEND und BRCV SFB12/SFB13 jeweils mit DB12 und DB13 ohne Probleme.

    Nun soll Station 2 (Hochregal) auch noch eingebunden werden: LokaleID2 / PartnerID2 auch mit SFB12/SFB13 und aber zum Senden/Empfangen im Master mit DB14 und DB15 da ja bereits DB12/13 (von der Pufferstation) im Master vorhanden?!.
    Wo muss der Verbindungsaufbau Aktiv sein?


    Funktioniert das so überhaupt wie wir uns das denken? Wir konnten keinen Verbindungsaufbau zustande bringen obwohl alles ähnlich wie bei Station 1 gemacht wurde.
    ID und R_ID an den jew. Bausteinen sind identisch (W#16#2); für die Länge des Bausteins jew. W#16#1

    Auszüge aus dem Programm liefere ich noch nach.

    Gruß Peet
    Geändert von Techniker.hef (21.05.2014 um 14:42 Uhr)
    Zitieren Zitieren 3 x CPU 315 mit Profinet verbinden / Probleme mit BSEND an CPU 3  

  2. #2
    Registriert seit
    20.02.2008
    Beiträge
    332
    Danke
    16
    Erhielt 40 Danke für 37 Beiträge

    Standard

    ID muss unterschiedlich sein. In NetPro müssen doch 2 Verbindungen eingerichtet sein - daher 2 unterschiedliche ID. Bei der R_ID bin ich momentan nicht sicher, da die Kommunikation auf die Verbindung aufsetzt - ich würde trotzdem auch hier zwei unterschiedliche nehmen.
    Also wenn das die Lösung sein soll ................................................................................ ......... dann hätte ich gerne mein Problem zurück.

  3. #3
    Registriert seit
    24.10.2007
    Ort
    Niederlande
    Beiträge
    673
    Danke
    22
    Erhielt 143 Danke für 135 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Sie habe in Netpro die verbindung geprojektiert mit lokales ID 2 und parter ID 1 , dieser IDs muste auch bei SFC 12/13 ubergeben wurde

    Joop

Ähnliche Themen

  1. Beckhoff BK9103 mit CPU 315-2PN/DP verbinden?
    Von Stephan25 im Forum Feldbusse
    Antworten: 4
    Letzter Beitrag: 24.05.2013, 10:44
  2. Probleme mit CPU 315 DP2 (2AG10)
    Von röhrengertl im Forum Simatic
    Antworten: 16
    Letzter Beitrag: 12.11.2012, 10:32
  3. Probleme mit CPU 315-2 DP und Profibus
    Von olitheis im Forum Simatic
    Antworten: 33
    Letzter Beitrag: 04.06.2009, 14:07
  4. Probleme mit CPU 315 2DP
    Von weißnix im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 13.09.2007, 12:51
  5. CPU's 315 mit Ethernet verbinden
    Von Anonymous im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 12.02.2005, 00:30

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •