Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: S7-Verbindung: Verbindungseigenschaften / Kommunikationsprobleme nach HW-Conf update

  1. #1
    Registriert seit
    28.08.2007
    Beiträge
    140
    Danke
    17
    Erhielt 13 Danke für 11 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Moin,

    Ich habe hier mehrere CPUs mit mehreren S7-Verbindungen. Nach einem Update der Hardware Konfiguration habe ich häufig Probleme, dass eine (manchmal mehrere) Verbindungen hinterher nicht mehr funktionieren. Es kommen Fehler wie, Empfangsbaustein auf Partner seite nicht vorhanden oder noch nie aufgerufen usw. Nachdem ich dann die Instanz DB gelöscht, neu erzeugt und übertragen habe geht es dann wieder. Ich bin verwirrt. Was kann ich machen damit sowas nicht mehr passiert, bzw. hatte jemand schon solche Probleme?

    Zweites (akutes) Problem. Habe an einer CPU HW Konfig. geladen. Diese hat eine passive S7-Verbindung. Nach dem Update der HW, hing der Sende-Baustein Status B#16#19 und keine Änderung der Statusbits, also habe ich wieder die Aktion mit den Instanz DBs versucht. Nun bekomme ich den Fehler 1. Ich muss gestehen, dass ich eine Eigenschaft an der an der Kommunikation beteiligten CP verändert habe. Aber muss ich denn jedesmal, wenn ich HW Konfig. übertrage zusätzlich auch die Verbindungseinstellungen mit NetPro übertragen? Online kann ich sehen, dass die Verbindung aufgebaut ist und vorher hat's auch funktioniert.

    Danke für alle Hinweise.

    Gruß. Sebastian.
    Zitieren Zitieren S7-Verbindung: Verbindungseigenschaften / Kommunikationsprobleme nach HW-Conf update  

  2. #2
    Registriert seit
    13.09.2010
    Beiträge
    2.292
    Danke
    178
    Erhielt 375 Danke für 355 Beiträge

    Standard

    .

    Einige Infos mehr wären ganz gut. Schau´auch mal nach, was deine Statusanzeige bedeutet.

    Also ich lade nach der HW-Konfig stets die Teilnehmer aus NetPro heraus nochmal, um die Verbindungen mitzuteilen.
    Bei zweiseiten Verbingungen sind beide Teilnehmer neu zu laden:


    • Bei der zweiseitig projektierten S7-Verbindung muss nach Anlegen der S7-Verbindung die Projektierung in beide Verbindungspartner geladen werden
    • Bei der einseitig projektierten S7-Verbindung muss nur die eine Station geladen werden, in dessen Verbindungstabelle die S7-Verbindung angezeigt wird
    kind regards
    SoftMachine

  3. #3
    EyeQ ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    28.08.2007
    Beiträge
    140
    Danke
    17
    Erhielt 13 Danke für 11 Beiträge

    Standard

    Hi und danke für die Antwort.

    Die 2. Sache hat sich durch ein neues Laden der Verbindungseigenschaften der CPU mit der veränderten HW-Konf. erledigt. Die Frage war, sollte ich das immer so machen? Nach einer Hardware Änderung immer HW + Netconf einspielen? Beides versetzt die CPU in STOP und dauert in diesem Fall je 10-15min.

    Bei der zweiseitig projektierten S7-Verbindung muss nach Anlegen der S7-Verbindung die Projektierung in beide Verbindungspartner geladen werden
    Bezieht sich nur auf Anlegen der Verbindung oder? Jedoch nicht auf eine Änderung der HW-Konf. (z.B. neue Eingangskarte). Habe ja in diesem Fall eine Änderung an der CP vorgenommen. Möglicherweise ist es nur dadurch notwendig gewesen.


    Die 1. Sache lässt mich immer noch nicht in Ruh. Zwar ist es bisher nicht wieder passiert, da auch keine HW neu geladen wurde, aber will es ja gelöst haben. Angenommen man hat eine Steuerung, auf der ca. 10 Verbindungen projektiert sind. Habt ihr dann eine Schrittkette, damit die einzelnen Verbindungen nicht alle gleichzeitig feuern oder ist das egal? Da das Problem ansich nur nach einem HW-Update also einem CPU Neustart vorkommt, könnte ich mir vorstellen, dass sich da irgendwas aufhängt, wenn alle Übertragungen im selben Zyklus getriggert werden. Es ist eine CPU319. Diese kommuniziert mit ein paar 319er und 315er von ext. CP zu int CP sowie ext. CP. Vielleicht kann mal jemand nen Tipp geben, wie ihr sowas aufbaut. Soviele Verbindungen habe ich eher selten.


    Danke

  4. #4
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.316
    Danke
    932
    Erhielt 3.331 Danke für 2.689 Beiträge

    Standard

    Die Verbindungskonfiguration kann ohne CPU-Stop aus NetPro geladen werden.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  5. #5
    EyeQ ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    28.08.2007
    Beiträge
    140
    Danke
    17
    Erhielt 13 Danke für 11 Beiträge

    Standard

    Hi Harald.

    Das ist mir neu. Bisher habe ich es nie geschafft, die Verbindungskonfiguration über NetPro ohne STOP zu übertragen. Gibt's da einen Trick? Oder funktioniert das nur bei bestimmten Änderungen? Selbst also ich nur eine Eiegnschaft am CP verändert habe und die HW bereits runtergeschickt hatte musste die CPU nochmal in STOP für die Verbindungskonfiguration.

    Gruß. Sebastian.

  6. #6
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.316
    Danke
    932
    Erhielt 3.331 Danke für 2.689 Beiträge

    Standard

    Man kann aus NetPro die Verbindungsprojektierung (und die S7Routing-Infos) in die CPU laden ohne CPU-Stop.
    Station markieren, dann: Zielsystem > Laden im aktuellen Projekt > Verbindungen und Netzübergänge

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  7. Folgender Benutzer sagt Danke zu PN/DP für den nützlichen Beitrag:

    EyeQ (15.07.2014)

  8. #7
    EyeQ ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    28.08.2007
    Beiträge
    140
    Danke
    17
    Erhielt 13 Danke für 11 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ok Danke. Den Weg kannte ich gar nicht. Habe sonst immer an der Station über das Kontextmenu übertragen. Dort gibt es diesen Menupunkt nicht. Werde das demnächst mal ausprobieren.

    Edit 17.07.14:

    Hat tatsächlich geklappt Leider ist es wohl nur bei Verbindungen über ext. CP möglich die Daten ohne CPU Stopp zu laden. Ist eine Verbindung über die int. Schnittstelle projektiert, muss die CPU in STOP.
    Geändert von EyeQ (17.07.2014 um 14:57 Uhr)

Ähnliche Themen

  1. Step 7 Kommunikationsprobleme nach CP-Tausch (CP343-5 FMS)
    Von fk- princess im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 26.09.2013, 16:57
  2. Antworten: 0
    Letzter Beitrag: 26.11.2012, 19:36
  3. Antworten: 9
    Letzter Beitrag: 03.07.2011, 13:15
  4. OP77A nach OS update keine Verbindung
    Von gustave im Forum HMI
    Antworten: 8
    Letzter Beitrag: 30.10.2009, 06:18
  5. Verbindung MP370 nach WinCCfelx update
    Von marcowitte im Forum HMI
    Antworten: 2
    Letzter Beitrag: 02.03.2009, 20:05

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •