Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: Zeitprobleme auf Mod-Bus

  1. #1
    Registriert seit
    04.08.2014
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich bin noch neu hier und traue mich trotzdem, mein Problem zu schildern:

    Als Lieferant eines Subsystems sind wir per Modbus am DCS angebunden.
    Über die S7 (CPU 313, mit CP343) werden nun Signal über den Bus zum DCS
    gesendet und empfangen.
    Die Signal kommen zwar an, aber es dauert bis zu 1 Minute (was ja bei einer
    LWL-Verbindung ewig ist).
    Im Programm benutze ich das Modbus-Modul FB108 mit den passenden Instanz-DB's.
    Kann ein Parameter diesen Zeitdelay auslösen?
    Vielleicht kennt sich jemand hier im Forum aus und hat einen Tipp für mich.

    Danke vorab.
    Zitieren Zitieren Zeitprobleme auf Mod-Bus  

  2. #2
    Registriert seit
    12.11.2007
    Beiträge
    92
    Danke
    1
    Erhielt 5 Danke für 5 Beiträge

    Standard

    Hi,
    nein, da gibt es keinen Parameter, der so eine Verzögerung auslöst.
    In welchem OB hast Du denn den FB108 aufgerufen? Und in welchem Zeitfenster prüft der Koppelpartner, ob eine Anfrage da ist und bearbeitet diese?

    Snape

  3. #3
    o.deimel ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    04.08.2014
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Snape,

    danke für Deine Antwort. Habe nur eingeschränkten Zugang zu meinen Mails, daher erst die späte Antwort:

    Der FB108 wird im OB1 zyklisch aufgerufen.
    Der InstanzDB wird im OB100 initialisiert.

    Bei dem zeitlichen Verzug ist eher meine Antwort auf die Anfrage des DCS gemeint.
    Ich muss allerdings sagen, ich bin der Programmierer der Anwendung. Ich bin als Servicetechniker im Feld
    und soll die Anlage vor Ort in Betrieb nehmen.
    Das heißt die Signal kommen an, aber mit einem großen zeitlichen Verzug.

    Sorry für die unprofessionelle Ausdrucksweise.

    mfG
    Olaf

  4. #4
    Registriert seit
    12.11.2007
    Beiträge
    92
    Danke
    1
    Erhielt 5 Danke für 5 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Also eine Zeitverzögerung gibt es da nicht. Sobald ein Telegramm kommt wird es bearbeitet.
    Wenn ich das richtig lese, dann ist die S7 der Server und der Partner der Client. Der Partner schickt Lese- und Schreibaufträge zur S7-CPU, richtig?
    Die einzige Verzögerung, die es S7-seitig geben kann ist, wenn der Baustein im OB35 oder so aufgerufen wird. Hast Du mal mit Wireshark oder so auf das Netz geschaut, wo die Verzögerung passiert? Vielleicht schickt der Partner auch später weg als er sollte. ???
    Schaust Du direkt im Datenbaustein, wo die Werte ankommen oder schiebst Du die Daten noch irgendwoanders hin? Könnte eine Verzögerung beim "Woanders-hin-schieben" passieren?

Ähnliche Themen

  1. MOD-Bus Slave Simulator für CP-341 RS485 RTU
    Von Wagginator im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 09.06.2011, 10:46
  2. MOD macht nicht was es sollte
    Von Andy082 im Forum Programmierstrategien
    Antworten: 9
    Letzter Beitrag: 21.11.2009, 01:50
  3. Zeitprobleme mit WAGO's MBT.dll
    Von torti im Forum CODESYS und IEC61131
    Antworten: 0
    Letzter Beitrag: 04.05.2009, 21:42
  4. Mod Bus Kommunikation
    Von Anonymous im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 03.11.2005, 19:00

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •