Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: Vorzeichenproblem mit HMI Anzeige von REAL Variablen

  1. #1
    Registriert seit
    25.10.2013
    Ort
    Castrop-Rauxel
    Beiträge
    177
    Danke
    36
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Leute,

    ich habe hier eine S7-1513er CPU und TP1900 Comfort Panel. Ich möchte in einem Ausgabefeld bei einer negativen Realzahl das Minus anzeigen lassen und bei einer positiven das Plus nicht!

    Das Probem ist, dass bei dieser CPU das PLUS auch immer mitangezeigt wird. Das HMI-Variablenformat ist mit s99,99 eingestellt... Hat das jemand eine Lösung oder muss ich das Plus manuell abschneiden?

    Danke!
    Zitieren Zitieren Vorzeichenproblem mit HMI Anzeige von REAL Variablen  

  2. #2
    Registriert seit
    10.07.2013
    Beiträge
    215
    Danke
    6
    Erhielt 46 Danke für 34 Beiträge

    Standard

    entweder mit Vorzeichen oder ohne.

    Du könntest dir natürlich auch ein Minus als Text über eine Variable einblenden wenn der Wert Minus ist.
    Geht nicht gibt's nicht

  3. #3
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.850
    Danke
    78
    Erhielt 800 Danke für 543 Beiträge

    Standard

    lass mal das s beim format weg. dann wird nur bei minus das vorzeichen angezeigt.
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  4. #4
    Registriert seit
    31.10.2013
    Beiträge
    36
    Danke
    3
    Erhielt 6 Danke für 6 Beiträge

    Standard

    Hi,

    einfach 99,999 (ohne s), dann dürfte es gehen.

    Gruß

    Edit: zu spät

  5. #5
    SanjaDO ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    25.10.2013
    Ort
    Castrop-Rauxel
    Beiträge
    177
    Danke
    36
    Erhielt 0 Danke für 0 Beiträge

    Standard

    ja das ist ja das Problem! Wenn ich ohne s eingebe, werden bei negativen Werten Lattenzeune angezeigt und das möchte ich ja nicht.

  6. #6
    Registriert seit
    31.10.2013
    Beiträge
    36
    Danke
    3
    Erhielt 6 Danke für 6 Beiträge

    Standard

    Evtl hat deine Vorgabe (s)99,999 zu wenige stellen vor dem Komma. Du kannst in der Zeile auch manuell weitere Stellen eintragen --> z.B. 9999999999,999

  7. #7
    SanjaDO ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    25.10.2013
    Ort
    Castrop-Rauxel
    Beiträge
    177
    Danke
    36
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von mostrich Beitrag anzeigen
    Evtl hat deine Vorgabe (s)99,999 zu wenige stellen vor dem Komma. Du kannst in der Zeile auch manuell weitere Stellen eintragen --> z.B. 9999999999,999
    JAU!!! Danke das war der Fehler, also ich habe jetzt ohne s eingegeben und der Wert wird auch mit Minus angezeigt!!!!!

    Danke Leute

  8. #8
    SanjaDO ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    25.10.2013
    Ort
    Castrop-Rauxel
    Beiträge
    177
    Danke
    36
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Offensichtlich ist dieses s nur auf Pluszeichen bezogen

Ähnliche Themen

  1. Anzeige von Time-Variablen
    Von wiede im Forum HMI
    Antworten: 16
    Letzter Beitrag: 15.01.2013, 17:29
  2. Antworten: 3
    Letzter Beitrag: 18.04.2012, 16:00
  3. Protool Anzeige von TIME Variablen
    Von hank12 im Forum HMI
    Antworten: 4
    Letzter Beitrag: 21.07.2009, 12:37
  4. Anzeige von verwendeten Variablen
    Von Kala Schnikov im Forum HMI
    Antworten: 0
    Letzter Beitrag: 24.04.2009, 13:54
  5. Darstellung von Real-Variablen im HMI
    Von dietere im Forum HMI
    Antworten: 1
    Letzter Beitrag: 14.01.2008, 23:14

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •