Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: AGSend und AG Recv an Vipa CPU

  1. #1
    Registriert seit
    18.05.2007
    Beiträge
    71
    Danke
    17
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich habe mehrere s7 300-Steuerungen mit einer s7 1500 verbunden, das läuft über Iso On TCP und AGSend und AG Recv auf der 300er Seite problemlos.
    Wenn ich jetzt aber eine Vipa 315-4 NE12 anbinden will, geht diese in Stop, sobald ich den FC5 oder FC5 lade. (AGSend und AGRecv).

    Die Diagnose meldet folgendes:

    Ereignis 4 von 100: Ereignis-ID 16# 4563
    STOP durch Peripheriezugriffsfehler (OB nicht geladen oder nicht möglich, bzw. kein FRB vorhanden)
    Unterbrechungstelle im Anwenderprogramm: Zyklisches Programm (OB 1)
    Prioritätsklasse: 1
    FC-Nummer: 5
    Bausteinadresse: 94
    Bisheriger Betriebszustand: RUN
    Angeforderter Betriebszustand: STOP (intern)
    interner Fehler, kommendes Ereignis
    07:55:54.035 18.08.2014
    (Kodierung: 16# 4563 FF84 8C70 0101 0005 005E)

    Ereignis 5 von 100: Ereignis-ID 16# 2942
    Peripherie-Zugriffsfehler, lesend
    P-Bereich , Wortzugriff, Zugriffsadresse: 292
    FC-Nummer: 5
    Bausteinadresse: 94
    Angeforderter OB: Peripheriezugriffsfehler-OB (OB 122)
    Prioritätsklasse: 1
    externer Fehler, kommendes Ereignis
    07:55:54.035 18.08.2014
    (Kodierung: 16# 2942 017A 8C20 0124 0005 005E)

    Was mache ich falsch?

    Vielen Dank schon mal Vorab.

    Grüße
    Harri
    Zitieren Zitieren AGSend und AG Recv an Vipa CPU  

  2. #2
    Registriert seit
    22.11.2006
    Ort
    CH
    Beiträge
    3.618
    Danke
    775
    Erhielt 646 Danke für 492 Beiträge

    Standard

    Jetzt mal ohne mich mit der VIPA speziell auseinander zu setzen, hört sich dies:
    P-Bereich , Wortzugriff, Zugriffsadresse: 292

    So an als gäbe es den CP mit der Hardwareadresse 292 nicht. HW geladen? CP Vorhanden?

    mfG René

  3. #3
    Registriert seit
    18.05.2007
    Beiträge
    71
    Danke
    17
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Ja genau, das habe ich auch nicht so richtig verstanden.
    Bei meiner Verbindung wird die Laddr #120 (entspricht ja Dez 28angegeben, hab ich gemacht.
    Die CP hat im Hardwaremanager die Adressen 288...303.
    Dann kommt der Verweis auf 292 ??

  4. #4
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.712
    Danke
    398
    Erhielt 2.397 Danke für 1.997 Beiträge

    Standard

    Hallo,
    hast du hier die Siemens-Bausteine oder die von Vipa (ich meine, die haben dafür eigene) im Einsatz ?

    Gruß
    Larry

  5. #5
    Registriert seit
    18.05.2007
    Beiträge
    71
    Danke
    17
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Nö, ich habe die Siemens Dinger aus der Bibliothek.
    Im Handbuch der Vipa wird auch von denen gesprochen.
    Aber ich geh mal auf die Vipa Seite, dein Einwand erscheint mir logisch

  6. #6
    Registriert seit
    14.09.2011
    Beiträge
    109
    Danke
    17
    Erhielt 5 Danke für 5 Beiträge

    Standard

    Moin,

    ich habe so ein ähnliches Problem vor 3 JAhren gehabt und im Abschluß nach der glänzenden Hilfe der VIPA Support diesen Beitrag dazu verfasst.
    BSEND/BRCV - Idee Was hier Falsch ist ?

    Da ging es zwar um bsend/brcv doch analog sollte damit Dein Problem auch gelöst sein.

    Euer Schatten

  7. #7
    Registriert seit
    18.05.2007
    Beiträge
    71
    Danke
    17
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    So,

    danke ans Forum und an den VIPA Support.
    Wie bereits vermutet müssen Vipa eigene FC verwendet werden. Diese hat Vipa schnell und problemlos geschickt und die Verbindung läuft wie gewünscht.

    Grüße
    Harri

Ähnliche Themen

  1. Antworten: 1
    Letzter Beitrag: 23.01.2013, 16:28
  2. Probleme mit MPI Koplung und Vipa CPU
    Von Jochen Kühner im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 22.06.2010, 19:53
  3. Antworten: 4
    Letzter Beitrag: 03.07.2009, 13:22
  4. T_Send/RECV oder PNIO_Send/RECV
    Von Zizou im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 12.12.2008, 16:18
  5. LibnoDave AS551 und VIPA CPU 243
    Von PeterEF im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 17.07.2007, 07:52

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •