Hallo Zusammen,

dies ist mein erster Besuch hier und ich hoffe, jemand kann mir weiterhelfen.

Für ein Projekt bin ich gerade folgendes am erstellen:

Es geht um eine Fernanbindung eines Trinkwasserreservoirs an ein Prozessleitsystem. Im Reservoir befindet sich eine S7 1214, welche Daten an dieses PLS sendet und ein HMI Touchpanel. S7, HMI und PLS sind mit TIA V13 prgrammiert und projektiert.
Es gibt 2 Verbindungswege: 1. Über eine DSL Verbindung (ganz normale HMI- Kommunikation), welche im Normalfall genutzt wird. Fällt diese Kommunikation aus, wird dies durch einen Watchdog erkannt und auf GPRS Verbindung (2) umgestellt.
Die GPRS Verbindung wird über ein CP 1242-7 auf SPS Seite und dem Telecontrol Server Basic (TCSB) auf der PLS Seite hergestellt.
Dies funktioniert soweit alles ganz gut. Ich kann IST- Werte über beide Kanäle auslesen. Auch Sollwerte senden ist möglich, jedoch habe ich hier noch einige Probleme:

Ich schreibe auf PLS Seite die Sollwerte über 2 E/A Felder (externe DSL Variable und externe GPRS Variable) in die Steuerung (beide an die gleiche Adresse im DB Receive für Telecontrol (DB200). Von dort werden sie in einen bestehenden Sollwert DB kopiert (DB100). Vom HMI Touchpanel im Reservoir wird direkt in den Sollwert DB (DB100) geschrieben.
An E/A Feld 1 ist die Prozessvariable für DSL Sollwert hinterlegt. Zusätzlich wird bei einer Änderung der Ethernet Sollwert in die entsprechende GPRS Sollwert- Variable geschrieben. Am E/A Feld 2 ist es genau umgekehrt: hier ist als Prozessvariable der Telecontrol (GPRS) Sollwert hinterlegt- zusätzlich wird bei einer Änderung der GPRSl Sollwert in die entsprechende DSL Sollwert- Variable geschrieben.

Fällt jedoch nun die GPRS Verbindung aus, so ist das entsprechende E/A Feld inaktiv (ausgegraut), da keine Kommunikation vorhanden ist. Der Wert, welcher in der DSL Variable steht, wird nicht mehr in das Telecontrol Feld kopiert. Bei der Wiederkehr der Verbindung wird dann der alte Wert, welcher in dem GPRS - E/A Feld stand, wieder in die Ethernet- Variable geschrieben.

Ich habe bereits mehrere Versuche unternommen, mit internen Variablen, die an den E/A Feldern angebunden sind und über Skripte in die jeweiligen Externen Variablen kopiert werden, jedoch ohne Erfolg. Zudem wird das System sehr langsam,
da es sich um ca. 90 Sollwerte handelt. Z.T hat es über 20 min gedauert, bis die Variablen entsprechen kopiert wurden.

Vielleicht kann mir ja jemand helfen.

Vielen Dank im Voraus.

jupp82