Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: Sinamics S120 - Referenzpunktfahrt

  1. #1
    Registriert seit
    05.10.2006
    Beiträge
    324
    Danke
    11
    Erhielt 8 Danke für 7 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Guten Abend,

    an einer Linearachse (1FK7 mit DriveCLIQ Geber) werden verschiedene Positionen absolut angefahren. Diese Positionen sind in einem Datenbaustein hinterlegt.

    Wenn nun aus Wartungszwecken die Achse demontiert wird oder aus sonstigen Gründen die Referenz verloren geht, müssen die eingestellten Werte natürlich wieder passen.

    Nun gibt es ja die Möglichkeit der Referenzpunktfahrt auf einen Nocken welche eigentlich für inkremental Geber benutzt wird. Wäre dies nicht auch die richtige Lösung für meinen Fall? Welches sind dafür die passenden Parameter im Sinamics?

    Wäre das auch eure favorisierte Lösung oder gibts da bessere Ideen?
    Dachte auch daran das rein Softwaretechnisch über Positionsoffsets etc zu lösen aber dass dies sicher funktioniert glaube ich nicht?!?

    Grüsse Pico
    Zitieren Zitieren Sinamics S120 - Referenzpunktfahrt  

  2. #2
    Registriert seit
    05.04.2012
    Beiträge
    952
    Danke
    94
    Erhielt 216 Danke für 191 Beiträge

    Standard

    ... hast Du einen Absolutwertgeber?
    Falls ja, kannst Du ja per Parameterauftrag die Absolutwertgeberjustage wieder anstoßen.

    Falls Du mit TIA Portal arbeitest, dann gibt es ja die DriveLib, wo diese Prozedur beschrieben ist.
    http://support.automation.siemens.co...ew/en/68034568

    Wenn Du die S7-1500 eínsetzt, dann könntest Du auch ein Technologieobjekt anlegen und damit positionieren und PLC Open Befehle z.B. zum Referenzieren nutzen.

  3. #3
    Pico1184 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.10.2006
    Beiträge
    324
    Danke
    11
    Erhielt 8 Danke für 7 Beiträge

    Standard

    Ja habe einen Absolutwertgeber! TIA Portal v13 s7-300

    Benutze die DriveLib auch schon für die Fahraufträge! Klar ist dort die Funktionalität der Referenzfahrt auf Seiten der Steuerung beschrieben...aber wie ist das im Antrieb? Wie verschalte ich den Referenznocken (bei mir an der CU auf DI4 angeklemmt)?

  4. #4
    Registriert seit
    05.04.2012
    Beiträge
    952
    Danke
    94
    Erhielt 216 Danke für 191 Beiträge

    Standard

    Wenn Du einen Absolutwertgeber hast, dann solltest (musst) Du mit der sog. Absolutwertgeberjustage arbeiten (p2507 (?) anstoßen), dann RAM --> ROM kopieren.
    Das macht man dann bei Stillstand der Achse. Z.B. fährt man mit dem Antrieb irgendwohin und der Bediener/Instandhalter würde dort die neue Referenzposition justieren.
    Anscheindend wäre für Dich ein opt. Encoder die bessere Wahl gewesen. Dann müsste nach Power ON immer wieder neu justiert werden.

    Wenn Du unbedingt den Nocken verwenden möchtest, dann könntest Du ja auch fliegend (passiv) Referenzieren - d.h. z.B. mit Tippen über den Nocken fahren bei angewählten passiven refernzieren. Aber dann würde die neue Position nicht Netzausfallsicher sein (oder Du müsstest nochmal eine Absolutwertgeberjustage auf die Aktualpostion durchführen).
    Man könnte auch nochmal Zusatzdaten definieren und über die Messfunktion (p2508/p2509) eine Nockenposition abfragen und in die SPS einlesen (r2523) - das ist im Funktionshandbuch beschrieben. Ggf. bringt Dir das was, wenn Du die Nockenposition kennst und dann entsprechend eine neue Absolutwertgeberjustage durchführst.
    Geändert von zako (04.09.2014 um 21:13 Uhr)

  5. #5
    Registriert seit
    17.04.2009
    Beiträge
    33
    Danke
    9
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo!
    Ich darf diesen Beitrag nochmal aufwärmen, da meine Frage in eine ähnliche Richtung geht. Und zwar habe ich für die Absolutwertgeberjustage einen FB von einem Siemensmitarbeiter bekommen. Daher gehe ich davon mal, dass er prinzipiell funktionieren sollte (jaja, ich bin verrückt :P), aber trotzdem verlieren meine Antriebe - bzw. manche... - bei Stromlos ihre Position (0 wird zu ~67mm oder so). Ein Kollege meinte so ein Problem hätten sie in einer anderen Anlage auch gehabt und anscheinend muss man im Antrieb irgendwas aktivieren, deaktivieren, einstellen, ... dass das RAM-ROM wirklich funktioniert oder so. Er weiss leider nicht mehr, was das war :/
    Hab mal in den FB geguckt, also das RAM-ROM scheint über p971 zu funktionieren. Ist dieser korrekt? Also macht zumindest vom Namen "Parameter speichern" sinn... Oder wird dieser möglicherweise blockiert?
    Hat da wer eine Ahnung, in welcher Richtung das sein könnte?
    Danke schonmal für etwaige Tipps!

  6. #6
    Registriert seit
    05.04.2012
    Beiträge
    952
    Danke
    94
    Erhielt 216 Danke für 191 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    ... hast Du das Problem auch, wenn Du über die STARTER- Maske referenzierst und anschließend RAM--> ROM kopierst? Ist nach Power OFF/ON der Wert auch falsch?
    Tritt das Problem immer, oder sporadisch auf?
    Hast Du eine Linear- oder Rundachse?
    Arbeitest Du mit Lageverfolgung?

Ähnliche Themen

  1. Sinamics S120 FB283
    Von figo80 im Forum Antriebstechnik
    Antworten: 9
    Letzter Beitrag: 18.08.2014, 22:44
  2. SINAMICS S120 reinigen
    Von NeuerSIMATICNutzer im Forum Antriebstechnik
    Antworten: 6
    Letzter Beitrag: 29.08.2012, 12:36
  3. Sinamics S120
    Von arena im Forum Antriebstechnik
    Antworten: 2
    Letzter Beitrag: 15.03.2010, 16:47
  4. Sinamics S120
    Von jackjones im Forum Antriebstechnik
    Antworten: 1
    Letzter Beitrag: 07.11.2008, 14:09
  5. S7 <-> Sinamics S120
    Von MSE im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 08.11.2007, 15:39

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •