Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: PN-Teilnehmer ohne PG taufen

  1. #1
    Registriert seit
    05.11.2004
    Ort
    66763
    Beiträge
    1.065
    Danke
    217
    Erhielt 103 Danke für 76 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo.

    Wir haben in unserem Haus Werkzeuge, auf denen Bewegungen direkt ablaufen.
    Damit diese angesteuert werden können, hat das Werkzeug Hydraulikanschlüsse, 24V Versorgung und ProfiNet.
    Damit werden dann Hydraulik-Ventile gesteuert und Sensoren abgefragt, die auf eine ET200ECO PN gehen.

    Nun ist es so, das wir im Moment recht viele neue Werkzeug vom Werkzeugbauer bekommen und ich jedesmal in
    die Werkstatt muss, um die Module zu taufen. Dazu benötige ich immer mein PG.

    Meine Idee ist nun, das ich über eine 300er + Panel dies so einrichte, dass die Mitarbeiter in der Werkstatt das
    Taufen selbst übernehmen können. Sprich, sie drücken einen Button im Panel und die Module werden getauft.
    Da es immer nur ein 16er Eingangs und ein 8er Ausgangmodul ist, kann auch nix "schief" gehen.

    Wir kann ich nun über eine 300er PN Teilnehmer taufen, ohne das ich ein PG habe?
    Sprich, gibt es in der CPU einen Baustein, mit dem ich das realisieren kann?

    Danke!
    Kommt Zeit.... Kommt Rat.... In der Tat.
    Lautlose Windturbine, die keinen bewegten Schattenwurf hat und in Wohngebiete aufgestellt werden kann? Bei Interesse PN
    Zitieren Zitieren PN-Teilnehmer ohne PG taufen  

  2. #2
    Registriert seit
    16.03.2006
    Ort
    Franken
    Beiträge
    3.148
    Danke
    27
    Erhielt 732 Danke für 639 Beiträge

    Standard

    Wenn du in der Projektierung der 300er eine Topologie angibst werden die Teilnehmer automatisch getauft, wenn sie noch keine Daten haben.
    Diese Daten werden dann aber auch permanent im Device gesetzt, bevor es also an eine andere Stelle eingestöpselt wird musst du es per Hand wieder zurücksetzen

  3. #3
    Krumnix ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.11.2004
    Ort
    66763
    Beiträge
    1.065
    Danke
    217
    Erhielt 103 Danke für 76 Beiträge

    Standard

    Ich hab nun eine Station gebaut mit einer MicroBox und einem WinCC TIA V12 Panel.
    In TIA V13 habe ich nun die Topologie vorgegeben und auch gesagt, dass eine automatische Taufe erfolgen soll.
    Das funktioniert "auch", aber nicht so effizient

    Problem ist, das wir 3 unterschiedliche Werkzeugkonfigurationen haben.
    Auf allen 3en ist das Ausgangsmodul gleich. Die Taufe dieses Moduls läuft perfekt.
    Jedoch sind die Eingangsmodule unterschiedlich.
    Auf dem Typ 1 ist nur ein 8er Modul verbaut.
    Auf Typ 2 sind 2x8er Module verbaut.
    Grundsätzlich tauft das System diese Module auch, wenn der Werkzeugbauer die Reihenfolge einhält.
    Somit gibt es hier auch kein Problem.

    Jetzt kommt mein Sorgenkind.
    Auf Typ 3 ist ein 16er Eingangsmodul aufgebaut. Dieses wird leider immer als das in der Topologie zuerst
    definierte 8er Modul getauft, obwohl es ja ein 16er ist.
    Wie kann ich der SPS nun beibringen, dass das 16er Modul auch als 16er getauft werden soll und nicht als 8er,
    nur weil dieses in der Topologie als 1. kommt?!?!
    Kommt Zeit.... Kommt Rat.... In der Tat.
    Lautlose Windturbine, die keinen bewegten Schattenwurf hat und in Wohngebiete aufgestellt werden kann? Bei Interesse PN

  4. #4
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.202
    Danke
    389
    Erhielt 2.297 Danke für 1.911 Beiträge

    Standard

    Du taufst doch gar nicht die einzelnen Karten sondern die IM (also den Buskoppler).
    Du müßtest also bei 3 verschiedenen HW-Konstellationen auch 3 verschiedene Teilnehmer anlegen, die in der Topologie (und somit auch im wirklichen Leben) unterschiedlich zu erreichen sind.
    So müßte dann dein Modul1 z.B. am Scalance an Port 1 sitzen, 2 an Port 2 usw.

    Gruß
    Larry

  5. #5
    Krumnix ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.11.2004
    Ort
    66763
    Beiträge
    1.065
    Danke
    217
    Erhielt 103 Danke für 76 Beiträge

    Standard

    Es sind ET200eco PN Teilnehmer. Da ist Koppler und "Karte" eins
    Kommt Zeit.... Kommt Rat.... In der Tat.
    Lautlose Windturbine, die keinen bewegten Schattenwurf hat und in Wohngebiete aufgestellt werden kann? Bei Interesse PN

  6. #6
    Registriert seit
    16.03.2006
    Ort
    Franken
    Beiträge
    3.148
    Danke
    27
    Erhielt 732 Danke für 639 Beiträge

    Standard

    Hi,

    ändert aber nix am prinzipellen ablauf.
    Wenn das alles vollautomatisch ablaufen soll brauchst du für jedes Werkzeug eine eindeutige Position in der Topologie und kein Werkzeug darf den Platz eines anderen Werkzeugs in der Topologie einnehmen.
    Einfachste lösung wäre hier ein Switch und über deren Ports dann die Steuerung der Positioon.

    Gruß
    Christoph

  7. #7
    Krumnix ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.11.2004
    Ort
    66763
    Beiträge
    1.065
    Danke
    217
    Erhielt 103 Danke für 76 Beiträge

    Standard

    Ja, das ist aber nicht möglich. Wir haben 20 Werkzeuge, die 3 Bustopologien haben. Jedoch kann nur immer ein Werkzeug an die Steuerung angeschlossen werden.
    Jedes Werkzeug hat die ET200eco PN 8er Ausgangskarte.
    4 Werkzeuge haben eine (1) ET200eco PN 8er Eingangskarte
    12 Werkzeuge haben zwei (2) ET200eco PN 8er Eingangskarten
    4 Werkzeuge haben eine (1) ET200eco PN 16er Eingangskarte

    Werkzeuge mit den 8er Modulen ist kein Thema, aber die Werkzeuge halt mit der 16er funktionieren nicht.

    Die Module sollen alle gleich getauft werden, da der Sinn der Sache ist, das ist bei einem neuen Werkzeug nicht die Maschine in der Hardware ändern muss.
    Daher muss der Name und die IP-Adresse vom Ausgangsmodul bei allen Werkzeugen gleich sein, sowie die Einstellungen für die Eingangskarten.

    Ich glaube nicht, das ich das per Switch in TIA definieren kann.
    Ich will einfach nur der Steuerung beibringen, das eine 16er Karte keine 8er-Konfiguration erhalten soll
    Kommt Zeit.... Kommt Rat.... In der Tat.
    Lautlose Windturbine, die keinen bewegten Schattenwurf hat und in Wohngebiete aufgestellt werden kann? Bei Interesse PN

  8. #8
    Registriert seit
    11.12.2009
    Beiträge
    2.024
    Danke
    383
    Erhielt 372 Danke für 259 Beiträge

    Standard

    Ich werf mal eine Idee in den Raum.

    Warum schreibst Du dem Werkzeugbauer nicht vor einen einheitlichen Maximalausbau zu nutzen?
    Somit hast Du immer z.B. 16DI und 16DO, sie heißen immer gleich usw.

    Grüße

    Marcel
    Stell Dir vor es geht, und keiner kriegts hin!

  9. #9
    Registriert seit
    16.03.2006
    Ort
    Franken
    Beiträge
    3.148
    Danke
    27
    Erhielt 732 Danke für 639 Beiträge

    Standard

    Hi,

    musst du nicht eh immer die HW anpassen?
    Oder wie soll eine 16er Karte angesprochen werden wenn nur ne 8er projektiert ist.
    Oder noch schlimmer ne 8er wenn eine 16 projektiert ist.
    Da passt doch dann schon die Adressierung in HWConfig nicht.

    Eigentlich müsste es mindestens 3 unterschiedliche HWKonfigurationen geben, in Abhängigkeit von der Bustopologie eben.

    Gruß
    Christoph

  10. #10
    Krumnix ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.11.2004
    Ort
    66763
    Beiträge
    1.065
    Danke
    217
    Erhielt 103 Danke für 76 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    @Matze001: Da ist wegen dem Aufbau der Werkzeuge leider nicht möglich, zumindest im Fall von 2 8er Modulen, da der Platz für mehr Verkabelung nicht vorhanden ist.

    ChristophD: In der Topologie im TIA sind alle Teilnehmer drin. 8er A --- 8er E --- 8er E --- 16er E . Ist der Aufbau. Ausgang und 1. 8er Eingang werden von der Topologie her immer richtig getauft.
    Wenn nun aber ein 16er Modul nur da ist, und die 2 8er fehlen, dann tauft die Steuerung das 16er als 1. 8er Modul, obwohl es ja eigentlich ein 16er Modul ist und die Konfiguration nicht passt.
    Wenn das Werkzeug mit dem 16er Modul angeschlossen ist, fehlen die beiden 8er Module und es kommt ein Busfehler. Das ist bei der Station hier egal, da diese nur zum Testen der Werkzeuge ist.
    Warum kann Siemens nicht "logisch" kontrollieren, ob die Konfiguration auch zum Empfänger passt und ihn dann taufen?!
    Kommt Zeit.... Kommt Rat.... In der Tat.
    Lautlose Windturbine, die keinen bewegten Schattenwurf hat und in Wohngebiete aufgestellt werden kann? Bei Interesse PN

Ähnliche Themen

  1. Antworten: 17
    Letzter Beitrag: 05.03.2015, 14:23
  2. Antworten: 6
    Letzter Beitrag: 12.01.2015, 09:33
  3. Antworten: 3
    Letzter Beitrag: 03.01.2014, 09:10
  4. Antworten: 1
    Letzter Beitrag: 22.11.2013, 12:28
  5. CX1000-Zugriff mit Delphi ohne TwinCat und ohne Modbus
    Von jank-automation im Forum CODESYS und IEC61131
    Antworten: 9
    Letzter Beitrag: 09.06.2008, 09:50

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •