Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: FC 105 Problem bei Skalierung

  1. #1
    Registriert seit
    03.12.2013
    Beiträge
    49
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi
    Durch die sufu bin ich für meine Analogwertverarbeitung auf den FC105 gestossen. Hab jetzt ein Problem beim Ausgang. Ich arbeite mit einem 0-10 V Signal, was einem Infrarot- Laser kommt ( Temperatur ). Habe auch schon mehrere PT 100 skaliert. Aber irgendwie kann ich mit dem "Out- Wert" jetzt nix anfangen. Ich muss den ja jetzt noch umrechnen oder sonst was ? ( z.B. Beim Pt100 durch 10 teilen ). Unten ein paar Grafiken. Kann mir eine auf die Sprünge helfen?

    MFG

    FC105.JPGFC105.1.JPG
    Zitieren Zitieren FC 105 Problem bei Skalierung  

  2. #2
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.263
    Danke
    537
    Erhielt 2.708 Danke für 1.957 Beiträge

    Standard

    Hier mal die Erklärung zum FC105 aus der Hilfedatei von Step7:

    Die Funktion Werte skalieren (SCALE) wandelt einen ganzzahligen Wert (IN) in einen Realzahlenwert um, der in physikalischen Einheiten zwischen einem unteren und einem oberen Grenzwert (LO_LIM und HI_LIM) skaliert wird. Das Ergebnis wird in den Parameter OUT geschrieben. Die Funktion SCALE arbeitet mit der folgenden Gleichung:


    OUT = [ ((FLOAT (IN) – K1)/(K2–K1)) * (HI_LIM–LO_LIM)] + LO_LIM


    Die Konstanten K1 und K2 werden unterschiedlich gesetzt, je nachdem, ob der Eingabewert BIPOLAR oder UNIPOLAR ist.


    · BIPOLAR: Es wird angenommen, daß der ganzzahlige Eingabewert zwischen -27648 und 27648 liegt, deshalb sind K1 = -27648,0 und K2 = +27648,0.


    · UNIPOLAR: Es wird angenommen, daß der ganzzahlige Eingabewert zwischen 0 und 27648 liegt, deshalb sind K1 = 0,0 und K2 = +27648,0.
    Du hast ja einen extrem kleinen Input-Wert, dieser wird nun auf den entsprechenden Wert zwischen 0 und 10 umgerechnet.
    Es sieht mit eher so aus, als ob du nicht den richtigen Messwert erhältst. Du mußt doch in etwa wissen, welche Temperatur du gerade mißt und was dann als Analogwert dafür herauskommen muß.
    Dazu solltest du dir noch einmal die Doku der Analog-Input-Baugruppe ansehen.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  3. #3
    Vagasa ist offline Benutzer
    Themenstarter
    Registriert seit
    03.12.2013
    Beiträge
    49
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Es ist vlt noch anzumerken das 100 Grad 0 V entsprechen und 600 Grad 10 V. Das Problem dabei ist ich muss das Material dann erst immer auf mindestens 100 Grad erwärmen um gescheit nachzuvollziehen was für eine Spannung jetzt vorhanden ist.
    Ich werd dein Tipp nachgehen und mir das Datenblatt mal anschauen.

  4. #4
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    Zitat Zitat von Vagasa Beitrag anzeigen
    Es ist vlt noch anzumerken das 100 Grad 0 V entsprechen und 600 Grad 10 V. Das Problem dabei ist ich muss das Material dann erst immer auf mindestens 100 Grad erwärmen um gescheit nachzuvollziehen was für eine Spannung jetzt vorhanden ist.
    Ich werd dein Tipp nachgehen und mir das Datenblatt mal anschauen.
    so gesehen, sind es knapp über 100 Grad Äpfel ... ich nehm aber an, du meinst Grad Celsius...
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  5. #5
    Vagasa ist offline Benutzer
    Themenstarter
    Registriert seit
    03.12.2013
    Beiträge
    49
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ja Herr Lehrer

    Die Karte ist richtig verklemmt, habs nochmal geprüft. Hab Einen IN Wert ( PEW/INT ) von 12. Mit diesem Wert kann ich auch nicht soviel anfangen.
    Wenn 0 Volt 100 Grad Celsius sind, müsste ich ja jetzt irgendwie auf meine 100 Grad Celsius kommen in der SPS ....
    Geändert von Vagasa (18.09.2014 um 09:45 Uhr)

  6. #6
    Registriert seit
    22.01.2008
    Ort
    Allgäu, da wo die Kühe schöner sind als die Mädels
    Beiträge
    1.775
    Danke
    51
    Erhielt 731 Danke für 436 Beiträge

    Standard

    Also wenn der ScreenShot noch aktuell ist, hast du Low auf 0 und High auf 10 gesetzt.
    Anderseits schreibst Du, dass der Sensor von 100 °C bis 600°C überträgt.
    Das passt natürlich nicht zusammen.

    Was ist das denn für ein Temperatursensor?
    Bei manchen Geräten kann man die Ausgabe des Analogwertes verstellen.
    Gruss Audsuperuser

    Herzlich Willkommen im Chat:
    SPS-Forum Chat (Mibbit) | SPS-Forum Chat (MIRC)

  7. #7
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.752
    Danke
    323
    Erhielt 1.526 Danke für 1.286 Beiträge

    Standard

    Nun ja, wenn du weißt, das
    0V = Wert 0
    10V = Wert 27648
    entspricht, dann kannst du das auch ganz leicht selbst berechnen.

    Hier dann also 12/27648 * 500°C + 100°C = 100,21 °C

    Für den FC105 heißt das dann:
    LoLim = 100, HiLim=600 ...

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  8. #8
    Vagasa ist offline Benutzer
    Themenstarter
    Registriert seit
    03.12.2013
    Beiträge
    49
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich Danke euch hab das jetzt am laufen...........Hatte Fehler in Hi_lim Lo_lim........ok beim nächsten Einsatz des FC105 weiss ich bescheid.

    Danke euch
    MFG

Ähnliche Themen

  1. Problem mit einer Skalierung
    Von Step7Neuling im Forum CODESYS und IEC61131
    Antworten: 6
    Letzter Beitrag: 29.08.2014, 12:47
  2. Antworten: 0
    Letzter Beitrag: 11.12.2012, 11:18
  3. Problem Skalierung
    Von Ulli_FHBRB im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 27.10.2010, 09:10
  4. Problem mit Messsonde und FC 105
    Von john321os im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 12.08.2010, 18:04
  5. Problem - Sensor Skalierung
    Von mac_hawk im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 24.05.2009, 13:08

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •