Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: Strommessung mit S7-1500er

  1. #1
    Registriert seit
    25.09.2014
    Beiträge
    7
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich bin hier ein wenig am verzweifeln,
    ich habe bisher nur mit den 300ern gearbeitet (und auch dort nicht sehr viel Erfahrung) und habe heute eine 1500er auf den Tisch gestellt bekommen, um mich darin einarbeiten zu können.
    Ich wollte in die analoge Eingabebaugruppe (AI 8xU/I/RTD/TC ST) einen Strom zwischen 4 und 20mA einspeisen, um eine kleine Funktion zu schreiben, die mir die Werte auf meine physikalische Einheit skaliert (nur um mit SCL etwas warm zu werden).
    Ich habe in TIA die Anlage automatisch erfassen lassen und alle Baugruppen wurden erkannt, bei den digitalen Ein- und Ausgabebaugruppen gibt es auch keine Probleme.

    Dann habe ich den Ch0 von der AI-Baugruppe auf 2-Draht-Strommessung und 4...20mA gestellt, das Projekt gespeichert und die Hardwarekonfig geladen.
    Versuche ich aber mit einer Konstantstromquelle ein paar mA einzuspeisen, dann sagt mir die Quelle, ich hätte eine zu hohe Bürde.
    Ich hab mal ein Fluke dazwischengeschaltet und den Strom gemessen: In dem Moment, wo ich den Stromkreis schließe fließt kurzzeitig (1...2s) der eingestellt Strom, im Anschluss sinkt er auf 1,5mA.
    Wenn ich den Eingang der Baugruppe über TIA beobachte, dann habe ich kontinuierlich und unabhängig von der Beschaltung den Maximalwert von 32767!
    Ich hoffe, mir kann irgendjemand auf die Sprünge helfen, was da im argen liegt und was ich noch einstellen muss, nach einem Nachmittag verzweifeltem Suchen bin ich etwas hilflos geworden...


    Viele Grüße
    jusaca
    Zitieren Zitieren Strommessung mit S7-1500er  

  2. #2
    Registriert seit
    12.12.2013
    Ort
    Kaiserslautern
    Beiträge
    1.339
    Danke
    388
    Erhielt 219 Danke für 173 Beiträge

    Standard

    Hallo Jusaca,

    Bei 2 Draht soll dein Loopkalibrator auf "Simulieren" stehen (Bei Fluke).

    Bei 4 Draht kannst du mit eine Quelle einspeisen. Einstellung "Source" bei Fluke.

    Stell mal um auf 4 Draht.
    Vielleicht lieg da das Problem.

    Bram
    Wenn es nicht auf STRAVA ist, ist es nicht passiert !!

  3. #3
    jusaca ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    25.09.2014
    Beiträge
    7
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich kann nur bei einer Vierdrahtmessung mit einer Stromquelle einspeisen? Wieso denn das?
    Wie gesagt, viel Expertise ist bei mir bisher in Sachen SPS nicht vorhanden. Einen "Loopkalibrator" habe ich ebenfalls nicht, nur ein Multimeter und eine Konstantstromquelle =)

    Viele Grüße
    jusaca

  4. #4
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.733
    Danke
    317
    Erhielt 1.522 Danke für 1.283 Beiträge

    Standard

    2 Draht = 24V (aus der Baugruppe) -> Sensor -> 4-20 MA -> Eingang
    Insofern ist deine Stromquelle eindeutig eine aktive Stromquelle und folglich 4-Draht.

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  5. #5
    jusaca ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    25.09.2014
    Beiträge
    7
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Tatsächlich, mit einer Vierdrahtmessung funktioniert das ganze...
    Dann habe ich bisher die beiden Begriffe 2-Draht und 4-Draht aus der Elektronik etwas durcheinandergebracht, für mich hieß 4-Drahtmessung bisher, dass ich zwei Leitungen für den Strom anschließe und zusätzlich noch zwei Sense-Leitungen. Wobei das bei einer Strommessung natürlich nicht so viel Sinn ergibt...

  6. #6
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.192
    Danke
    925
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Das heißt ja auch nicht 4-Draht-Messung sondern 4-Draht-Messumformer und meint laienhaft, daß der Messumformer bzw. Sensor 4 Drähte hat (2 Drähte für das Meßsignal und 2 Drähte für die Betriebsspannungsversorgung). Ein 2-Draht-Messumformer hat dagegen nur 2 Drähte für das Meßsignal und muß daher über diese 2 Drähte auch mit Betriebsspannung versorgt werden.
    Diejenigen, welche sich diese bescheuerte 2DMU/4DMU-Bezeichnung ausgedacht haben, waren wohl keine Elektrotechniker und meinten wohl, der gemeine elektrisch-unkundige SPS-Programmierer könne durch einfaches "Abzählen" der Drähte am Sensor erkennen, auf welchen Modus er den Analogeingang einzustellen hat. Die good-old Bezeichnungen "aktiv" und "passiv" waren da aber eher korrekt.

    Hier mal meine Übersetzung von 2DMU/4DMU:
    • 2DMU = 2-Draht-Messumformer = der MU ist passiv = der Analogeingang muß aktiv den Messsignalstrom liefern, die 20mA fließen aus dem AI+ heraus und in den AI- hinein
    • 4DMU = 4-Draht-Messumformer = MU ist aktiv = der Messsignalstrom wird außerhalb des passiven Analogeingangs erzeugt, die 20mA fließen in den AI+ hinein und am AI- heraus


    Welcher Modus für den Analogeingang einzustellen ist, muß man eigentlich "rückwärts" übersetzen:
    Muß der Analogeingang die 20mA speisen, dann ist 2DMU einzustellen. Kommen die 20mA von außerhalb des Analogeingangs, dann ist 4DMU einzustellen.

    Um die Verwirrung komplett zu machen: man kann auch real passive Messumformer mit nur 2 Drähten so schalten, daß der Analogeingang auf 4DMU eingestellt werden muß: den Plus-Draht des Sensors an +24V, den Minus-Draht des Sensors an AI+ und AI- an 0V. Dies wird relativ häufig so gemacht. Eigentlich braucht man 2DMU echt nur sehr selten und deshalb gibt es auch preiswertere Analogeingangskarten, welche nur 4DMU können (z.B. 331-7NF00).

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  7. Folgender Benutzer sagt Danke zu PN/DP für den nützlichen Beitrag:

    jusaca (26.09.2014)

  8. #7
    Registriert seit
    16.11.2006
    Beiträge
    104
    Danke
    7
    Erhielt 11 Danke für 11 Beiträge

    Standard

    Der Vollständigkeit halber und um die Verwirrung komplett zu machen, haben die meisten 4DMU Sensoren aber nur 3 Drähte bzw. benötigen nur 3 (+24V, 0V, Signal an SPS). Jedenfalls die meisten Sensoren die mir bisher unter gekommen sind. Den AI- legt man ja dann im Schrank ebenfalls auf das 0V Potential. Zumindest handhaben wir das bei uns in der Firma immer so.

  9. #8
    Registriert seit
    12.12.2013
    Ort
    Kaiserslautern
    Beiträge
    1.339
    Danke
    388
    Erhielt 219 Danke für 173 Beiträge

    Standard

    Eigentlich braucht man 2DMU echt nur sehr selten
    Bei uns ist es genau anders rum. Die 4 draht ist seltener.

    Den AI- legt man ja dann im Schrank ebenfalls auf das 0V Potential.
    Wie soll das gehen ?


    Um die Verwirrung komplett zu machen: man kann auch real passive Messumformer mit nur 2 Drähten so schalten, daß der Analogeingang auf 4DMU eingestellt werden muß: den Plus-Draht des Sensors an +24V, den Minus-Draht des Sensors an AI+ und AI- an 0V.
    Kommt bei uns nur in Retrofit Anlage vor. Aber das kann ich auch auf 1 Hand zählen das wir das so umgesetzt haben.

    Bram
    Geändert von de vliegende hollander (26.09.2014 um 15:45 Uhr)
    Wenn es nicht auf STRAVA ist, ist es nicht passiert !!

  10. #9
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.192
    Danke
    925
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Zitat Zitat von de vliegende hollander Beitrag anzeigen
    Bei uns ist es genau anders rum. Die 4 draht ist seltener.
    Jaaa, Ihr in Holland macht vieles anders ... Aber wir sind Weltmeister ...

    Es ging mir nicht darum, ob 2-Draht-Sensoren häufiger sind als 4-Draht-Sensoren, sondern darum, wie die 2-Draht- oder 4-Draht-Sensoren an den Analogeingang angeschlossen werden. Und da überwiegt bei uns die 4DMU-Schaltung.

    Jeden 2-Draht-Sensor kann man an einem als 4DMU konfigurierten Analogeingang betreiben, aber nicht umgekehrt aktive "4-Draht"-Sensoren an 2DMU-Analogeingängen. (Da braucht man dann extra Trennverstärker dazwischen.)

    Alle nicht benutzten Analogeingänge konfiguriere ich als 4DMU, da kann man später im laufenden Betrieb immer noch was anschließen oder umverdrahten, ohne die Baugruppe ausbauen zu müssen, nur um den "Würfel" zu drehen.


    Unabhängig von 2DMU/4DMU: Wenn ich es bestimmen kann, dann schalte ich immer den AI- auf 0V. So kann zwischen den Analogeingängen keine Potentialdifferenz entstehen. Der 2-Draht-Anschluß suggeriert, daß man den Sensor-Anschluß dadurch potentialfrei bekommt. Siemens-Analogeingänge können aber meistens nur eine Potentialdifferenz von 2V zwischen den Eingängen ab. Da kommt es dann gerne mal zu unerklärlichen Beeinflussungen von Analogeingängen durch Nachbareingänge bis hin zum Defekt von "unschuldigen" Eingängen.
    Wenn mal Analogeingänge in Reihe geschaltet werden müssen und "meine" Siemens ist nicht die letzte in der Reihe, dann nehme ich lieber einen Trennverstärker als die 0V abzuklemmen.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  11. #10
    Registriert seit
    12.12.2013
    Ort
    Kaiserslautern
    Beiträge
    1.339
    Danke
    388
    Erhielt 219 Danke für 173 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    OT
    Jaaa, Ihr in Holland macht vieles anders ... Aber wir sind Weltmeister ...
    Ich wohn aber im schönen Pfälzerwald und hab sogar ein Deutsches Fahrerlaubnis und fahr mit weißen Nummerschilder...
    Dan bin ich jetzt auch ein bisschen Weltmeister.

    Gute Theorie oder ?

    [Unabhängig von 2DMU/4DMU: Wenn ich es bestimmen kann, dann schalte ich immer den AI- auf 0V. So kann zwischen den Analogeingängen keine Potentialdifferenz entstehen. Der 2-Draht-Anschluß suggeriert, daß man den Sensor-Anschluß dadurch potentialfrei bekommt. Siemens-Analogeingänge können aber meistens nur eine Potentialdifferenz von 2V zwischen den Eingängen ab. Da kommt es dann gerne mal zu unerklärlichen Beeinflussungen von Analogeingängen durch Nachbareingänge bis hin zum Defekt von "unschuldigen" Eingängen.
    Das ist interresant, Das merk ich mir mal bei eventuelle Fehlersuche.

    Was auch gemacht wird ist am nicht verwendete 2 Draht Eingängen ein 3K Widerstand anschließen.
    Und die nicht verwendete 4 Draht zusammen mit ein Analog Ausgang in eine riese Schleife machen.
    Ist aber mehr für die Kanalüberwachung gedenkt, wenn die aktiviert ist.

    Bram
    Wenn es nicht auf STRAVA ist, ist es nicht passiert !!

Ähnliche Themen

  1. Antworten: 12
    Letzter Beitrag: 04.12.2013, 15:17
  2. Strommessung über 1A Wandler mit ET 200
    Von deepack27 im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 11.07.2012, 14:46
  3. Analalogmodul SM334 mit Zweidraht Strommessung
    Von Mu3rte8 im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 13.02.2012, 11:36
  4. Spannungs-, Strommessung mit S7 400
    Von Einherjer14 im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 04.11.2006, 12:32
  5. Strommessung mit Messumformer
    Von MatMer im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 29.09.2005, 10:17

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •