Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: Step7 Classic, ET200SP und Modbus

  1. #1
    Registriert seit
    26.09.2009
    Beiträge
    62
    Danke
    20
    Erhielt 6 Danke für 5 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Forum!

    Ich muss für ein Projekt mehrere Wärmezähler mittels Modbus RTU in die Steuerung einbinden. Ich verwende eine CPU317-2 PN/DP programmiert mit Step7 Classic, als DP ein ET200SP System mit einer Kommunikationsbaugruppe CM PtP (6ES7 137-6AA0-0AB0). Das Erste was auffällt ist, dass das Protokoll Modbus in den Parametern der Baugruppe nicht anwählbar ist. Bei einem Test mit dem TIA Portal war das Modbus Protokoll wählbar, was der erste Hinweis dafür wäre, dass die Kombination CM PtP (Modbus Protokoll) und Step7 Classic nicht funktioniert. In den diversen Handbüchern habe ich nur die Kombination S7-1500 und CM PtP (Modbus) gefunden, aber auch keinen Hinweis das es mit Step7 Classic nicht funktioniert.

    Meine Frage an euch ist nun, ob es tatsächlich nicht funktioniert oder ob es jemand bereits zum Laufen gebracht hat.

    Vielen Danke für eure Hilfe.

    MfG
    Wolfgang O.
    Zitieren Zitieren Step7 Classic, ET200SP und Modbus  

  2. #2
    Registriert seit
    12.12.2013
    Ort
    Kaiserslautern
    Beiträge
    1.373
    Danke
    397
    Erhielt 224 Danke für 177 Beiträge

    Standard

    Hallo Wolfgang,

    Al unsere Modbusverbindungen im Classic (zwar über ein CP441) sind zum laufen gebracht mit :
    Einstellung - RS422/485 und die Verbindung selbst als PTP Verbindung.

    Wenn ich mich aber nicht täusche brauch man aber abhängig der gewollte Funktion Lizenzen.
    Im CP441 Stekbar und für die 300er ladbar glaube ich.

    Bram
    Wenn es nicht auf STRAVA ist, ist es nicht passiert !!

  3. #3
    Registriert seit
    24.02.2009
    Ort
    Garrel
    Beiträge
    36
    Danke
    2
    Erhielt 3 Danke für 3 Beiträge

    Standard

    Hallo Wolfgang,

    die Modbus-Kommunikation funktioniert! Das Modbus-Protokoll wird aber nicht in der Hardware ausgewählt.
    Bedienungsanleitung siehe hier:
    http://support.automation.siemens.co...ew/de/69124220
    Bausteine siehe hier:
    http://support.automation.siemens.co...ew/de/75226762

    Michael

  4. Folgender Benutzer sagt Danke zu m.beeken für den nützlichen Beitrag:

    sventek (29.09.2014)

  5. #4
    Registriert seit
    26.09.2009
    Beiträge
    62
    Danke
    20
    Erhielt 6 Danke für 5 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Michael!

    Vielen Dank für den nützlichen Hinweis. Ich habe zwar auch danach gesucht, aber nicht wahrscheinlich nicht gut genug. Ich werde es diese Woche testen.

    Gruß
    Wolfgang

Ähnliche Themen

  1. TIA Temperaturmessung mit ET200SP und S7-1200
    Von Vetsrob im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 03.06.2014, 12:35
  2. Safety Programmierung im s7 classic
    Von mjoedi im Forum Simatic
    Antworten: 14
    Letzter Beitrag: 21.09.2012, 15:50
  3. Antworten: 4
    Letzter Beitrag: 21.09.2011, 13:45
  4. Handling Step7 lite und Step7 prof.
    Von wortlos im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 16.04.2011, 15:14
  5. Antworten: 0
    Letzter Beitrag: 05.08.2010, 08:14

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •