Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 4 ErsteErste 1234 LetzteLetzte
Ergebnis 11 bis 20 von 36

Thema: Onlineperformance TIA-13 bei Fernwartung

  1. #11
    Registriert seit
    03.07.2006
    Beiträge
    1.725
    Danke
    515
    Erhielt 303 Danke für 223 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von vollmi Beitrag anzeigen
    Offline online gehen habe ich bisher nicht ausprobiert bei dem Problem. Aber wenn ich dann konsistent runterladen will kommt Korben Dallas mit nem lächelnden Supergreen um die Ecke.

    sogeil ich das konsistente runterladen auch finde, aber diese Möglichkeit wär wirklich zu wünschen.

    mfG René
    Für diesen ständigen vergleich kommt einfach bei allen SPS Steuerungen nicht genug Performance aus den Schnittstellen........

    Und bei den älteren wie der 300er schon mal gar nicht. Auch die 1200er ist da nicht viel besser.

  2. #12
    Registriert seit
    12.12.2013
    Ort
    Kaiserslautern
    Beiträge
    1.339
    Danke
    388
    Erhielt 219 Danke für 173 Beiträge

    Standard

    Was für einen Ping hast du zu den 300ern?
    Bei mir schwankt er zwischen 80ms und 800ms - also nicht so dolle...
    Anhang 25682

    Hab aus Interesse der gleiche CPU, 1 mal mit S7 Classic gepingt und dann 1 mal mit TIA V13upd4 gepingt.
    Sehe das Resultat vom Ping im Screenshot. CPU liegt aber direkt neben mir. Ein 317 2 PN/DP.
    Sonnst lauft mein erste TIA auf ein 400e mit CP443. da hab keinerlei Problemen mit der online peformance, gefühlsmäßig gleich wie die 317er PN/DP

    Bram
    Wenn es nicht auf STRAVA ist, ist es nicht passiert !!

  3. #13
    Registriert seit
    29.03.2004
    Beiträge
    5.741
    Danke
    143
    Erhielt 1.686 Danke für 1.225 Beiträge

    Standard

    Warum das TIA Portal selbst bei einer Variablentabelle so langsam ist, sind die folgenden:
    - Es wird bei Online gehen immer ein kompletter Bausteinvergleich gemacht
    - TIA-Portal fragt beim Onlinegehen wesentlich mehr Informationen (SZL) von der CPU an als Step7
    - Bei einer Variablentabelle fragt Step7 (5.x) nur die für die Variablentabelle relevanten Nutzdaten ab. TIA Portal fragt bei jedem Zyklus zusätzlich wieder einen ganzen Satz SZL-Daten ab. D.h. für einen Variablenwert in der VAT wenn man endlich mal Online ist, benötigt TIA geschätzt die 10 fache Bandbreite als Step7. Zusätzlich kommen die Verzögerungszeiten hinzu, weil erst die Antworten der SPS abgewartet werden müssen

    Was kann man daran ändern? Nichts.

  4. Folgender Benutzer sagt Danke zu Thomas_v2.1 für den nützlichen Beitrag:

    Markus (03.10.2014)

  5. #14
    Registriert seit
    22.11.2006
    Ort
    CH
    Beiträge
    3.620
    Danke
    777
    Erhielt 647 Danke für 493 Beiträge

    Standard

    Zitat Zitat von Markus Beitrag anzeigen
    @Vollmi
    Was für einen Ping hast du zu den 300ern?
    Bei mir schwankt er zwischen 80ms und 800ms - also nicht so dolle...
    zwischen 50 und 150ms schwankend.

  6. Folgender Benutzer sagt Danke zu vollmi für den nützlichen Beitrag:

    Markus (03.10.2014)

  7. #15
    Registriert seit
    29.03.2004
    Beiträge
    5.741
    Danke
    143
    Erhielt 1.686 Danke für 1.225 Beiträge

    Standard

    Um mal zwei Vergleichswerte zu haben:
    Testobjekt ist eine IM-151-8 PN/CPU mit Online 10 programmierten Bausteinen im LAN:

    - Step7 V5.5 hat nach Verbindungsaufbau nach 0,05 Sekunden die ersten Werte der VAT.
    - TIA-Portal nach 30 Sekunden.

  8. Folgender Benutzer sagt Danke zu Thomas_v2.1 für den nützlichen Beitrag:

    Markus (03.10.2014)

  9. #16
    Avatar von Markus
    Markus ist offline Administrator
    Themenstarter
    Registriert seit
    16.06.2003
    Ort
    88356 Ostrach
    Beiträge
    4.812
    Danke
    1.231
    Erhielt 1.101 Danke für 527 Beiträge

    Standard

    Zitat Zitat von de vliegende hollander Beitrag anzeigen
    Anhang 25682

    Hab aus Interesse der gleiche CPU, 1 mal mit S7 Classic gepingt und dann 1 mal mit TIA V13upd4 gepingt.
    Sehe das Resultat vom Ping im Screenshot. CPU liegt aber direkt neben mir. Ein 317 2 PN/DP.
    Sonnst lauft mein erste TIA auf ein 400e mit CP443. da hab keinerlei Problemen mit der online peformance, gefühlsmäßig gleich wie die 317er PN/DP

    Bram
    Wir reden hier nicht über Probleme beim direkten Verbinden.
    Es geht hier um das Verhalten wenn eine "langsame" Verbindung zur CPU besteht, z.B. über VPN.
    "Es ist weit besser, große Dinge zu wagen, ruhmreiche Triumphe zu erringen, auch wenn es manchmal bedeutet, Niederlagen einzustecken, als sich zu den Krämerseelen zu gesellen, die weder große Freude noch großen Schmerz empfinden, weil sie im grauen Zwielicht leben, das weder Sieg noch Niederlage kennt." Theodore Roosevelt - President of the United States (1901-1909)

  10. #17
    Registriert seit
    22.11.2006
    Ort
    CH
    Beiträge
    3.620
    Danke
    777
    Erhielt 647 Danke für 493 Beiträge

    Standard

    Zitat Zitat von UniMog Beitrag anzeigen
    Für diesen ständigen vergleich kommt einfach bei allen SPS Steuerungen nicht genug Performance aus den Schnittstellen........
    definitiv. Bei der 1500er und 400PN gehts noch recht gut. Aber bei den anderen wäre optimierungspotential dabei.
    Letztens bin ich über die 300 advanced cp gestolpert. Mit nem Gigabit Port. Wozu braucht man denn das bitte? Die CPUs können doch garnix liefern was diesen erfordern würde.

    Aber IMHO wäre sicher optimierungspotential bei der kommunikation da. z.B. einmal Online/Offlinekonsistenz prüfen und dann davon ausgehen dass sich nur das ändern was seit dem letzten offline gehen auch wirklich von TIA geändert wird, das braucht man nicht zyklisch zu überprüfen!

    mfG René

  11. #18
    Avatar von Markus
    Markus ist offline Administrator
    Themenstarter
    Registriert seit
    16.06.2003
    Ort
    88356 Ostrach
    Beiträge
    4.812
    Danke
    1.231
    Erhielt 1.101 Danke für 527 Beiträge

    Standard

    Zitat Zitat von Thomas_v2.1 Beitrag anzeigen
    Warum das TIA Portal selbst bei einer Variablentabelle so langsam ist, sind die folgenden:
    - Es wird bei Online gehen immer ein kompletter Bausteinvergleich gemacht
    - TIA-Portal fragt beim Onlinegehen wesentlich mehr Informationen (SZL) von der CPU an als Step7
    - Bei einer Variablentabelle fragt Step7 (5.x) nur die für die Variablentabelle relevanten Nutzdaten ab. TIA Portal fragt bei jedem Zyklus zusätzlich wieder einen ganzen Satz SZL-Daten ab. D.h. für einen Variablenwert in der VAT wenn man endlich mal Online ist, benötigt TIA geschätzt die 10 fache Bandbreite als Step7. Zusätzlich kommen die Verzögerungszeiten hinzu, weil erst die Antworten der SPS abgewartet werden müssen

    Was kann man daran ändern? Nichts.
    Naja aber SIEMENS sollte da dann DRINGEND etwas tun.
    Immerhin bestätigt dies das eine Fernwartung mit TIA13 unmöglich ist - außer ich habe eine superschnelle Onlineverbindung (Willkommen in Deutschland).

    Allerdings würde deine Beschreibung erklären warum es SEHR langsam wäre.
    Was das angeht, da hat SIEMENS inzwischen wohl die meisten Anwender so mürbe gemacht das hier keine mehr auf Besserung hofft.

    Aber das Problem ist ja das es überhaupt nicht funktioniert.
    TIA wartet ja nicht wenigstens bis alles geladen ist, so wie ich das beobachte (bei der VAT ganz deutlich) bricht es nach einem gewissen timeout automatisch ab.

    Warum da jetzt dieser timeout drin ist lässt natürlich nur erahnen wie vermurkst das ganze Konstrukt intern sein muss...
    "Es ist weit besser, große Dinge zu wagen, ruhmreiche Triumphe zu erringen, auch wenn es manchmal bedeutet, Niederlagen einzustecken, als sich zu den Krämerseelen zu gesellen, die weder große Freude noch großen Schmerz empfinden, weil sie im grauen Zwielicht leben, das weder Sieg noch Niederlage kennt." Theodore Roosevelt - President of the United States (1901-1909)

  12. #19
    Registriert seit
    29.03.2004
    Beiträge
    5.741
    Danke
    143
    Erhielt 1.686 Danke für 1.225 Beiträge

    Standard

    Ich vermute mal, an der Anbindung der S7-300/400 wird am TIA-Portal nicht mehr viel optimiert. Darum würde ich bei den Steuerungen auch immer bei Step7 bleiben.

    Das ständige Bausteinvergleichen wird man dem TIA-Portal wohl nicht abgewöhnen können, dazu liegt das viel zu tief im Konzept begründet. Bei Step7 bist du als Benutzer dafür verantwortlich dein Programm offline/online konsistent zu halten. Bei TIA macht das TIA-Portal das für dich, darum muss es immer ganz genau wissen was online los ist, und wo die Unterschiede sind.

    Wobei es eigentlich möglich sein sollte, den Vergleich zumindest wenn man nur beobachten will den Vergleich zu deaktivieren. Wenn man etwas übertragen will, kann TIA ja meinetwegen immer noch den Vergleich starten.
    Komischerweise gehts bei Codesys auch, und selbst bei Step7-CFC bei dem man als Benutzer auch keine detaillierte Kontrolle über den Ladevorgang hat, geht es ohne den Vergleich - und schneller als bei TIA, und ich finde bei CFC den Fluss beim Programmieren und Laden schon nervig langsam, verglichen mit AWL/FUP/KOP.

  13. #20
    Registriert seit
    13.10.2007
    Beiträge
    12.038
    Danke
    2.789
    Erhielt 3.273 Danke für 2.159 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Fazit: mit TIA wurde also eines der wichtigsten Werkzeuge in der Simatic Welt entfernt,
    ohne einen Schnellen Zugriff auf einer Steuerung ist eine Fernwartung unmöglich.

    Mich würde interessieren, wie lange es Siemens sich noch erlauben kann, für nicht
    funktiorende Software Geld zu verlangen. Meiner subjektiven Auffassung nach ist es
    zur Zeit schlimmer, wie beim Übergang von Step5/ProTool nach Step7/WinCCflex.

    @Thomas, es wird der Zeitpunkt kommen an den du dich auch auf Steuerungsseite
    von der Classic Welt verabschieden mußt, bei den Panel's st es ja seit Oktober stand
    der Dinge.
    Geändert von rostiger Nagel (03.10.2014 um 13:17 Uhr)
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

Ähnliche Themen

  1. [TIA-V11] Rechnet TIA falsch bei SCL
    Von BlackLizzard im Forum Simatic
    Antworten: 43
    Letzter Beitrag: 09.02.2016, 02:59
  2. TIA TIA Portal - Fernwartung über VPN Anforderungen
    Von Pico1184 im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 04.09.2014, 10:36
  3. Antworten: 0
    Letzter Beitrag: 19.08.2013, 08:48
  4. Antworten: 1
    Letzter Beitrag: 27.03.2012, 08:33
  5. S7 geistert bei Fernwartung
    Von kilic im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 04.11.2008, 13:15

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •