Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 5 ErsteErste 1234 ... LetzteLetzte
Ergebnis 11 bis 20 von 46

Thema: TIA V13 Update 5

  1. #11
    Registriert seit
    13.10.2007
    Beiträge
    12.024
    Danke
    2.784
    Erhielt 3.268 Danke für 2.156 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von - chris - Beitrag anzeigen
    Hallo

    Seit dem UPD5 habe ich folgendes Problem:

    Neues Projekt mit Panel - KP900 Comfort

    Bei den Funktionstasten sind die Funktionen "Taste drücken" und "Taste loslassen" vertauscht.

    Ich habe bei "Taste drücken" die Funktion "SetzeBit" und bei "Taste loslassen" die Funktion "RücksetzeBit" projektiert (interne Bool Variable).
    Starte ich die Simulation, ist die Variable 0.
    1. Taste wird gedrückt Variable 0
    2. Taste wird losgelassen Variable 1
    3. Taste wird gedrückt Variable 0
    4. usw..

    Verwenden ich die Funktion "SetzeBitWährendTastegedrückt" habe ich das selbe Verhalten.

    Die Funktion "InvertiereBit" arbeitet wie erwartet.

    Mit dem UPD4 hatte ich dieses Problem nicht, es funktionierte soweit.
    ich habe das jetzt gerade mal versucht nachzustellen mit einen 1200er comfort panel,
    den Fehler kann ich nicht nachvollziehen. Vielleicht ist etwas bei der Hochrüstung schiefgelaufen.
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  2. #12
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.616
    Danke
    377
    Erhielt 799 Danke für 642 Beiträge

    Standard

    Hast du probiert Compile ... Software (Rebuild all) ?
    Jesper M. Pedersen

  3. #13
    Registriert seit
    12.12.2013
    Ort
    Kaiserslautern
    Beiträge
    1.337
    Danke
    385
    Erhielt 218 Danke für 173 Beiträge

    Standard

    Ich hab mit ein TP1900 und TP700 Comfort geprüft,
    Ich kann es auch nicht nachvollziehen.

    Sehe aber jetzt dass um F-Tasten geht, die hatt ein Touch nicht....

    Bram
    Wenn es nicht auf STRAVA ist, ist es nicht passiert !!

  4. #14
    Registriert seit
    13.10.2007
    Beiträge
    12.024
    Danke
    2.784
    Erhielt 3.268 Danke für 2.156 Beiträge

    Standard

    Jau F-Taste habe ich auch nicht.
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  5. #15
    Registriert seit
    27.10.2005
    Beiträge
    47
    Danke
    1
    Erhielt 7 Danke für 7 Beiträge

    Standard

    Legt doch bitte mal ein neues Projekt mit einem KP900 Comfort an und simuliert es.

    Mit Schaltfläche setzen und rücksetzen funktioniert bei mir auch.

    Projekt komplett übersetzen bringt auch nichts.




    KP900 Comfort

  6. #16
    Registriert seit
    13.10.2007
    Beiträge
    12.024
    Danke
    2.784
    Erhielt 3.268 Danke für 2.156 Beiträge

    Standard

    Zitat Zitat von - chris - Beitrag anzeigen
    Legt doch bitte mal ein neues Projekt mit einem KP900 Comfort an und simuliert es.

    Mit Schaltfläche setzen und rücksetzen funktioniert bei mir auch.

    Projekt komplett übersetzen bringt auch nichts.




    KP900 Comfort
    du testest aber schon mit echter Hardware?
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  7. #17
    Registriert seit
    27.10.2005
    Beiträge
    47
    Danke
    1
    Erhielt 7 Danke für 7 Beiträge

    Standard

    Mit echter Hardware getestet:

    Mit Panel - KP900 Comfort + CPU317-2 getestet und PLC-Variable (TIA V13 UPD5)

    Es bleibt dabei:

    Wenn ich bei "Taste drücken" die Funktion "SetzeBit" und bei "Taste loslassen" die Funktion "RücksetzeBit"
    projektiere, ist "Taste drücken" und "Taste loslassen" vertauscht.
    Geändert von - chris - (20.10.2014 um 17:15 Uhr)

  8. #18
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.616
    Danke
    377
    Erhielt 799 Danke für 642 Beiträge

    Standard

    Nur für vollständigkeit, kannst du das bestätigen:
    Zitat Zitat von JesperMP Beitrag anzeigen
    Hast du probiert Compile ... Software (Rebuild all) ?
    Jesper M. Pedersen

  9. #19
    Registriert seit
    27.10.2005
    Beiträge
    47
    Danke
    1
    Erhielt 7 Danke für 7 Beiträge

    Standard

    Übersetzen -> Software (komplett übersetzen)

    ja, das hab ich gemacht.

  10. #20
    Registriert seit
    27.10.2005
    Beiträge
    47
    Danke
    1
    Erhielt 7 Danke für 7 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Mit "WinCC RT Advanced" das selbe Problem

    Funktiontaste F1 -> Taste drücken -> SetzeBit
    Funktiontaste F1 -> Taste loslassen -> RücksetzeBit

    1. Runtime gestartet Variabe - 0
    2. Beim ersten drücken der Taste F1 bleibt Variabe - 0
    3. Taste loslassen Variable - 1
    4. Taste drücken Variable - 0
    5. usw.

    Steuer ich die Variable mit einer Schaltfläche ist das setzen und rücksetzen in Ordnung.
    Geändert von - chris - (20.10.2014 um 17:40 Uhr)

Ähnliche Themen

  1. TIA Version V13 ???
    Von UniMog im Forum Stammtisch
    Antworten: 461
    Letzter Beitrag: 14.11.2014, 13:43
  2. Antworten: 2
    Letzter Beitrag: 11.05.2014, 08:14
  3. Antworten: 2
    Letzter Beitrag: 14.04.2014, 16:31
  4. TIA Tia v12 / v13
    Von rise66 im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 04.04.2014, 16:23
  5. TIA Portal V13
    Von UniMog im Forum Stammtisch
    Antworten: 20
    Letzter Beitrag: 04.03.2014, 21:40

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •