Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 28

Thema: Programmieren einer Wasserkraftanlage Technikerarbeit

  1. #11
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.716
    Danke
    443
    Erhielt 914 Danke für 739 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von DanielX_12 Beitrag anzeigen
    Mit was für einem Programm abreiten die Profis wo auch SCL... programmieren?
    SCL kann TIA ja mit der S7-1200. Nur halt AWL nicht.
    Das liegt aber nicht an TIA sondern an der S7-1200.

  2. #12
    Registriert seit
    11.11.2013
    Ort
    Bielefeld
    Beiträge
    12
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich hoffe nicht mit TIA wenn ja kann die 1500er sicher AWL.
    Warum ist deine Wahl eigentlich überhaupt auf TIA gefallen ? Warum nicht eine 300er ?

    Aber ein schönes Projekt hast du du dir dort ausgesucht.

  3. #13
    DanielX_12 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    08.11.2014
    Beiträge
    14
    Danke
    2
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Die 1200er wurde mir von Siemens empfohlen und gefördert!

    Kann mir bitte jemand helfen wie ich die Analogeingänge aufarbeiten kann nun mit der S7 1214 und Tia Portal V12?
    Was muss ich an den Eingängen für meine Drehzahlsensoren einstellen um dort ein Signal zu empfangen? und wo?

    würde mich um eine Antwort freuen.
    mit freundlichen Grüßen
    Daniel

  4. #14
    Registriert seit
    11.11.2013
    Ort
    Bielefeld
    Beiträge
    12
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Was für Sensoren hast du denn ?
    Was geben sie raus ? 4-20mA oder 0-10V ? Impulse ?
    Eigentlich ist die Bausteinverarbeitung doch auch nicht so viel anders als wie bei der S7-XXX. Aufjeden musst du das PEW auslesn
    Geändert von PLRK (17.11.2014 um 18:06 Uhr)

  5. #15
    Registriert seit
    23.07.2009
    Ort
    Österreich
    Beiträge
    2.339
    Danke
    449
    Erhielt 688 Danke für 513 Beiträge

    Standard

    Zitat Zitat von DanielX_12 Beitrag anzeigen
    Die 1200er wurde mir von Siemens empfohlen und gefördert!
    Kann mir bitte jemand helfen wie ich die Analogeingänge aufarbeiten kann nun mit der S7 1214 und Tia Portal V12?
    Im Prinzip musst du das gleiche machen wie bei einer S7-200er/S7-300er/S7-400er/S7-1500er und so ziemlich jeder anderen Steuerung auf dem Planeten. Stichwort Analogwert "Normieren" [EDIT]und[/EDIT] "Skalieren"
    Empfehlung Link 1 mit TIA-Bordmitteln

    Empfehlung Link 2 mit FCs und simpler Formel

    Gefunden via Forensuche oder Google

    Zitat Zitat von DanielX_12 Beitrag anzeigen
    Was muss ich an den Eingängen für meine Drehzahlsensoren einstellen um dort ein Signal zu empfangen?
    Wie arbeiteten denn deine Drehzahlsensoren?
    Geändert von RONIN (17.11.2014 um 18:49 Uhr)
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

  6. Folgender Benutzer sagt Danke zu RONIN für den nützlichen Beitrag:

    DanielX_12 (17.11.2014)

  7. #16
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.716
    Danke
    443
    Erhielt 914 Danke für 739 Beiträge

    Standard

    Zitat Zitat von RONIN Beitrag anzeigen
    Stichwort Analogwert "Normieren" oder "Skalieren"
    Nicht oder - und!

  8. #17
    DanielX_12 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    08.11.2014
    Beiträge
    14
    Danke
    2
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Vielen Dank für die Schnelle Rückmeldung, Habe nun die Bausteine für die Analogwertverarbeitun gefunden ( norm / scale )
    Meine beiden Pegelsonden haben 0-20mA, die beiden Maschinenöffnungen und der Agregatedruck hat 0-10Vüber Spannungsteiler!
    Muss ich Ampere und Volt etwas verstellen?

    Ich habe als Drehzahlsensor einen normalen Induktivgeber, welcher mir bei einer Generatorumdrehung ein Signal geben sollte.
    20141112_180038.jpgSollte das Programm funktionieren? B1 ist mein DSensor und bei 960 1/min sollte der Schütz Q einschalten?

    20140918_165536.jpg
    Geändert von DanielX_12 (24.11.2014 um 17:36 Uhr)

  9. #18
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.732
    Danke
    314
    Erhielt 1.519 Danke für 1.282 Beiträge

    Standard

    Wenn ich mir deinen Anbau hier so anschaue, würde ich sagen du musst den Betätigungsschraube entweder so gestalten, das dein Ini eine halbe Umdrehung der Schwungscheibe betätigt ist,
    oder schnelle Zähler verwenden ... was aber eine Umbelegung deiner EAs erfordert (Stichwort hier HSC).
    Bei 1000 U/Min hast du 16U/Sek und bezogen auf den Betätigungswinkel deiner Schraube ist die Betätigungszeit für einen normalen Eingang sehr sicher zu kurz

    Zu deinem Programm: Das wird so mit an Sicherheit grenzender Wahrscheinlichkeit nicht funktionieren.
    Da du sowieso einen schnellen Zähler benötigst, kannst du das ganze in der HW-Konfig auch als Frequenzmessung parametrieren (ich hoffe mal, das geht mit den S7-1200 HSCs).

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  10. #19
    Registriert seit
    23.07.2009
    Ort
    Österreich
    Beiträge
    2.339
    Danke
    449
    Erhielt 688 Danke für 513 Beiträge

    Standard

    Zitat Zitat von DanielX_12 Beitrag anzeigen
    Meine beiden Pegelsonden haben 0-20mA
    Muss ich Ampere und Volt etwas verstellen?
    Je nachdem was du verwendest. Die CPUs habe On-Board nur 0-10VDC Analogeingänge. Dort kann man sich helfen in dem man für 0/4-20mA einen 500Ohm Widerstand parallel schaltet. Wenn du ein Erweiterungsmodul verwendest das von Haus aus 4-20mA kann, dann musst du nichts spezielles machen.
    Die Einstellungen/Parameter des Analogeingangs in der Hardwarekonfig musst du aber in beiden Fällen richtig setzen.

    Zitat Zitat von DanielX_12 Beitrag anzeigen
    Ich habe als Drehzahlsensor einen normalen Induktivgeber, welcher mir bei einer Generatorumdrehung ein Signal geben sollte.
    Sollte das Programm funktionieren? B1 ist mein DSensor und bei 960 1/min sollte der Schütz Q einschalten?
    NEIN

    1. Bei deinem Vorschlag wird jede Sekunde der Zähler zurückgesetzt und dein Schütz gleich mit. Das wiederholt sich ein paar mal und dann ist was kapputt. Du musst also was machen das der Schütz drin bleibt wenn er mal geschalten hat. Ich würde das sowieso auftrennen in ein Signal "Drehzahl OK" und erst dann (eventuell mit weiteren Prüfabfragen) dann den Schütz schalten.

    2. Musst du bei so was immer die Signal-Dauer beachten. Wenn sich die Welle mit 960U/min und entsprechender Winkelgeschwindigkeit dreht, dann hängt es von der Größe der Objekts dass dein Initiator erfasst ab, wie viele Millisekunden das Signal auf 1 geht und ob die SPS überhaupt genügend Zeit hat dieses Signal korrekt zu erkennen.
    Stichwort Eingangs-Verzögerung (Entprellung) an den Digitaleingägen, die kann man in der Hardware-Konfig verstellen.

    Bei Standard-Eingängen sollten damit es sicher geht min. 30ms Puls / 30ms Pause sein.

    Zitat Zitat von DanielX_12 Beitrag anzeigen
    die beiden Maschinenöffnungen und der Agregatedruck hat 0-10A über Spannungsteiler!
    0..10A.. ?? hä..


    [EDIT] MSB war schneller
    Wie MSB schon schrieb wirst du mit dem HSC (High Speed Counter) wohl besser dran sein
    [/EDIT]
    Geändert von RONIN (18.11.2014 um 06:33 Uhr)
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

  11. #20
    DanielX_12 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    08.11.2014
    Beiträge
    14
    Danke
    2
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Kann mir jemand das skalieren und Normieren meiner Analogwerte erklären?
    20141124_164703.jpg20141124_164622.jpg
    meine Beiden Pegelsonden sind nicht direkt auf dem Boden (250 mm Abstand) den Wert zwischen 4 und 20mA bekomme ich eingelesen welches 0 bis 6000mm entspricht. 0 mA sollen also bei mir 250mm sein!
    Bei meiner Turbinenöffnung ist das Problem das die Signale inverse sind. 1V entspricht 100% offen und 9,5V (geschlossen) 0%
    würde mich über Vorschläge freuen.

    mit freundlichen Grüßen
    Daniel

Ähnliche Themen

  1. TIA Technikerarbeit Stickstoffregelung
    Von Simon Bosch im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 31.07.2013, 11:17
  2. Programmieren einer ET200s
    Von wapiti im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 15.06.2010, 00:26
  3. Technikerarbeit/Abschlussarbeit
    Von CryingFreeman im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 30.10.2008, 22:50
  4. Technikerarbeit Bausteine gelesen
    Von nonguru im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 03.10.2008, 19:44
  5. Programmieren einer S7 über Ethernet
    Von Balou im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 01.08.2004, 18:00

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •