Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: EEprom für CPU 103

  1. #1
    Registriert seit
    28.12.2012
    Beiträge
    6
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Guten Morgen zusammen,

    an der Steuerung für meinen LKW(CPU103) war die Pufferbatterie(obwohl nur 1,5Jahre alt) leer also Programm im AG weg.Habe das identische Programm in einer anderen CPU103 (mit intakter Pufferbatterie) drin.Also Rechter Schalter auf Stop Strom aus EEProm stecken Strom 1 3sec copy halten aber es blinkt immer die rote LED habe dies mir zwei identischen EEprom`s versucht Typ 6ES5 375 0Lc11.Nun meine Frage können diese EEprom für die CPU 103 nicht verwendet werden (Speicherplatz zu klein oder muß falls ein anderes Programm gespeichert wäre diese gelöscht werden.Wo habe ich einen Denkfehler.7



    Vielen Dank für die Hilfe im vorraus


    Gruß Markus
    Zitieren Zitieren EEprom für CPU 103  

  2. #2
    Registriert seit
    21.01.2008
    Ort
    Lippe
    Beiträge
    317
    Danke
    43
    Erhielt 49 Danke für 46 Beiträge

    Standard

    Wenn du ein EEprom mit Programm darauf in eine CPU steckst, wird dieses sofort gelesen (rote LED flackert schnell) den Copy Taster sollte man nicht benutzen, damit schreibt man auf dasc EEprom!
    ***************************************

    Sonnige Grüße online


    Wegen hübschen Frauen kaufen wir Bier, wegen häßlichen Frauen trinken wir Bier...

  3. #3
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.726
    Danke
    314
    Erhielt 1.519 Danke für 1.282 Beiträge

    Standard

    Da dein EEPROM 375-0LC11 nur ein 2K ROM ist, ist dieses mit allergrößter Wahrscheinlichkeit zu klein.
    (2K = 1024 Anweisungen, die CPU 103 hat aber bis zu 10240 Anweisungen ...)
    100 Prozent könnte man das nur mit einem PG feststellen, durch Analyse von USTACK oder Bausteingrößen.

    Im Schlimmsten Fall benötigst du ein 32K EPROM, falls die Kiste "voll" sein sollte.

    @online
    Um das zu verhindern ist im Handbuch mehr als einmal darauf hingewiesen, das die Pufferbatterie intakt sein muss.
    Ansonsten geb ich dir insofern recht, als das das Vorgehen des TE im Rahmen seiner geschilderten Situation schon einen gewissen "Mut" erfordert ...

    Mfg
    Manuel
    Geändert von MSB (11.11.2014 um 10:51 Uhr)
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  4. #4
    Agrostar6.38 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    28.12.2012
    Beiträge
    6
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Schon mal Danke für die Antworten.
    Man sieht halt das ich mich mit der Materie zu wenig auskenne,jetzt kann man mir natürlich vorwerfen lass die Finger davon.Was mich ärgert ist das die Pufferbatterie nur 1.5 Jahre gehalten hat diese werden von mir eigentlich schon regelmäßig erneuert habe aber schon welche gesehen die 8 Jahre drin waren.
    nach der Schildrung waren die EEProm`s leer.Werde versuchen ein größeres zu besorgen.

    Danke Markus

  5. #5
    Registriert seit
    15.04.2011
    Beiträge
    1.122
    Danke
    229
    Erhielt 208 Danke für 176 Beiträge

    Standard

    Erweckst Du denn die Pufferbatterien vor dem Einsetzen aus dem Tiefschlaf geweckt?

    http://support.automation.siemens.com/WW/view/de/153047
    Geändert von 190B (11.11.2014 um 16:17 Uhr)
    Gruß
    190B

  6. #6
    Agrostar6.38 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    28.12.2012
    Beiträge
    6
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Guten Abend zusammen,

    Vielen Dank für die Hilfe.Es war tatsächlich so das der Speicherplatz der eeprom zu klein war.Anderes EEprom besorgt und dann hat alles so geklappt wie ich es mir vorgestellt habe.Programm von CPU auf eeprom übertragen und auf anderer CPU hochgeladen Anlage funktioniert. Das die Pufferbatterien aufgeweckt werden müssen habe ich nicht gewusst .Habe es auch an einer CPU 100 versucht dort war eine funktionierende Pufferbatterie aus 1993 drin!!!!!!!!!!!!!!

    Das Programm sollte jetzt ja dauerhaft auf der EEprom gesichert sein oder dies wird ja nicht nach dem hochladen wieder glöscht?


    Nochmals Danke an alle.

    Gruß Markus

  7. #7
    Registriert seit
    21.01.2008
    Ort
    Lippe
    Beiträge
    317
    Danke
    43
    Erhielt 49 Danke für 46 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Das Programm bleibt nun dauerhaft auf dem EEprom, es sei denn du löscht/überschreibst es.
    ***************************************

    Sonnige Grüße online


    Wegen hübschen Frauen kaufen wir Bier, wegen häßlichen Frauen trinken wir Bier...

Ähnliche Themen

  1. EEPROM auf S5 CPU 103 übertragen
    Von Agrostar6.38 im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 29.12.2012, 09:17
  2. S5 CPU 103 - stop
    Von Hr.Nehrving im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 14.12.2011, 06:55
  3. Analogbearbeitung S5 100U CPU 103
    Von Würgenippel im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 06.06.2008, 12:48
  4. EPROM für S5 CPU 103
    Von Rudi im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 28.08.2007, 19:41
  5. S5 100u Cpu 103
    Von Wilhelm im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 28.07.2007, 16:36

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •