Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 2 von 2

Thema: OPC Scout 10 Verbindung mit S7-200 über TCP/IP

  1. #1
    Registriert seit
    29.09.2008
    Beiträge
    17
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Zusammen,

    ich habe aktuelle Schwierigkeiten die Werte E/A/M einer S7-200 Steuerung über OPC Scout abzurufen.

    Aufbau.:
    1. S7-200 mit CP 243-1 konfiguriert und im Netz vorhanden
    2. OPC Server installiert Simatic Net Softnet-IE S7 lean V12 (6GK1704-1LW12-0AA0)
    3. Ein S7-Projekt erstellt mit IE Allgemein und OPC jeweils Vers. 8.2 im Net-Pro übersetzt.
    4. Die XDB Datei über den Komponenten Konfigurator importiert - alles grün !
    5. Bei Beobachtung der Variablen bekomme ich Qualität "ungültig" bei Ergebnis "S_OK"
    6. Bei Ansicht von z.B. S7:[S7-Verbindung_1]&statepath() kommt Qualität "gut"

    Wie muss die S7-200 Seite programmiert werden um einzelne Bits im OPC anzeigen zu können.

    Über einige Tipps oder Beispiele wäre ich dankbar.
    Angehängte Grafiken Angehängte Grafiken
    Zitieren Zitieren OPC Scout 10 Verbindung mit S7-200 über TCP/IP  

  2. #2
    Registriert seit
    27.10.2009
    Beiträge
    317
    Danke
    0
    Erhielt 64 Danke für 54 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Die S7-Verbindung ist im Zustand "Recovery". Sie wurde also NICHT korrekt aufgebaut. Als Folge davon ist die ArrayVariable "bad".
    Du musst dir also deine Verbindungskonfiguration nochmal genau anschauen, irgendetwas stimmt da nicht (IP, TSAP, aktiver Aufbau, etc.)

    Gruß
    Dr. OPC

Ähnliche Themen

  1. Antworten: 2
    Letzter Beitrag: 07.08.2014, 08:19
  2. WinCC 7.0 OPC Abfrage über Client OPC-Scout
    Von GobotheHero im Forum HMI
    Antworten: 3
    Letzter Beitrag: 27.06.2013, 12:31
  3. Sonstiges OPC Scout verbindet nicht mit OPC Server
    Von ohmshiva23 im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 22.04.2013, 09:19
  4. Probleme mit OPC Server und OPC Scout
    Von Heiti im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 20.09.2010, 15:16
  5. Verbindung über MPI mit OPC auf S7-300?
    Von obviate im Forum Hochsprachen - OPC
    Antworten: 8
    Letzter Beitrag: 15.09.2008, 14:28

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •