Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: FDL Verbindungen

  1. #1
    Registriert seit
    25.03.2006
    Beiträge
    13
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Böse


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich habe eine Anlage mit 4 Stk. 315 2 DP und 2 Stk. 317, alle 6 mit CP 342-5. die cp's sind mit einem profibusnetzt (1,5M länge ca 80m) verbunden.

    es soll zwischen den cpu's mittels FDL kommuniziert werden (je verbindung ca. 200 Byte).
    auf den 315'ern gibt es jeweils 3 FDL verbinungen:
    2 zu einer der 317
    1 zu einer anderen 315

    auf den den 317'ern gibt es jeweils 6 FDL verbindungen:
    2 zu der anderen 317
    2 zu einer 315
    2 zu einer anderen 315

    der datenaustausch erfolgt über ag_send und receive - parallel und permanent

    Nun so siehts aus.

    bis vor kurzem hatte ich das laufen ohne die verbindung 2 FDL zwischen den 317 und es lief ohne probleme(ist zumindest nichts aufgefallen).

    dieser tage habe ich die 2 Verbindungen dazu gebaut und mir fällt jeweils eine der verbindungen von 315 zu 317 in richtung 315 zu 317 aus. auf den anderen treten teilweise fehler auf.
    die fehlermeldung , bzw. der diagnosepuffer im CP deuten auf ein resurcenproblem ...
    die hilfe allerdings behauptet, dass 16 Verbindung auf einem CP möglich sind...

    Kann es sein das profibus überlastet ist ? wie kann ich das diagnostizieren?

    im forum bin ich über den beitrag
    FDL-Verbindungen Simatic
    gestolpert. darin wird behauptet, dass die kommunikation der FDL's sequetiell sein soll. ist das definitiv so?
    ich habe laufzeit bedenken bei 6 FDL's ... wieviel zyklen dauert eine übertragung, das mal 6?

    ID's und datenlänge habe ich natürlich bereits überprüft.

    Übrigens bin in China und wir suchen zu zweit seit ca. 15 Stunden, langsam gehen die Ideen aus - aber so wie mein kollege immer sagt "Aufgeben gibt's nicht -never ever"

    danke im voraus an die
    "SPS Selbsthilfe Gruppe"
    Zitieren Zitieren FDL Verbindungen  

  2. #2
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.224
    Danke
    630
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Bei der Kommunikation zwischen PC und SPSen ist mir bis jetzt nicht aufgefallen, dass diese sequentiell über alle Verbindungen abfolgen muss. Ich denke, das Projekt mit der Hardwarekonfig und zumindest mit den Kommunikationsaufrufen wäre sicher hilfreich für die Fehlersuche. Dort wird dann auch klar, welche Ausgabestände der Komponenten verwendet werden. Haben Sie schon einmal versucht bei den 315er den DP (ist doch vorhanden?) über die 342-5 und die Kommunikation über die Onboard Profibus-Schnittstelle zu fahren? Was ist der momentane Stand?
    Geändert von Rainer Hönle (26.03.2006 um 10:22 Uhr)
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  3. #3
    sps_horst ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    25.03.2006
    Beiträge
    13
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    wie kann ich ihnen die Daten zukommen lassen?
    Die Softwarestände der CP's sind V5.2 da bei V5.4 das Routing nicht funktioniert - Softwarefehler (hat übrigens über 1 Woche gedauert bis wir das in Zusamenarbeit mit Siemens raus hatten).
    Schnittstellenwechsel haben wir noch nicht versucht, bin mir nicht sicher welche Auswirkungen das auf die OP Verbindungen hat und wie lange das dauern würde bzw. wielange der Anlagenstillstand ist bis es wieder läuft.
    Übringens die 317 haben auch eine DP auf der CPU.

    Momentaner Stand:
    Wir haben beschlossen es morgen einmal sequenziell zu probieren, geht relativ schnell und ein Anlagenstillstand ist unwarscheinlich.

    Die Hilfe (Programmbeispiel von FC5 ) läßt, wenn man zwischen den Zeilen liest, einen sequentiellen Aufruf durchblicken.
    dies in Verbindung mit dem Beitrag FDL-Verbindungen Simatic bringt uns zu diesem Entschluß.

    Abgesehen davon möchte ich auch wenn das funktioniert genau wissen wurm es sonst nicht gegangen ist.
    Nur probieren bis es geht ist eigentlich nicht meine Arbeitsweise ...

    danke für die Antwort

    sps_horst

  4. #4
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.224
    Danke
    630
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Einfach das gepackte Projekt als Anhang zu einer Nachricht hochladen. Was sie SPS-SPS-Kommunikation angeht gibt es hier im Forum größere Spezialisten als mich. Mein Schwerpunkt liegt in der PC-SPS-Kommunikation (und dort habe ich einiges mit FDL-Kommunikation zu tun). Werde dann auch einen Blick auf das Projekt werfen.
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  5. #5
    Inbetriebnehmer Gast

    Cool

    Hallo Zusammen,
    bin zwar eben erst "reingeschneit", hätte aber eine Idee: Wenn der Profibus (wie ich erwarte) mit 12Mbit fährt, setzt ihn doch mal runter auf 1,5. Das hat bei mir schon wunder bewirkt. Mit 80m länge (+X) kann er durch die reduzierung erheblich unempfindlicher werden.
    Hoffe es klappt
    Gruss
    CB
    Zitieren Zitieren Vorschlag  

  6. #6
    sps_horst ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    25.03.2006
    Beiträge
    13
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    so sieht es zur Zeit aus:

    Wir haben die Aufrufe der ag_send squentiel ausgeführt und die zur zeit noch nicht benötigten FDL's gelöscht(zu der ander 317) und die Konfiguration neu eingespielt. Anschließend haben wir alle CPU's ausgeschaltet(spannungslos) und nacheinander wieder eingeschaltet.

    Nun laufen die Verbindungen mehr oder weniger, dh. jede Verbindung von 317 zu 315 bring ca. 15% Error (8302). In die andere Richtung habe ich die Zähler noch nicht drin.

    Auszug aus der Hilfe:
    keine Empfangsresourcen bei Ziel-Station, Empfänger-Station kann empfangene Daten nicht schnell genug verarbeiten bzw. hat kein Empfangsressourcen bereitgestellt.

    Die Zykluszeiten der CPU's:
    315 ca. 60ms
    317 < 20ms
    Übrigens der Profibus läuft schon immer auf 1,5 MBit.

    Mir stellen sich folgende Fragen:

    kommen die Fehler durch,
    * pysikalische Proble am Bus (Schirm, Verlegung, ...)?
    * zu langsamer Profibusbus?
    * zu schneller Profibus?
    * Bus überlastet?
    * CP überlastet?
    * zu lange Zykluszeit auf der 315 -> CP bringt die Daten nicht weg?

    Wie kann ich das diagnostizieren?


    So soll's weiter gehnen:

    Einbau der 2 Verbindungen zw. den 317, mal sehen ob die Error steigen.
    Veränderung der Profibusgeschwindigkeit auf 500kBit - 6MBit, wenn es mit niedriger Übertragungsrate besser wird sollte es ein pysikalisches Problem, sonst ein Busgeschwindigkeitsproblem sein. Oder?

    Vielleicht hat jemand ander Vorschläge oder weiß was zur Diagnose?

    Danke im Voraus

    sps_horst

  7. #7
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.224
    Danke
    630
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Bei dieser Fehlermeldung glaube ich an eine Überlastung der "kleinen" CPU. Dann darf es allerdings in der Gegenrichtung kaum zu Fehlern kommen. Wie hoch ist die Zykluszeitbelastung durch Kommunikation bei den einzelnen CPUs parametriert? Können Sie mir mal das Projekt (nur mit dem Kommunikationsanteil) zumailen? Ich möchte mir das Ganze mal mit einem Busanalyser ansehen, was in welchen Fällen auf dem Bus wirklich passiert und was die eigentliche Ursache für die Fehlermeldung ist. Ich komme allerdings erst nächste Woche zum testen.
    Geändert von Rainer Hönle (28.03.2006 um 17:41 Uhr)
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  8. #8
    sps_horst ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    25.03.2006
    Beiträge
    13
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    das haben wir heute der Reihe nach gemacht:

    * Fehlerzähler für AG_SEND in die 315.
    -> siehe da keine Fehler.

    Die Zykluszeiten der CPU's:
    315 ca. 60ms
    317 < 20ms
    -> Anscheinend holt die 315 die Daten nicht schnell genug aus dem CP (Vermutung).

    * Anderung des Komunikationsaufruf's von OB1 in OB35 mit 50ms Intervall (weil die 317 2-3 Zyklen für ein AG_send braucht)
    -> Siehe da auf beiden Seiten keine Fehler mehr (beobachtet über mehr alls 5000 AG_send)

    * die ausgebauten Verbindungen wieder eingebaut.
    -> geht noch immer fehlerfrei

    *Den sequentiellen Aufruf der AG_Send wieder auf "DAuer", sprich 1 auf ACT gelegt.
    -> geht noch immer fehlerfrei.

    Schluß aus dem obigen:

    Offenbar sollten AG_SEND und RECEIVE auf beiden Partner der FDL Verbindung mit halbwegs gleichem Intervall aufgerufen werden, damit der CP auf der "langsameren" CPU nicht übergeht.
    Die AG_SEND und RECEIVE müßen nicht sequentiell sein (auf 2 der CPU's sind 7 FDL mit je ca. 200 Byte bidirektional, auf dem Profibus dürften gesamt ca. 2kB alle 50ms übertragen werden mit 1,5Mbit Busrate)


    übrigens: hat uns beiden jeweils ca. 35 Stunden gekostet

    Danke für die Mithilfe

    sps_horst

Ähnliche Themen

  1. Verbindungen via OPC
    Von thomasgull im Forum HMI
    Antworten: 2
    Letzter Beitrag: 14.01.2011, 21:39
  2. HMI´s 2 Verbindungen
    Von 4nD1 im Forum HMI
    Antworten: 12
    Letzter Beitrag: 13.01.2011, 06:39
  3. NetPro Verbindungen
    Von dapi911 im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 28.04.2010, 20:06
  4. S7 Verbindungen
    Von torstenh im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 08.07.2009, 11:52
  5. mehrere TCP-Verbindungen
    Von Jelly im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 14.11.2006, 14:24

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •