Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 19 von 19

Thema: Problem mit Timer

  1. #11
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Warum soll bzw muss der Timer zurückgesetzt werden?
    Wenn der Eingang des Timers nach 0 wechselt, bleibt der doch stehen und bei dem nächsten 1 Signal wird der wieder neu gestartet.
    Ich denke ein Merker, der von der Lichtschranke gesetzt wird und vom abgelaufenen Timer zurückgesetzt wird, macht hier das was der TE braucht.
    ODER:
    Der Kollege schreibt einen Kommentar zu den Ein- und Ausgängen, dann kann man auch eine andere Lösung ggF finden.

    Sonst hilft nur meine Glaskugel und die ist bei der Kälte heute Morgen eingefroren


    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  2. #12
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.716
    Danke
    443
    Erhielt 914 Danke für 739 Beiträge

    Standard

    Zitat Zitat von bike Beitrag anzeigen
    Wenn der Eingang des Timers nach 0 wechselt, bleibt der doch stehen und bei dem nächsten 1 Signal wird der wieder neu gestartet.
    Speichernde Einschaltverzögerung bleibt nicht stehen, sondern läuft weiter, bis sie resettet wird.
    War lt. TE auch so erwünscht, da nach Betätigung der Lichtschranke eine festgelegte Zeit bis zur Aktion vergehen soll, aber die LS selbst in der Zwischenzeit schon wieder frei gegeben wird.


    Zitat Zitat von bike Beitrag anzeigen
    Ich denke ein Merker, der von der Lichtschranke gesetzt wird und vom abgelaufenen Timer zurückgesetzt wird, macht hier das was der TE braucht.
    Ich würde eher einen Merker verwenden, der von der abgelaufenen Zeit gesetzt und von der darauf zu Ende ausgeführten Ausstoss-Aktion rückgesetzt wird. (Bzw. das Ganze in eine vernünftige Schrittkette einbinden.)



    Und ich stimme auch vollmi zu, dass es unter FUP/KOP in der Regel übersichtlicher ist, den Timer (mit dessen Auslösung und Reset) und die daraus resultierenden Aktionen netzwerktechnisch zu trennen.

  3. #13
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Zitat Zitat von hucki Beitrag anzeigen
    Speichernde Einschaltverzögerung bleibt nicht stehen, sondern läuft weiter, bis sie resettet wird.
    Mist, da habe ich falsch gelesen, tut mir leid.
    Habe irgendwie SE gelesen, daher die Beschreibung von mir.

    Aber ich denke wir gehen konform, wenn der TE sein Stückchen Code kommentieren würde, wäre es leichter sinnvoll zu helfen.


    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  4. #14
    baiko ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    28.11.2014
    Beiträge
    7
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ok sitze immer noch etwas ratlos vor diesem Miniprogramm. Also hab jetzt den Timer in ein extra Netzwerk gepackt. Da Problem bleibt. Der Timer springt gar nicht erst an obwohl das Eingangssignal anliegt. ( in win sps läuft er zumindest - in Trysim tut er das nicht ) die Resetfunktion wurde von mir jetzt über ein Zeitverzögertes Signal der LS 3 geschalten dieser Timer wiederum wird über die LS 1 resettet. ( Zu kompliziert?) Nun nochmal die AWL:
    NW 1
    UN E 0.1 // Lichtschranke 1
    U M 0.0
    UN E 0.3 // Lichtschranke 3
    U E 0.4 // Auswahlschalter
    = A 0.0 // Ausstossvorrichtung

    NW 2
    U E 0.2 // Lichtschranke 2
    L S5T#3S
    SS T 100
    U M 0.1
    R T 100
    U T 100
    = M 0.0

    NW 3
    U E 0.3
    L S5T#2S
    SS T200
    U E 0.1
    R T 200
    U T 200
    = M 0.1

    zur Erkärung der Aufgabe es sollen Werkstücke die nur die LS 2 Belegen aussortiert werden bei eingeschaltetem Auswahlschalter.
    Geändert von baiko (16.12.2014 um 09:15 Uhr) Grund: Fehler Awl

  5. #15
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Kannst du uns verraten, wie die einzelnen Eingänge heißen?
    Warum musst du die Timer zurücksetzen?
    Wie schon beschrieben, meine Glaskugel ist eingefroren.


    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  6. #16
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    ass.JPG

    ___________________________
    Zitieren Zitieren Quick 'n dirty  

  7. #17
    baiko ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    28.11.2014
    Beiträge
    7
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Timer muss ich zurücksetzen da es SS sind die resettet werden müssen

    E 0.1 // Lichtschranke 1
    E 0.2 // Lichtschranke 2
    E 0.3 // Lichtschranke 3
    E 0.4 // Auswahlschalter

  8. #18
    baiko ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    28.11.2014
    Beiträge
    7
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    @ verpolt Vielen Dank so geht es. An einen Flipflop hab ich überhaupt nicht gedacht. Irgendwie kämpf ich auch noch immer mit der Logik. Vielleicht hatte ich einfach ein falsches Denkmodell im Kopf nur die LS 2 über einen Timer laufen lassen zu wollen. Danke nochmal.

  9. #19
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Du hast kein falsches Denkmodell.
    Du hast eine andere "Spur" verfolgt.

Ähnliche Themen

  1. Step 7 S7 Timer Problem
    Von jule im Forum Simatic
    Antworten: 23
    Letzter Beitrag: 21.02.2014, 14:00
  2. problem mit timer
    Von linuxluder im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 06.11.2007, 16:41
  3. Problem mit FB, Timer und Bezeichnung
    Von Anonymous im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 24.10.2004, 13:58
  4. Antworten: 5
    Letzter Beitrag: 13.08.2004, 22:54
  5. Problem mit Timer und Zähler innerhalb eines FC
    Von Anonymous im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 01.06.2004, 09:43

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •