Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 20

Thema: Simatic Manager ohne Hardware im Simulationsmodus:

  1. #1
    Registriert seit
    29.11.2014
    Beiträge
    37
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    man hat den Simatic-Manager (nur Software ohne Hardware). durch welche Schritte kommt man zum Programmschreiben?

    Ich habe den Simatic-Manager geöffnet und das Projekt erzeugt. (momentane Zustand in Anhang gezeigt).

    Meine Frage wäre:

    Nun wie komme ich zur Simulation weiter da ich keine Hardware habe? Eine fiktive Hardware-Konfiguration geben (z.B. Einfügen -> Station - -> S7-300 - > NT, CPU, Baugruppen) ?
    Gibt es Simulationsmodus so dass das wirkliche Vorhandensein von Hardware nicht relevant ist?

    Genauer gesagt wie (durch welche Schritte) komme ich aus dem momentanen Zustand zum OB1 wo ich ein einfaches FUP-Programm schreiben und zum DI/DO-Testen (als Lämpchen) kommen werde?
    Angehängte Grafiken Angehängte Grafiken
    Zitieren Zitieren Simatic Manager ohne Hardware im Simulationsmodus:  

  2. #2
    Registriert seit
    23.03.2013
    Beiträge
    66
    Danke
    11
    Erhielt 17 Danke für 11 Beiträge

    Standard

    1. Hardware öffnen
    2. Profilschiene hinzufügen
    3. Cpu hinzufügen
    4. weitere Komponenten hinzufügen
    5. Alles konfigurieren
    6. Speichern und übersetzen
    7. Hardwarekonfiguration schließen
    8. Nun gibt es ein S7-Programmordner mit OB1

    Zum Testen deines Programms ohne Hardware benötigst du Simatic PLCSIM, welches extra zu kaufen ist.

    Frohe Weihnachten!

  3. #3
    Jonni ist offline Benutzer
    Themenstarter
    Registriert seit
    29.11.2014
    Beiträge
    37
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Vielen Dank und schöne Feiertage!

  4. #4
    Registriert seit
    12.12.2013
    Ort
    Kaiserslautern
    Beiträge
    1.337
    Danke
    385
    Erhielt 218 Danke für 173 Beiträge

    Standard

    Hallo Jonnie,

    Online sind sehr viele Beispielen und Anleitungen zu finden.

    Zum Beispiel HIER

    Bram
    Wenn es nicht auf STRAVA ist, ist es nicht passiert !!

  5. #5
    Registriert seit
    12.03.2011
    Ort
    Erzgebirge
    Beiträge
    247
    Danke
    77
    Erhielt 29 Danke für 27 Beiträge

    Standard

    Zum Testen deines Programms ohne Hardware benötigst du Simatic PLCSIM, welches extra zu kaufen ist.
    Also ich denke PLCSIM ist schon seit Jahren standartmäßig im S7.. enthalten.
    Wie auch immer, an diesem Symbol erkennst du, ob du es auf deinem Rechner hast.
    PLCSIM.jpg

    .. Einfach starten ... Die virtuelle CPU auf RUNP schalten ... Bausteine übersetzen ... Bausteine Übertragen ...

    Viel Erfolg

  6. #6
    Jonni ist offline Benutzer
    Themenstarter
    Registriert seit
    29.11.2014
    Beiträge
    37
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Vielen Dank für die Tipps und Hilfe.

    PLC_Sim ist also bei mir vorhanden im Moment.

    Jetzt wollte ich einfaches Programm im OB1 im FUP schreiben, wo einfaches "Und"-Schaltung realisiert wird und mit Hilfe von PLC_SIM die Eingänge auf "1" setzen können und am Ausgang das Ergebnis "0" oder "1" sehen.
    Ich habe die Hardware entsprechend konfiguriert (s. Anhang HW-Konfig): so dass die erste DI/DO-Baugruppe E-Adresse 0...1 und A Adresse 0...1 hat; ....und wollte die Eingänge E0.0 und E0.1 und Ausgang A0.0 nennen.

    Als ich 1) im Simatic-Manager (Menü) "Simulation ein" gesetzt habe, habe ich 2) die angezeigte Bytes in EB0 (mit Bit E0.0 und E0.1) und AB0 (mit Bit A0.0) umbenannt (s.Anhang), 3) virtuelle CPU auf RUN gesetzt ...
    aber im AB0 ist bit A0.0 dann keine Anzeige....

    Ich bitte um Hilfe, was habe ich falsch getan? wie kann ich im PLC_SIM : E0.0, E0.1 (EB0) sehen und richtig auf "1" setzen können und A0.0 (AB0) als Ergebnis "1" sehen ?

    Die entsprechende Bits habe ich in die Symboltabelle eingetragen. Den OB1 sieht man auch im Anhang (ist-Zustand).
    Angehängte Grafiken Angehängte Grafiken

  7. #7
    Registriert seit
    24.10.2007
    Ort
    Niederlande
    Beiträge
    673
    Danke
    22
    Erhielt 143 Danke für 135 Beiträge

    Standard

    Haben Sie die HW konfig und das programm ubertrage nach PLCSim?

    Normal must mann die PG/PC schnittstelle einstelle auf PLCsim (abhangig von cpu auf plcsim-mpi oder -profibus oder -profinet) viellicht anderd dass automatich wenn sie PLCSim start. Mit dieser einstellung kontte Sie die HW config und dass programm in die PLCSIM laden. Wenn dass ferdig ist konte sie die A0.0 steuren .

  8. #8
    Jonni ist offline Benutzer
    Themenstarter
    Registriert seit
    29.11.2014
    Beiträge
    37
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich wäre dankbar für Tipp, wie genau kann man PG/PC-Schnittstelle auf PLC_SIM einstellen?

    Was ich gefunden habe: Simatic-Manager -> Station laden in PG - > (Teilnehmer auswählen) Anzeigen -> dann erscheint MPI-Adresse 2, erreichbare TN CPU841-0 (das war nicht die Einstellung)...
    Leider hänge ich im Moment auf dieser Stelle....

  9. #9
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.725
    Danke
    314
    Erhielt 1.519 Danke für 1.282 Beiträge

    Standard

    HW-Konfig ist in deinem Fall nicht sooo wichtig ...
    Die Virtuelle Verbindung funktioniert nach deiner Beschreibung scheinbar, insofern brauchst du an deinen Schnittstelleneinstellungen nichts ändern.

    Hast du den Baustein auf die CPU geladen?
    (Symbol mit Pfeil richtung CPU)

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  10. #10
    Jonni ist offline Benutzer
    Themenstarter
    Registriert seit
    29.11.2014
    Beiträge
    37
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zur Frage ob ich PG/PC-Schnitstelle auf PLC-Sim einstellen brauche (darüber habe ich noch keine Ahnung) habe ich folgendes gefunden.

    Projekt geschlossen. (bei Bedarf öffne ich das leicht und schnell).

    Aber: SimaticManager -> Extras -> Einstellungen -> PG/PC-Schnittstelle einstellen und dann erschein sich das Bild (s Anhang) mit der Optionen mit PLCSIM... Sollte ich die Option PLCSIM(TCP/IP) oder PLCSIM(MPI) wählen? (bevor ich das Projekt öffne)?

    Es gibt in diesem Fenster auch Schnittstellen - Auswählen... dann "Auswahl" : PLCSIM V5.x --> installieren und "installiert" : PLCSIM V5.x - villeicht was damit unternehmen?
    Angehängte Grafiken Angehängte Grafiken

Ähnliche Themen

  1. Sonstiges [Simatic STEP7 / WinCC] Simulation / Übung ohne Hardware
    Von eternr3 im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 21.01.2014, 15:42
  2. Antworten: 1
    Letzter Beitrag: 08.10.2013, 15:52
  3. SIMATIC HARDWARE-MANAGER Problem - Hilfe!
    Von Berx im Forum Simatic
    Antworten: 20
    Letzter Beitrag: 12.08.2010, 11:29
  4. S7 Hardware Simulation (ohne S7 Hardware)
    Von GerhardPtl im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 17.04.2007, 21:09
  5. Antworten: 5
    Letzter Beitrag: 27.07.2004, 15:09

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •