Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 22

Thema: Cont_c Augang bleibt auf 0

  1. #1
    Registriert seit
    08.12.2014
    Beiträge
    20
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    Ich versuche verzweifelt diesen Regler in gang zu bekommen nur leider komme ich nicht dahinter was ich falsch mache. Für mein vorhaben ist ledigleich eine I Reglung von nöten. Das Ziel ist es einen Servos zu steuern meines erachtens habe ich auch alle Werte richtig eingetragen. Als Lösung habe ich versucht den Sollwert und den Istwert zu ändern was zur folge haben sollte was der Ausgang einfach auf den angeforderten Sollwert spring. Dies geschieht leider nicht, der Ausgang bleibt auf 0. Im anhang befindet sich die verschaltung des Cont_C und des Pulsgen innerhalb eines FB#s der in dem OB 35 mit 100ms aufgerufen wird. Allerdings es ist eine Pulsfrequenz von 50hz gewünscht ich vermute das diese auch mit der Aufrufzeit des OB zu tun hat.
    Ich hoffe mir kann jemand helfen.

    MfG

    Niklas
    Angehängte Grafiken Angehängte Grafiken
    Zitieren Zitieren Cont_c Augang bleibt auf 0  

  2. #2
    Registriert seit
    23.07.2009
    Ort
    Österreich
    Beiträge
    2.367
    Danke
    457
    Erhielt 696 Danke für 521 Beiträge

    Standard

    MAN_ON ist bei dir TRUE und bei MAN ist nichts....
    Soll/Ist-Wert ist auch gleich (90)

    In deinen Screenshots siehts so aus als ob dein ON-Signal nicht TRUE wäre....

    Zur Pulsfrequenz: Mit ner Aufrüfhäufigkeit von 100ms schaffst du gerade mal 5Hz
    Geändert von RONIN (29.12.2014 um 00:43 Uhr)
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

  3. #3
    NiklasM ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    08.12.2014
    Beiträge
    20
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Man_on ist standartmäßig auf true und die Varriable on dient nur dazu diese Eigenschaftes des Reglers zu aktivieren bzw. zu deaktivieren. Allerdings habe ich auch versucht Man_on zu aktivieren und bei Man einen Wert einzugeben doch nichts passiert.

  4. #4
    Registriert seit
    23.07.2009
    Ort
    Österreich
    Beiträge
    2.367
    Danke
    457
    Erhielt 696 Danke für 521 Beiträge

    Standard

    Es wäre aber auf jeden Fall Screenshots hilfreich bei denen ON auf TRUE ist und der IST-Wert vom Sollwert abweicht.
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

  5. #5
    Registriert seit
    23.07.2009
    Ort
    Österreich
    Beiträge
    2.367
    Danke
    457
    Erhielt 696 Danke für 521 Beiträge

    Standard

    Und beim HIGH-Limit ist 0.0 eingetragen und beim LOW-LIMIT ist 100.0 drin.
    Ist das von dir so gewünscht, weil ich glaube dass das nicht erlaubt ist.
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

  6. #6
    Registriert seit
    29.03.2004
    Beiträge
    5.800
    Danke
    144
    Erhielt 1.709 Danke für 1.240 Beiträge

    Standard

    Und wenn PVPER_ON auf True ist, dann wird der Eingang PV_PER für den Istwert genommen, und nicht PV_IN.

    Ich würde die ganze Beschaltung nochmal überarbeiten.

  7. #7
    NiklasM ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    08.12.2014
    Beiträge
    20
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Kann ich liefern nur verstehe ich den Sinn hinter on = 1 nicht da ich damit ledigliech den Man_on und den P-Anteil deaktiviere.
    Angehängte Grafiken Angehängte Grafiken

  8. #8
    Registriert seit
    23.07.2009
    Ort
    Österreich
    Beiträge
    2.367
    Danke
    457
    Erhielt 696 Danke für 521 Beiträge

    Standard

    Zitat Zitat von Thomas_v2.1 Beitrag anzeigen
    Und wenn PVPER_ON auf True ist, dann wird der Eingang PV_PER für den Istwert genommen, und nicht PV_IN.
    Wenn er denn seinen ON-Eingang auf TRUE bringt, dann sollte das zumindest soweit stimmen das PVPER_ON auf FALSE ist.

    Ich würde die ganze Beschaltung nochmal überarbeiten.
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

  9. #9
    Registriert seit
    23.07.2009
    Ort
    Österreich
    Beiträge
    2.367
    Danke
    457
    Erhielt 696 Danke für 521 Beiträge

    Standard

    Zitat Zitat von NiklasM Beitrag anzeigen
    Kann ich liefern nur verstehe ich den Sinn hinter on = 1 nicht da ich damit ledigliech den Man_on und den P-Anteil deaktiviere.
    Wie gesagt, wir können dir hier schwer helfen wenn du uns von Haus aus Screenshots lieferst bei denen der Regler von Haus aus 0.0 ausgeben soll.

    In deinem Fall: ON = 0 und Sollwert = Istwert.
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

  10. #10
    NiklasM ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    08.12.2014
    Beiträge
    20
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Danke das erklärt warum in keinem Beschaltungsfall ein Wert am Ausgang ausgegeben wurde, ich hab das lediglich verwechselt.

Ähnliche Themen

  1. Step 7 Pulsgen Cont_c Regelkreis
    Von NiklasM im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 08.12.2014, 22:08
  2. Micromaster 440 bleibt auf Minimal Frequenz
    Von volcomluggi im Forum Antriebstechnik
    Antworten: 0
    Letzter Beitrag: 12.06.2013, 10:13
  3. 24v Heizungrventile über Digital augang
    Von emilio20 im Forum Schaltschrankbau
    Antworten: 4
    Letzter Beitrag: 18.12.2012, 22:06
  4. Temperaturregelung FB41 Cont_c
    Von Gustel im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 30.05.2009, 07:26
  5. 2x CONT_C Regler1 greift auf 2 über
    Von Jelly im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 23.02.2006, 14:40

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •