Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: Probleme Bandsteuerung SPS

  1. #1
    Registriert seit
    20.11.2014
    Beiträge
    3
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Gemeinde
    Ich habe folgendes Problem in der SPS-Steuerung. Grundlage ist ein Umlaufband mit Trays, eine Prüstation zur Höhenprüfung und ein elektrischer Ofen.

    Normalfall
    Die auf dem Umlaufband befindlichen Trays mit den 4 Bauteilen werden an eine Höhenprüfstation gefahren . Wenn diese Trays an der Station sind (Erkennung durch Initiator) werden sie durch zwei Stopper gehalten, danach werden 2 Hubzylinder ausgefahren um die Trays zu klemmen anschließend werden die Bauteile in der Höhe vermessen. Bei erfolgreicher Vermessung gehen die Hubzylinder runter es geht die Ofentür geht auf.
    Anschließend gehen die Stopper am Band runter und der Tray wird in den Ofen geschleust und die Ofentür geht runter wenn der Tray den Initiator passiert hat.

    Problemfall 1

    Das Bauteil ist gemessen i.o. Hubzylinder gehen runter Ofentür geht nicht auf, aber Stopper am Band geht runter Tray fährt an die Tür.
    Problemfall 2
    Das Bauteil ist gemessen i.o. Hubzylinder gehen runter Ofentür geht auf, Tray wird in den Ofen geschleust aber jetzt kommt noch ein Teil hinterher wahrscheinlich ungemessen und will noch mit in den Ofen.
    Das Tray im Ofen überfährt den Ini. die Tür geht zu, 2.Tray wird von der Tür geklemmt.=====Ergebniss: Die Abschaltung der Ofentür am Ofeneingang findet nicht statt als Folge der Endschalter wird überfahren und die Kette der Ofentür wird straff aufgewickelt. Der Motor der die Tür hochzieht schaltet nicht ohne Not-Aus ab.

    Am Ofenausgang alles okay. Ist ein Tray am Ini.holt der Robbi das Bauteil. Ist das Tray mit dem Ferigteil am Ini.geht die Ofentür Ofenausgang auf und ein Tray kommt heraus.Wenn das Tray am Ini. ist geht die Ofentür wieder zu. usw.
    Hat jemand einen Tip ?
    Zitieren Zitieren Probleme Bandsteuerung SPS  

  2. #2
    Registriert seit
    03.02.2015
    Ort
    Hatten
    Beiträge
    183
    Danke
    16
    Erhielt 32 Danke für 29 Beiträge

    Standard

    Hallo,

    das kann ja nun, ohne die Anlage und das Programm zu kennen, viele Gründe haben.
    Ist das als Schrittkette geschrieben?

    Zu Problem 1: Den Stopper erst runtergehen lassen, wenn die Tür auch offen ist... Zumindest steht dann die Anlage und Du kannst nachsehen, warum die Tür nicht aufgeht... bekommt die nur einen Impuls? Bekommt die den eventuell nicht mit? Zu kurz? Geht ein Dauerbefehl? Mal erforscht, warum die Tür nicht aufgeht?

    Zu Problem 2: Den Stopper sofort wieder hochgehen lassen, wenn der Initiator wieder frei ist. Dann wird ein zweites Bauteil sofort abgefangen und die Tür kann in Ruhe zugehen. Haben die Trays keinen Mindestabstand? Wenn die direkt aufeinander fahren, müßt Ihr wohl noch einen Separierer einbauen... Der Tür würde ich eine Laufzeitabschaltung als Sicherheit verpassen... Wenn sie 3s zum Schließen braucht, würde ich sie nach 5s abschalten und einen Alarm ausgeben.
    Schon mal erforscht, warum das zweite Teil nicht gestoppt wird?

    Das so ohne weitere Kenntnisse mal in die Tastatur ergossen... um mehr zu sagen, müßte man die Anlage und das Programm genauer kennen.

  3. Folgende 2 Benutzer sagen Danke zu JSEngineering für den nützlichen Beitrag:

    dg3mhj (11.02.2015),kapo666 (10.02.2015)

  4. #3
    dg3mhj ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    20.11.2014
    Beiträge
    3
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Habe folgende neue Erkentnisse gesammelt und es geht bis jetzt ab gestern 20:00 ohne Probleme
    ==== alter Zustand: Zuförderung der Trays in Automatik bis zu 2 Trays vor der Höhenprüstation = sporadisch Endschalter überfahren.

    Ich habe nun folgendes probiert,
    1. die Bestüchkung auf Hand um gestellt
    2. wenn 1 Tray im Umkauf ist = alles gut = momentaner Zustand

    Momentan alles okay 09:19 Uhr

    Ich habe keine Vermutung

  5. #4
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.710
    Danke
    398
    Erhielt 2.397 Danke für 1.997 Beiträge

    Standard

    Wenn du hier weiterkommen möchtest dann solltest du auf den Beitrag von JS sinnvoll eingehen.
    Aus meiner Sicht ist da alles Wesentliche gesagt.
    Wahrscheinlich hast du in deinem Programm weder eine Schrittkette (schrittweisen Ablauf) für diese Funktion noch ist ein Vor-Stopper installiert, der das verhindern könnte.

    Gruß
    Larry

  6. #5
    dg3mhj ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    20.11.2014
    Beiträge
    3
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    genau so werde ich es machen Danke noch ein mal

Ähnliche Themen

  1. Bandsteuerung - Siloanlage - Schrittketten
    Von josef-b im Forum CODESYS und IEC61131
    Antworten: 2
    Letzter Beitrag: 28.08.2014, 12:37
  2. Probleme mit OPC -> SPS Verbindung
    Von Homer-Jay im Forum Hochsprachen - OPC
    Antworten: 4
    Letzter Beitrag: 27.10.2011, 08:37
  3. Gute Bandsteuerung gesucht
    Von Bensen83 im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 07.03.2011, 06:15
  4. Probleme mit Phoenix-SPS
    Von the bang 2 im Forum PHOENIX CONTACT
    Antworten: 13
    Letzter Beitrag: 13.04.2007, 13:14
  5. B&R SPS mit EPROM probleme.
    Von JesperMP im Forum Sonstige Steuerungen
    Antworten: 3
    Letzter Beitrag: 01.06.2006, 20:56

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •