Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: Analogwert PT100 in 100U CPU103

  1. #1
    Registriert seit
    12.02.2015
    Beiträge
    3
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    wie viele melde ich mich weil ich ein Problem habe.

    Ich habe eine S5 100U CPU103 über eine CP541 mit einer S7 315er CPU gekoppelt.
    Jetzt möchte ich in der S5 mit einem PT100 auf eine 6ES5 464-8MF11 auf SP0 CH0 eine Temperatur messen, an die S7 übertragen und an einem TP angezeigt bekommen.
    Die Analogwertverarbeitung in der S7 mit PT100 auf 6ES7 331-7KF02-0AB0 funktioniert.
    Versucht habe ich das EW64 an die S7 zu übertragen um dann dort wie schon funktionierende Temperaturmessungen zu verarbeiten. Erfolglos
    Bei der Beobachtung der Bits in den zwei Wörtern konnte ich keinen Zusammenhang in der Wortbelegung bei der S5 Messung mit einer S7 Messung erkennen.
    Kennt einer die Bitbelegung in der S5 Welt und zum Vergleich auch in der S7 Welt.
    Laut Handbuch haben beide BG 12 Bit +VZ. Die S5 hat noch 3 Status Bit. In der S7 werden diese 3 Bit nicht benutzt.
    Ich versuche noch mit ein paar Festwiderständen der Bitfolge auf die Spur zu kommen. Mal schauen was ich rausfinde.
    Wenn einer eine Erklärung hat ist mir das natürlich auch recht.
    Zitieren Zitieren Analogwert PT100 in 100U CPU103  

  2. #2
    Registriert seit
    17.06.2010
    Ort
    nähe Memmingen
    Beiträge
    610
    Danke
    93
    Erhielt 116 Danke für 100 Beiträge

    Standard

    Ich hab aktuell die Unterlagen nicht zur Hand. Soweit ich noch weiß ist in der S5 115U der Analogwert auf
    Bit 3-15. D.h. das EW erst mal mit SRW3 um 3 Bit schieben. Der sich ergebende Wert ist dann 0-2048
    bzw. bei 4-20mA war es 512-2560 (hier 512 abziehen, dann passt es).
    Ob es in der 100U ebenso ist weiß ich nicht. Aber vielleicht hilft es Dir schon mal weiter.

    In der S7 sind die Werte auf 0-27648 normiert (bzw. C° x 10 bei Pt100).

    Bei negativen Werten (z.B. bei Spannungsmessung) geht der Wert dann entsprechend ins Minus.
    Hierbei in der S5 aufpassen, da mussten die drei verschobenen Bits auf die leeren, oberen Bits kopiert
    werden damit das Vorzeichen korrekt gebildet wird.

  3. #3
    Registriert seit
    13.04.2008
    Ort
    Großraum KA
    Beiträge
    963
    Danke
    52
    Erhielt 128 Danke für 112 Beiträge

    Standard

    Hier gibts von S5 an Handbüchern was das Herz begehrt http://www.es.fh-mannheim.de/sp/simatic/s5.htm

    peter(R)
    The difference between theory and practice in practice is bigger than
    the difference between theory and practice in theory.

  4. Folgender Benutzer sagt Danke zu peter(R) für den nützlichen Beitrag:

    Vulturef (14.02.2015)

  5. #4
    Vulturef ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    12.02.2015
    Beiträge
    3
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Schönen Dank,

    das verschieben hatte ich schon in einem anderen Beitrag gelesen.
    Wenn ich mir die Eingänge in der S5 ansehe verhalten die sich nicht wie die Eingänge in der S7
    Wir in der S5 ein anderes Format als in der S7 verwendet?

  6. #5
    Registriert seit
    17.06.2010
    Ort
    nähe Memmingen
    Beiträge
    610
    Danke
    93
    Erhielt 116 Danke für 100 Beiträge

    Standard

    Ja!



    1234567890

  7. #6
    Vulturef ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    12.02.2015
    Beiträge
    3
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich denke ich habs.

    In der S5 wir eine 12 Bit breite unipolare Dualzahl von 0-2048 im EW dargestellt.
    In der S7 wir eine 12 Bit breite bipolare Dualzahl im EW dargestellt.
    Die Eingangswörter können so nicht identisch sein.
    Das EW der S5 habe ich um drei Stellen verschoben und im FB der S7 eingelesen. Die unterschiedliche Darstellung konnte ich durch verändern
    des Normierungsbereich anpassen.

  8. #7
    Registriert seit
    17.06.2009
    Beiträge
    24
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    habe eine PT100 Karte über eine ET200U per DP an einer 300er hängen. Muß ich das EW auch so wie oben beschrieben bearbeiten ?
    Vielen Dank schon im voraus!

Ähnliche Themen

  1. S5-100U CPU103 an OP7
    Von Industrieservic im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 21.02.2007, 00:02
  2. S5-100u Cpu103 Hilfe!!!!
    Von Sören im Forum Simatic
    Antworten: 20
    Letzter Beitrag: 21.12.2006, 08:42
  3. Bezug von S5/100U-CPU103
    Von INST im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 26.09.2005, 15:07
  4. OP7 an S5-100U / CPU103
    Von INST im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 21.03.2005, 22:39
  5. Anschluß OP7 an S5-100U / CPU103
    Von Anonymous im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 28.02.2005, 15:54

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •