Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 10 von 10

Thema: TIA V13 - I-Device Kommunikation (315-2 PN/DP > IM 151-8 PN/DP)

  1. #1
    Registriert seit
    23.02.2015
    Beiträge
    3
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Guten Abend,

    ich habe folgendes Problem ich möchte über die I-Device zwischen einer CPU 315-2 PN/DP und zwei IM 151-8 PN/DP Daten austauschen. (jeweils 1 BYTE)

    Dafür habe ich jeweils in den IM den Transferbereich festgelegt (siehe Bild):

    http://www.bilder-upload.eu/show.php...1424711987.png

    Die Betriebsart wurde für die IM so festgelegt:

    http://www.bilder-upload.eu/show.php...1424712158.png

    Ich bekomme jedoch keine Kommunikation zu stande. Was muss geändert werden bzw. was ist eventuell falsch.

    Müssen die Daten mit dem SFC14/15 geschrieben bzw. gelesen werden. Oder können sie direkt beschrieben werden.

    Über eine Antwort würde ich mich sehr freuen. Evtl. sogar ein Beispiel Projekt
    IP Adressen:

    CPU: 192.168.1.10 / 255.255.255.0
    IM 1: CPU: 192.168.1.20 / 255.255.255.0
    IM 2: CPU: 192.168.1.30 / 255.255.255.0
    Zitieren Zitieren TIA V13 - I-Device Kommunikation (315-2 PN/DP > IM 151-8 PN/DP)  

  2. #2
    Registriert seit
    16.03.2006
    Ort
    Franken
    Beiträge
    3.797
    Danke
    30
    Erhielt 917 Danke für 798 Beiträge

    Standard

    Hi,

    auf die IO Adressen kannst du direkt zugreifen vom Programm aus.
    Sind die BF LED's aller beteiligten Geräte aus, oder leuchtet da was rot ?

    Gruß
    Christoph

  3. #3
    Zee1987 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    23.02.2015
    Beiträge
    3
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Alle BF LED´s sind aus, habe folgenden Fehler an den IM´s anstehen. Kann damit aber leider nichts anfangen. Wenn ich in der IM einen Eingang beschreibe z.B.

    U M77.5
    = I100.0

    Dann müsste doch in der CPU der Ausgang Q100.0 gesetzt werden. Oder versehe ich mit da?

    http://www.bilder-upload.eu/show.php...1424769164.png

    http://www.bilder-upload.eu/show.php...1424769253.png

    http://www.bilder-upload.eu/show.php...1424769282.png

  4. #4
    Registriert seit
    16.03.2006
    Ort
    Franken
    Beiträge
    3.797
    Danke
    30
    Erhielt 917 Danke für 798 Beiträge

    Standard

    Hi,

    einen Eingang schreiben? Das stelle ich mir gerade sehr schwierig vor.
    Vor allem weil der Eingang ja in der IM ist.

    Da ist es sinnvoller der Ausgang 100 zu schreiben damit der Eingang 100 auf der anderen Seite high wird.

    Die Bilder sind leider geplackt bei mir vom proxy, lade sie doch bitte hier im Forum als Anhang zum beitrag hoch.

    Gruß
    Christoph

  5. #5
    Zee1987 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    23.02.2015
    Beiträge
    3
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    So Fehler gestern Abend gefunden, wie Christoph auch schon angemerkt hat, habe ich es einfach falsch gesetzt. Musste natürlich der Ausgang in der IM gestetzt werden.

    Vielen Dank für die Antworten.

  6. #6
    Registriert seit
    29.05.2013
    Beiträge
    353
    Danke
    74
    Erhielt 3 Danke für 3 Beiträge

    Standard

    Hallo zusammen,

    zu diesem Thema hätte ich bitte auch eine Frage. Wie kann man im TIA V13 aus einer ET200S CPU ( IM151-8 PN/DP) ein I-Device machen?

    Gruß

  7. #7
    Registriert seit
    16.03.2006
    Ort
    Franken
    Beiträge
    3.797
    Danke
    30
    Erhielt 917 Danke für 798 Beiträge

    Standard

    Hi,

    in der Gerätesicht die PN Schnittstelle wählen und bei Eigensachaften unten dann bei Betriebsart "IO-Device" einstellen.

    Gruß
    Christoph

  8. Folgender Benutzer sagt Danke zu ChristophD für den nützlichen Beitrag:

    kuti (24.03.2015)

  9. #8
    Registriert seit
    29.05.2013
    Beiträge
    353
    Danke
    74
    Erhielt 3 Danke für 3 Beiträge

    Standard

    Ah, super danke.

  10. #9
    Registriert seit
    29.05.2013
    Beiträge
    353
    Danke
    74
    Erhielt 3 Danke für 3 Beiträge

    Standard

    Ach , sorry, was ich noch vergessen habe. Kann man aus diesem I-Device (also meine ET200S) eine GSD-Datei machen, weil ich diese ja an die PN-Schnittstelle des Masters anbringen muss, genau wie bei Step7? oder ist das hier im TIA anders?

  11. #10
    Registriert seit
    29.05.2013
    Beiträge
    353
    Danke
    74
    Erhielt 3 Danke für 3 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ist die Oberfläche von TIA klein ...

Ähnliche Themen

  1. Antworten: 5
    Letzter Beitrag: 23.01.2015, 14:30
  2. TIA Siemens S7 TIA V13 Basic <> TIA V13 Professional
    Von piksieben im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 05.11.2014, 19:23
  3. Antworten: 0
    Letzter Beitrag: 20.10.2014, 20:25
  4. Antworten: 1
    Letzter Beitrag: 07.10.2014, 08:25
  5. Step 7 Schnelle Kommunikation 315 2pn/dp <-> 315 2pn/dp I-Device???
    Von elmoklemme im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 10.12.2013, 17:24

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •